Analog Demodulation (R&S FSW-K7)
Contents
  • Welcome to the Analog Demodulation Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • I/Q Data Import and Export
  • How to Perform Measurements in the Analog Demodulation Application
  • Measurement Example: Demodulating an FM Signal
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands for Analog Demodulation Measurements
  • List of Commands
Top


Welcome to the Analog Demodulation Application

Analog Demodulation (R&S FSW-K7) > Welcome to the Analog Demodulation Application
Welcome to the Analog Demodulation Application

The R&S FSW-K7 AM/FM/PM measurement demodulator option converts the R&S FSW into an analog modulation analyzer for amplitude-, frequency- or phase-modulated signals. It measures not only characteristics of the useful modulation, but also factors such as residual FM or synchronous modulation.

The digital signal processing in the R&S FSW, used in the Spectrum application for digital IF filters, is also ideally suited for demodulating AM, FM, or PM signals. The firmware option R&S FSW-K7 provides the necessary measurement functions.

The R&S FSW Analog Demodulation application features:

  • AM, FM, and PM demodulation, with various result displays:
    – Modulation signal versus time
    – Spectrum of the modulation signal (FFT)
    – RF signal power versus time
    – Spectrum of the RF signal
  • Determining maximum, minimum and average or current values in parallel over a selected number of measurements
  • Maximum accuracy and temperature stability due to sampling (digitization) already at the IF and digital down-conversion to the baseband (I/Q)
  • Error-free AM to FM conversion and vice versa, without deviation errors, frequency response or frequency drift at DC coupling

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

(http://www2.rohde-schwarz.com/product/FSW.html).

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the Analog Demodulation Application
  • Understanding the Display Information


Starting the Analog Demodulation Application

Analog Demodulation (R&S FSW-K7) > Welcome to the Analog Demodulation Application > Starting the Analog Demodulation Application
Starting the Analog Demodulation Application

Analog Demodulation is a separate application on the R&S FSW.

To activate the Analog Demodulation application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Analog Demodulation" item.

    The R&S FSW opens a new measurement channel for the Analog Demodulation application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the Analog Demodulation "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

Analog Demodulation (R&S FSW-K7) > Welcome to the Analog Demodulation Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during an Analog Demodulation measurement. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information, depending on result display
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA/MSRT operating mode

In MSRA/MSRT operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA/MSRT operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Channel bar information

In the Analog Demodulation application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the Analog Demodulation application
Ref Level | Reference level
m.+el.Att | Mechanical and electronic RF attenuation
Offset | Reference level offset
AQT | Measurement time for data acquisition.
RBW | Resolution bandwidth
DBW | Demodulation bandwidth
Freq | Center frequency for the RF signal
Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the Analog Demodulation application
1 = Window number
2 = Modulation type
3 = Trace color
4 = Trace number
5 = Detector
6 = Trace mode
7 = Reference value (at the defined reference position)
8 = AF coupling (AC/DC), only in AF time domains, if applicable
9 = Results are selected for demodulation output
Diagram footer information

The diagram footer (beneath the diagram) contains the following information, depending on the evaluation:

RF Spectrum

CF: Center frequency of input signal

Sweep points

Span: measured span

RF Time domain

CF: Center frequency of input signal

Sweep points

Time per division

AF Spectrum

AF CF: center frequency of demodulated signal

Sweep points

AF Span: evaluated span

AF Time domain

CF: Center frequency of input signal

Sweep points

Time per division

For most modes, the number of sweep points shown in the display are indicated in the diagram footer. In zoom mode, the (rounded) number of currently displayed points are indicated.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Displays

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays
Measurements and Result Displays

The data that was measured by the R&S FSW can be evaluated using various different methods. In the Analog Demodulation application, up to six evaluation methods can be displayed simultaneously in separate windows. The results can be displayed as absolute deviations or relative to a reference value or level.

The abbreviation "AF" (for Audio Frequency) refers to the demodulated AM, FM or PM signal.

Basis for evaluation

All evaluations are based on the I/Q data set acquired during the measurement. The spectrum of the modulated signal to be evaluated is determined by the demodulation bandwidth. However, it can be restricted to a limited span ("AF Span") if only part of the signal is of interest. Furthermore, the time base for evaluations in the time domain can be restricted to analyze a smaller extract in more detail, see "Time Domain Zoom".

└ AM Time Domain
└ FM Time Domain
└ PM Time Domain
└ AM Spectrum
└ FM Spectrum
└ PM Spectrum
└ RF Time Domain
└ RF Spectrum
└ Result Summary
└ Marker Table
└ Marker Peak List


AM Time Domain

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > AM Time Domain
AM Time Domain

Displays the modulation depth of the demodulated AM signal (in %) versus time.

Remote command:

LAY:ADD? '1',RIGH,'XTIM:AM:REL'

(See LAYout:​ADD[:​WINDow]?)


FM Time Domain

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > FM Time Domain
FM Time Domain

Displays the frequency spectrum of the demodulated FM signal versus time.

Remote command:

LAY:ADD? '1',RIGH,'XTIM:FM'

(See LAYout:​ADD[:​WINDow]?)


PM Time Domain

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > PM Time Domain
PM Time Domain

Displays the phase deviations of the demodulated PM signal (in rad or °) versus time.

Remote command:

LAY:ADD? '1',RIGH,'XTIM:PM'

(See LAYout:​ADD[:​WINDow]?)


AM Spectrum

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > AM Spectrum
AM Spectrum

Displays the modulation depth of the demodulated AM signal (in % or dB) versus AF span. The spectrum is calculated from the demodulated AM signal in the time domain via FFT.

Remote command:

LAY:ADD? '1',RIGH,'XTIMe:AM:REL:AFSPectrum1'

(see LAYout:​ADD[:​WINDow]?)


FM Spectrum

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > FM Spectrum
FM Spectrum

Displays the frequency deviations of the demodulated FM signal (in Hz or dB) versus AF span. The spectrum is calculated from the demodulated AM signal in the time domain via FFT.

Remote command:

LAY:ADD? '1',RIGH,'XTIMe:FM:AFSPectrum1'

(see LAYout:​ADD[:​WINDow]?)


PM Spectrum

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > PM Spectrum
PM Spectrum

Displays the phase deviations of the demodulated PM signal (in rad, ° or dB) versus AF span. The spectrum is calculated from the demodulated AM signal in the time domain via FFT.

Remote command:

LAY:ADD? '1',RIGH,'XTIMe:PM:AFSPectrum1'

(see LAYout:​ADD[:​WINDow]?)


RF Time Domain

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > RF Time Domain
RF Time Domain

Displays the RF power of the input signal versus time. The level values represent the magnitude of the I/Q data set.

Remote command:

LAY:ADD? '1',RIGH,'XTIM:AM'

(see LAYout:​ADD[:​WINDow]?)


RF Spectrum

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > RF Spectrum
RF Spectrum

Displays the spectrum of the input signal. In contrast to the Spectrum application, the frequency values are determined using FFT from the recorded I/Q data set.

Remote command:

LAY:ADD? '1',RIGH,'XTIM:SPECTRUM'

(see LAYout:​ADD[:​WINDow]?)


Result Summary

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > Result Summary
Result Summary

The result summary displays the results of the demodulation functions for all windows in a table.

For each demodulation, the following information is provided:

Result summary description
Label | Description
+Peak | Positive peak (maximum)
-Peak | Negative peak (minimum)
+/-Peak/2 | Average of positive and negative peaks
RMS | Root Mean Square value
Mod Freq | Modulation frequency
SINAD | Signal-to-noise-and-distortion (Calculated only if AF Spectrum is displayed) Measures the ratio of the total power to the power of noise and harmonic distortions. The noise and harmonic power is calculated inside the AF spectrum span. The DC offset is removed before the calculation.
THD | Total harmonic distortion The ratio of the harmonics to the fundamental and harmonics. All harmonics inside the AF spectrum span are considered up to the tenth harmonic. (Calculated only if AF Spectrum is displayed)

In addition, the following general information for the input signal is provided:

  • Carrier Power: the power of the carrier without modulation
  • Carrier Offset: the deviation of the calculated carrier frequency to the ideal carrier frequency
  • Modulation Depth (AM or RF Time Domain only): the difference in amplitude the carrier signal is modulated with
Remote command:

LAY:ADD? '1',RIGH,RSUM, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate:​MARKer:​FUNCtion:​ADEMod:​PM[:​RESult<t>]?


Marker Table

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

Analog Demodulation (R&S FSW-K7) > Measurements and Result Displays > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

You can define search and sort criteria to influence the results of the analysis (see "Marker Search Settings").

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

Analog Demodulation (R&S FSW-K7) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in Analog Demodulation measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Demodulation Process - Circuit Description
  • Demodulation Bandwidth
  • Sample Rate, Measurement Time and Trigger Offset
  • AF Triggers
  • AF Filters
  • Time Domain Zoom
  • Receiving Data Input and Providing Data Output
  • Analog Demodulation in MSRA/MSRT Operating Mode


Demodulation Process - Circuit Description

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Demodulation Process - Circuit Description
Demodulation Process - Circuit Description

The software demodulator runs on the main processor of the analyzer. The demodulation process is shown in figure "Block diagram of software demodulator". All calculations are performed simultaneously with the same I/Q data set. Magnitude (= amplitude) and phase of the complex I/Q pairs are determined. The frequency result is obtained from the differential phase.

For details on general I/Q data processing in the R&S FSW, refer to "Reference: Format Description for I/Q Data Files" .

Block diagram of software demodulator

The AM DC, FM DC and PM DC raw data of the demodulators is fed into the "Trace Arithmetic" block that combines consecutive data sets. Possible trace modes are: Clear Write, Max Hold, Min Hold and Average. The output data of the "Trace Arithmetic" block can be read via remote control ([SENS:]ADEM:<evaluation>:RES?, see [SENSe:​]ADEMod:​AM[:​ABSolute][:​TDOMain]:​RESult?.

The collected measured values are evaluated by the selected detector. The result is displayed on the screen and can be read out via remote control.

In addition, important parameters are calculated:

  • A counter determines the modulation frequency for AM, FM, and PM.
  • average power = carrier power (RF power)
  • average frequency = carrier frequency offset (FM)
  • The modulation depth or the frequency or phase deviation; the deviations are determined from the trace data

AC coupling is possible with FM and PM display.


Demodulation Bandwidth

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Demodulation Bandwidth
Demodulation Bandwidth

The demodulation bandwidth determines the span of the signal that is demodulated. It is not the 3 dB bandwidth of the filter but the useful bandwidth which is distortion-free with regard to phase and amplitude.

Therefore the following formulas apply:

  • AM: demodulation bandwidth ≥ 2 x modulation frequency
  • FM: demodulation bandwidth ≥ 2 x (frequency deviation + modulation frequency)
  • PM: demodulation bandwidth ≥ 2 x modulation frequency x (1 + phase deviation)

If the center frequency of the analyzer is not set exactly to the signal frequency, the demodulation bandwidth must be increased by the carrier offset, in addition to the requirement described above. This also applies if FM or PM AC coupling has been selected.

In general, the demodulation bandwidth should be as narrow as possible to improve the S/N ratio. The residual FM caused by noise floor and phase noise increases dramatically with the bandwidth, especially with FM.

For help on determining the adequate demodulation bandwidth see "Determining the demodulation bandwidth". A practical example is described in "Measurement Example: Demodulating an FM Signal".


Sample Rate, Measurement Time and Trigger Offset

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Sample Rate, Measurement Time and Trigger Offset
Sample Rate, Measurement Time and Trigger Offset

The maximum demodulation bandwidths that can be obtained during the measurement, depending on the sample rate, are listed in the tables below for different demodulation filter types. The allowed value range of the measurement time and trigger offset depends on the selected demodulation bandwidth and demodulation filter. If the AF filter or the AF trigger are not active, the measurement time increases by 20 %.

A maximum of 24 million samples can now be captured, assuming sufficient memory is available; thus the new maximum measurement time has also increased, according to the following formula:

Meas.timemax = Sample countmax / sample rate

The minimum trigger offset is (-Meas.timemax)

Sample Rate, Measurement Time and Trigger Offset using a flat demodulation filter
Demod. bandwidth | Sample rate | Measurement time |  | Trigger offset
 |  | Min. | Max. | Min. | Max.
500 MHz6) | 600 MHz | 1.66 ns | 40 ms | -40 ms | 0.3495 s
320 MHz5) | 400 MHz | 2.5 ns | 60 ms | -60 ms | 0.5243 s
160 MHz4) | 200 MHz | 5 ns | 120 ms | -120 ms | 1.0486 s
80 MHz3) | 128 MHz | 7.8125 ns | 187.5 ms | -187.5 ms | 1.6384 s
40 MHz2) | 64 MHz | 15.625 ns | 375 ms | -375 ms | 3.2768 s
28 MHz1) | 64 MHz | 15.625 ns | 375 ms | -375 ms | 3.2768 s
18 MHz | 32 MHz | 31.25 ns | 750 ms | -750 ms | 6.5536 s
10 MHz | 32 MHz | 31.25 ns | 750 ms | -750 ms | 6.5536 s
8 MHz | 16 MHz | 62.5 ns | 1.5 ms | -1.5 ms | 13.1072 s
5 MHz | 8 MHz | 125 ns | 3 ms | -3 ms | 26.2144 s
3 MHz | 4 MHz | 250 ns | 6 ms | -6 ms | 52.4288 s
1.6 MHz | 2 MHz | 500 ns | 12 ms | -12 ms | 104.8576 s
800 kHz | 1 MHz | 1 µs | 24 ms | -24 ms | 209.7152 s
400 kHz | 500 kHz | 2 µs | 48 ms | -48 ms | 419.4304 s
200 kHz | 250 kHz | 4 µs | 96 s | -96 s | 838.8608 s
100 kHz | 125 kHz | 8 µs | 192 s | -192 s | 1677.7216 s
50 kHz | 62.5 kHz | 16 µs | 384 s | -384 s | 3355.4432 s
25 kHz | 31.25 kHz | 32 µs | 768 s | -768 s | 6710.8864 s
12.5 kHz | 15.625 kHz | 64 µs | 1536 s | -1536 s | 13421.7728 s
6.4 kHz | 7.8125 kHz | 128 µs | 3072 s | -3072 s | 26843.5456 s
3.2 kHz | 3.90625 kHz | 256 µs | 6144 s | -6144 s | 53687.0912 s
1.6 kHz | 1.953125 kHz | 512 µs | 12288 s | -12288 s | 107374.1824 s
800 Hz | 976.5625 Hz | 1.024 ms | 24576 s | -24576 s | 214748.3648 s
400 Hz | 488.28125 Hz | 2.048 ms | 49152 s | -49152 s | 429496.7296 s
200 Hz | 244.140625 Hz | 4.096 ms | 98304 s | -98304 s | 858993.4592 s
100 Hz | 122.0703125 Hz | 8.192 ms | 196608 s | -196608 s | 1717986.918 s
1) only available with option B28 2) only available with option B40 3) only available with option B80 4) only available with option B160 5) only available with option B320 6) only available with option B500
Sample Rate, Measurement Time and Trigger Offset using a Gaussian demodulation filter
Demod. bandwidth | Sample rate | Measurement time |  | Trigger offset
 |  | Min. | Max. | Min. | Max.
160 MHz*5) | 640 MHz | 1.5625 ns | 37.5 ms | -37.5 ms | 0.32768 s
80 MHz*4) | 320 MHz | 3.125 ns | 75 ms | -75 ms | 0.65536 s
40 MHz*4) | 160 MHz | 6.25 ns | 150 ms | -150 ms | 1.310719993 s
28 MHz*2) | 112 MHz | 8.929 ns | 214.286 ms | -214.286 ms | 1.872457134 s
18 MHz*2) | 72 MHz | 13.88 ns | 333.333 ms | -333.333 ms | 2.912711097 s
10 MHz | 40 MHz | 25 ns | 600 ms | -600 ms | 5,242879975 s
8 MHz | 32 MHz | 31.25 ns | 750 ms | -750 ms | 6.553599969 s
5 MHz | 12 MHz | 83.33 ns | 2 s | -2 s | 10,48575995 s
3 MHz | 10.666 MHz | 93.75 ns | 2.25 s | -2.25 s | 17,47626667 s
1.6 MHz | 6.4 MHz | 156.25 ns | 3.75 s | -3.75 s | 32.76799984 s
800 kHz | 3.2 MHz | 312.5 ns | 7.5 s | -7.5 s | 65.53599969 s
400 kHz | 1.6 MHz | 625 ns | 15 s | -15 s | 131.0719994 s
200 kHz | 800 kHz | 1.25 us | 30 s | -30 s | 262.1439988 s
100 kHz | 400 kHz | 2.5 us | 60 s | -60 s | 524.2879975 s
50 kHz | 200 kHz | 5 us | 120 s | -120 s | 1048.575995 s
25 kHz | 100 kHz | 10 us | 240 s | -240 s | 2097.15199 s
12.5 kHz | 50 kHz | 20 us | 480 s | -480 s | 4194.30398 s
6.4 kHz | 25.6 kHz | 39.0625 us | 937.5 s | -937.5 s | 8191.999961 s
3.2 kHz | 12.8 kHz | 78.125 us | 1875 s | -1875 s | 16383.99992 s
1.6 kHz | 6.4 kHz | 156.25 us | 3750 s | -3750 s | 32767.99984 s
800 Hz | 3.2 kHz | 312.5 us | 7500 s | -7500 s | 65535.99969 s
400 Hz | 1.6 kHz | 625 us | 15000 s | -15000 s | 131071.9994 s
200 Hz | 800 Hz | 1.25 ms | 30000 s | -30000 s | 262143.9988 s
100 Hz | 400 Hz | 2.5 ms | 60000 s | -60000 s | 524287.9975 s
* Gaussian filter curve is limited by I/Q bandwidth 2) only available with option B40 4) only available with option B160 or higher 5) only available with option B320 (not B500)
Large numbers of samples

Principally, the R&S FSW can handle up to 1.6 million samples. However, when 480 001 samples are exceeded, all traces that are not currently being displayed in a window are deactivated to improve performance. The traces can only be activated again when the samples are reduced.

Effects of measurement time on the stability of measurement results

Despite amplitude and frequency modulation, the display of carrier power and carrier frequency offset is stable.

This is achieved by a digital filter which sufficiently suppresses the modulation, provided, however, that the measurement time is ≥ 3 x 1 / modulation frequency, i.e. that at least three periods of the AF signal are recorded.

The mean carrier power for calculating the AM is also calculated with a digital filter that returns stable results after a measurement time of ≥ 3 x 1 / modulation frequency, i.e. at least three cycles of the AF signal must be recorded before a stable AM can be shown.


AF Triggers

Analog Demodulation (R&S FSW-K7) > Measurement Basics > AF Triggers
AF Triggers

The Analog Demodulation option allows triggering to the demodulated signal. The display is stable if a minimum of five modulation periods are within the recording time.

Triggering is always DC-coupled. Therefore triggering is possible directly to the point where a specific carrier level, phase or frequency is exceeded or not attained.


AF Filters

Analog Demodulation (R&S FSW-K7) > Measurement Basics > AF Filters
AF Filters

Additional filters applied after demodulation help filter out unwanted signals, or correct pre-emphasized input signals. A CCITT filter allows you to evaluate the signal by simulating the characteristics of human hearing.


Time Domain Zoom

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Time Domain Zoom
Time Domain Zoom

For evaluations in the time domain, the demodulated data for a particular time span can be extracted and displayed in more detail using the "Time Domain Zoom" function. This is useful if the measurement time is very large and thus each sweep point represents a large time span. The time domain zoom function distributes the available sweep points only among the time span defined by the zoom area length. The time span displayed per division of the diagram is decreased. Thus, the display of the extracted time span becomes more precise.

FM time domain measurement with a very long measurement time
FM time domain measurement with time domain zoom

The time domain zoom area affects not only the diagram display, but the entire evaluation for the current window.

In contrast to the time domain zoom, the graphical zoom is available for all diagram evaluations. However, the graphical zoom is useful only if more measured values than trace points are available. The (time) span represented by each measurement point remains the same.

Time domain zoom | Graphical zoom


Receiving Data Input and Providing Data Output

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output
Receiving Data Input and Providing Data Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Contents
  • RF Input Protection
  • RF Input from the Analog Baseband Connector
  • Using Probes
  • Basics on External Generator Control
  • Input from Noise Sources
  • Receiving and Providing Trigger Signals


RF Input Protection

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > RF Input Protection
RF Input Protection

The RF input connector of the R&S FSW must be protected against signal levels that exceed the ranges specified in the data sheet. Therefore, the R&S FSW is equipped with an overload protection mechanism. This mechanism becomes active as soon as the power at the input mixer exceeds the specified limit. It ensures that the connection between RF input and input mixer is cut off.

When the overload protection is activated, an error message is displayed in the status bar ("INPUT OVLD"), and a message box informs you that the RF Input was disconnected. Furthermore, a status bit (bit 3) in the STAT:QUES:POW status register is set. In this case you must decrease the level at the RF input connector and then close the message box. Then measurement is possible again. Reactivating the RF input is also possible via the remote command INPut:​ATTenuation:​PROTection:​RESet.


RF Input from the Analog Baseband Connector

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > RF Input from the Analog Baseband Connector
RF Input from the Analog Baseband Connector

RF input can not only be taken from the RF INPUT connector on the front panel of the R&S FSW. If the optional Analog Baseband Interface (R&S FSW-B71) is installed and active for input, an RF signal can be input at the BASEBAND INPUT I connector and redirected from there to the RF input path. A transducer is activated to compensate for the additional path of the redirected signal. The signal is then processed as usual in the frequency and time domain as for any other RF input.

This is useful, for example, to perform frequency sweep measurements with (single-ended or differential) active probes, which can also be connected to the BASEBAND INPUT I connector.

Frequency sweep measurements on probe input

You can perform RF measurements (measurements in the time or frequency domain) by connecting a probe to the BASEBAND INPUT I connector and switching the input source to this connector in the RF input configuration (see "Input Connector").

The probe's attenuation is compensated automatically by the R&S FSW using a transducer named "Probe on Baseband Input I". (The probe can only be connected on I, as only input at the I connector can be redirected to the RF path). A comment is assigned that includes the type, name and serial number of the detected probe. The transducer is deleted as soon as the probe is disconnected.

For details on transducers see "Basics on Transducer Factors" .

For more information on using probes for input see "Using Probes".


Using Probes

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Using Probes
Using Probes

As an alternative means of input to the R&S FSW, active probes from Rohde&Schwarz can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband Interface (option R&S FSW-B71) is installed. These probes allow you to perform voltage measurements very flexibly and precisely on all sorts of devices to be tested, without interfering with the signal.

Connecting probes

Probes are automatically detected when you plug them into the upper BASEBAND INPUT connectors on the front panel of the R&S FSW. The detected information on the probe is displayed in the "Probes" tab of the "Input" dialog box, individually for each connector.

Single-ended and differential probes

Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Input Configuration" setting for the "Analog Baseband" input source must be set to "Single-ended" for all probes (see "Input configuration").

Availability of probe input

Analog baseband input from connected probes can only be analyzed in applications that support I/Q data processing and the Analog Baseband Interface (R&S FSW-B71), such as the I/Q Analyzer, the Analog Demodulation application, or one of the optional applications.

Frequency sweep measurements with probes

Probes can also be used as an alternative method of providing RF input to the R&S FSW. In this case, the probe must be connected to the BASEBAND INPUT I connector, and the input is redirected to the RF input path (see "RF Input from the Analog Baseband Connector"). As opposed to common RF input processing, a transducer is activated before the common process to compensate for the additional path of the redirected signal. Probe signals that are redirected to the RF input path can also be analyzed in the Spectrum application of the R&S FSW base unit. Then you can perform RF measurements (measurements in the time or frequency domain) on the input from a probe.

Microbutton action

You can define an action to be performed by the R&S FSW when the probe's microbutton (if available) is pressed. Currently, a single data acquisition via the probe can be performed simply by pressing the microbutton.

Impedance and attenuation

The measured signal from the probe is attenuated internally by the probe's specific attenuation. For probe signals that are redirected to the RF path, the attenuation is compensated using a transducer (see "Frequency sweep measurements on probe input"). The reference level is adjusted automatically.

For analog baseband input, the attenuation is compensated without a transducer. In this case, higher levels are available for the full scale level.

A fixed impedance of 50 Ω is used for all probes to convert voltage values to power levels.


Basics on External Generator Control

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control
Basics on External Generator Control

Some background knowledge on basic terms and principles used for external generator control is provided here for a better understanding of the required configuration settings.

External generator control is only available in the Spectrum, I/Q Analyzer, Analog Demodulation and Noise Figure applications.

Contents
  • External Generator Connections
  • Overview of Generators Supported by the R&S FSW-B10 Option
  • Generator Setup Files
  • Calibration Mechanism
  • Normalization
  • Reference Trace, Reference Line and Reference Level
  • Coupling the Frequencies
  • Displayed Information and Errors


External Generator Connections

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > External Generator Connections
External Generator Connections

The external generator is controlled either via a LAN connection or via the EXT. GEN. CONTROL GPIB interface of the R&S FSW supplied with the R&S FSW-B10 option.

For more information on configuring interfaces see "Remote Control Interfaces and Protocols" .

TTL synchronization

In addition, TTL synchronization can be used with some Rohde & Schwarz generators connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator. For details see "Coupling the Frequencies".

In figure " TTL connection for an SMU generator" the TTL connection is illustrated using an SMU generator, for example.

TTL connection for an SMU generator

The external generator can be used to calibrate the data source by performing either transmission or reflection measurements.

Transmission Measurement

This measurement yields the transmission characteristics of a two-port network. The external generator is used as a signal source. It is connected to the input connector of the DUT. The input of the R&S FSW is fed from the output of the DUT. A calibration can be carried out to compensate for the effects of the test setup (e.g. frequency response of connecting cables).

Test setup for transmission measurement
Reflection Measurement

Scalar reflection measurements can be carried out using a reflection-coefficient measurement bridge.

Test setup for reflection measurement
Generated signal input

In order to use the functions of the external generator, an appropriate generator must be connected and configured correctly. In particular, the generator output must be connected to the RF input of the R&S FSW.

External reference frequency

In order to enhance measurement accuracy, a common reference frequency should be used for both the R&S FSW and the generator. If no independent 10 MHz reference frequency is available, it is recommended that you connect the reference output of the generator with the reference input of the R&S FSW and that you enable usage of the external reference on the R&S FSW via "SETUP" > "Reference" > "External Reference".

For more information on external references see "Reference Frequency Input" .

Connection errors

If no external generator is connected, if the connection address is not correct, or the generator is not ready for operation, an error message is displayed (e.g."Ext. Generator TCPIP Handshake Error!", see "Displayed Information and Errors").


Overview of Generators Supported by the R&S FSW-B10 Option

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Overview of Generators Supported by the R&S FSW-B10 Option
Overview of Generators Supported by the R&S FSW-B10 Option
Generator type | TTL support | Generator type | TTL support
SGS100A12 | X | SMP02 | X
SMA01A 1) | X | SMP03 | X
SMA100A3 | X | SMP04 | X
SMA100A6 | X | SMP22 | X
SMB100A1 | X | SMR20 | -
SMB100A12 | X | SMR20B11 3) | X
SMB100A2 | X | SMR27 | X
SMB100A20 | X | SMR27B11 3) | X
SMB100A3 | X | SMR30 | X
SMB100A40 | X | SMR30B11 3) | X
SMBV100A3 | X | SMR40 | X
SMBV100A6 | X | SMR40B11 3) | X
SMC100A1 | - | SMR50 | X
SMC100A3 | - | SMR50B11 3) | X
SME02 | X | SMR60 | X
SME03 | X | SMR60B11 3) | X
SME06 | X | SMT02 | -
SMF100A | X | SMT03 | -
SMF22 | X | SMT06 | -
SMF22B2 | X | SMU02 | X
SMF43 | X | SMU02B31 2) | X
SMF43B2 | X | SMU03 2) | X
SMG | - | SMU03B31 2) | X
SMGL | - | SMU04 2) | X
SMGU | - | SMU04B31 2) | X
SMH | - | SMU06 2) | X
SMHU | - | SMU06B31 2) | X
SMIQ02 | X | SMV03 | -
SMIQ02B | X | SMW03 | -
SMIQ02E | - | SMW06 | -
SMIQ03 | X | SMX | -
SMIQ03B | X | SMY01 | -
SMIQ03E | - | SMY02 | -
SMIQ04B | X | HP8254A | -
SMIQ06B | X | HP8257D | -
SMJ03 | X | HP8340A | -
SMJ06 | X | HP8648 | -
SML01 | - | HP ESG-A Series 1000A, 2000A, 3000A, 4000A | -
SML02 | - | HP ESG B Sereies | -
SML03 | - | HP ESG-D SERIES E4432B | -
1) Requires firmware version V2.10.x or higher 2) Requires firmware version V1.10.x or higher 3) Requires the option SMR-B11


Generator Setup Files

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Generator Setup Files
Generator Setup Files

For each signal generator type to be controlled by the R&S FSW a generator setup file must be configured and stored on the R&S FSW. The setup file defines the frequency and power ranges supported by the generator, as well as information required for communication. For the signal generators listed in "Overview of Generators Supported by the R&S FSW-B10 Option", default setup files are provided. If necessary, these files can be edited or duplicated for varying measurement setups or other instruments.

The existing setup files can be displayed in an editor in read-only mode directly from the "External Generator" configuration dialog box. From there, they can be edited and stored under a different name, and are then available on the R&S FSW.

(For details see "To define a new generator setup file" ).


Calibration Mechanism

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Calibration Mechanism
Calibration Mechanism

A common measurement setup includes a signal generator, a device under test (DUT), and a signal and spectrum analyzer. Therefore, it is useful to measure the attenuation or gain caused by the cables and connectors from the signal generator and the signal analyzer in advance. The known level offsets can then be removed from the measurement results in order to obtain accurate information on the DUT.

Calculating the difference between the currently measured power and a reference trace is referred to as calibration. Thus, the measurement results from the controlled external generator - including the inherent distortions - can be used as a reference trace to calibrate the measurement setup.

The inherent frequency and power level distortions can be determined by connecting the R&S FSW to the signal generator. The R&S FSW sends a predefined list of frequencies to the signal generator (see also "Coupling the Frequencies"). The signal generator then sends a signal with the specified level at each frequency in the predefined list. The R&S FSW measures the signal and determines the level offsets to the expected values.

Saving calibration results

A reference dataset for the calibration results is stored internally as a table of value pairs (frequency/level), one for each sweep point. The measured offsets can then be used as calibration factors for subsequent measurement results.

The calibration can be performed using either transmission or reflection measurements. The selected type of measurement used to determine the reference trace is included in the reference dataset.


Normalization

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Normalization
Normalization

Once the measurement setup has been calibrated and the reference trace is available, subsequent measurement results can be corrected according to the calibration factors, if necessary. This is done by subtracting the reference trace from the measurement results. This process is referred to as normalization and can be activated or deactivated as required. If normalization is activated, "NOR" is displayed in the channel bar, next to the indication that an external generator is being used ("Ext.Gen").The normalized trace from the calibration sweep is a constant 0 dB line, as <calibration trace> - <reference trace> = 0.

As long as the same settings are used for measurement as for calibration, the normalized measurement results should not contain any inherent frequency or power distortions. Thus, the measured DUT values are very accurate.

Approximate normalization

As soon as any of the calibration measurement settings are changed, the stored reference trace will no longer be identical to the new measurement results. However, if the measurement settings do not deviate too much, the measurement results can still be normalized approximately using the stored reference trace. This is indicated by the "APX" label in the channel bar (instead of "NOR").

This is the case if one or more of the following values deviate from the calibration settings:
  • coupling (RBW, VBW, SWT)
  • reference level, RF attenuation
  • start or stop frequency
  • output level of external generator
  • detector (max. peak, min. peak, sample, etc.)
  • frequency deviation at a maximum of 1001 points within the set sweep limits (corresponds to a doubling of the span)

Differences in level settings between the reference trace and the current instrument settings are taken into account automatically. If the span is reduced, a linear interpolation of the intermediate values is applied. If the span increases, the values at the left or right border of the reference dataset are extrapolated to the current start or stop frequency, i.e. the reference dataset is extended by constant values.

Thus, the instrument settings can be changed in a wide area without giving up normalization. This reduces the necessity to carry out a new normalization to a minimum.

If approximation becomes too poor, however, normalization is aborted and an error message is displayed (see "Displayed Information and Errors").

The normalized trace in the display

The normalized reference trace is also displayed in the spectrum diagram, by default at the top of the diagram (= 100% of the window height). It is indicated by a red line labeled "NOR", followed by the current reference value. However, it can be shifted vertically to reflect an attenuation or gain caused by the measured DUT (see also "Shifting the reference line (and normalized trace)").

Restoring the calibration settings

If the measurement settings no longer match the instrument settings with which the calibration was performed (indicated by the "APX" or no label next to "Ext.TG" in the channel bar), you can restore the calibration settings, which are stored with the reference dataset on the R&S FSW.

Storing the normalized reference trace as a transducer factor

The (inverse) normalized reference trace can also be stored as a transducer factor for use in other R&S FSW applications that do not support external generator control. The normalized trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between the start and stop frequency.

This is useful, for example, to determine the effects of a particular device component and then remove these effects from a subsequent measurement which includes this component.

For an example see "Coupling the Frequencies".

Note that the normalized measurement data is stored, not the original reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).


Reference Trace, Reference Line and Reference Level

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Reference Trace, Reference Line and Reference Level
Reference Trace, Reference Line and Reference Level
Reference trace

The calibration results are stored internally on the R&S FSW as a reference trace. For each measured sweep point the offset to the expected values is determined. If normalization is activated, the offsets in the reference trace are removed from the current measurement results to compensate for the inherent distortions.

Reference line

The reference line is defined by the "Reference Value" and "Reference Position" in the "External Generator" > "Source Calibration" settings. It is similar to the "Reference Level" defined in the "Amplitude" settings. However, as opposed to the reference level, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The reference line determines the range and the scaling of the y-axis, just as the reference level does.

The normalized reference trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. By default, the reference line is displayed at the top of the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Shifting the reference line (and normalized trace)

You can shift the reference line - and thus the normalized trace - in the result display by changing the "Reference Position" or the "Reference Value".

If the DUT inserts a gain or an attenuation in the measurement, this effect can be reflected in the result display on the R&S FSW. To reflect a power offset in the measurement trace, change the "Reference Value".


Coupling the Frequencies

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Coupling the Frequencies
Coupling the Frequencies

As described in "Normalization", normalized measurement results are very accurate as long as the same settings are used as for calibration. Although approximate normalization is possible, it is important to consider the required frequencies for calibration in advance. The frequencies and levels supported by the connected signal generator are provided for reference with the interface configuration.

Two different methods are available to define the frequencies for calibration, that is to couple the frequencies of the R&S FSW with those of the signal generator:

  • Manual coupling: a single frequency is defined
  • Automatic coupling: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
Automatic coupling

If automatic coupling is used, the output frequency of the generator (source frequency) is calculated as follows:

Output frequency of the generator

where:

FGenerator = output frequency of the generator

FAnalyzer = current frequency at the RF input of the R&S FSW

Numerator = multiplication factor for the current analyzer frequency

Denominator = division factor for the current analyzer frequency

FOffset = frequency offset for the current analyzer frequency, for example for frequency-converting measurements or harmonics measurements

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets other than 0 Hz are indicated by the "FRQ" label in the channel bar (see also "Displayed Information and Errors").

Swept frequency range

The FAnalyzer values for the calibration sweep start with the start frequency and end with the stop frequency defined in the "Frequency" settings of the R&S FSW. The resulting output frequencies ("Result Frequency Start" and "Result Frequency Stop") are displayed in the "External Generator" > "Measurement Configuration" for reference.

If the resulting frequency range exeeds the allowed ranges of the signal generator, an error message is displayed (see "Displayed Information and Errors") and the "Result Frequency Start" and "Result Frequency Stop" values are corrected to comply with the range limits.

The calibration sweep nevertheless covers the entire span defined by the R&S FSW; however, no input is received from the generator outside the generator's defined limits.

TTL synchronization

Some Rohde & Schwarz signal generators support TTL synchronization when connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

When pure GPIB connections are used between the R&S FSW and the signal generator, the R&S FSW sets the generator frequency for each frequency point individually via GPIB, and only when the setting procedure is finished, the R&S FSW can measure the next sweep point.

For generators with a TTL interface, the R&S FSW sends a list of the frequencies to be set to the generator before the beginning of the first sweep. Then the R&S FSW starts the sweep and the next frequency point is selected by both the R&S FSW and the generator using the TTL handshake line "TRIGGER". The R&S FSW can only measure a value when the generator signals the end of the setting procedure via the "BLANK" signal.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

Reverse sweep

The frequency offset for automatic coupling can be used to sweep in the reverse direction. To do so, define a negative offset in the external generator measurement configuration. (Note that the frequency is defined as the unsigned value of the equation, thus a negative frequency is not possible.)

Example: Example for reverse sweep

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -300 MHz

Numerator = Denominator = 1

→FGeneratorStart = 200 MHz

→FGeneratorStop = 100 MHz

If the offset is adjusted so that the sweep of the generator crosses the minimum generator frequency, a message is displayed in the status bar ("Reverse Sweep via min. Ext. Generator Frequency!").

Example: Example for reverse sweep via minimum frequency

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -150 MHz

Fmin = 20 MHz

Numerator = Denominator = 1

→FGeneratorStart = 50 MHz

→FGeneratorStop = 50 MHz via Fmin


Displayed Information and Errors

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on External Generator Control > Displayed Information and Errors
Displayed Information and Errors
Channel bar

If external generator control is active, some additional information is displayed in the channel bar.

Label | Description
EXT TG: <source power> | External generator active; signal sent with <source power> level
LVL | Power Offset (see "Source Offset"
FRQ | Frequency Offset (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"
NOR | Normalization on; No difference between reference setting and measurement
APX (approximation) | Normalization on; Deviation from the reference setting occurs
- | Aborted normalization or no calibration performed yet
Error and status messages

The following status and error messages may occur during external generator control.

Message | Description
"Ext. Generator GPIB Handshake Error!" / "Ext. Generator TCPIP Handshake Error!" / "Ext. Generator TTL Handshake Error!" | Connection to the generator is not possible, e.g. due to a cable damage or loose connection or wrong address.
"Ext. Generator Limits Exceeded!" | The allowed frequency or power ranges for the generator were exceeded.
"Reverse Sweep via min. Ext. Generator Frequency!" | Reverse sweep is performed; frequencies are reduced to the minimum frequency, then increased again; see " Reverse sweep"
"Ext. Generator File Syntax Error!" | Syntax error in the generator setup file (see "Generator Setup Files"
"Ext. Generator Command Error!" | Missing or wrong command in the generator setup file (see "Generator Setup Files"
"Ext. Generator Visa Error!!" | Error with Visa driver provided with installation (very unlikely)
Overloading

At a reference level of -10 dBm and at a external generator output level of the same value, the R&S FSW operates without overrange reserve. That means the R&S FSW is in danger of being overloaded if a signal is applied whose amplitude is higher than the reference line. In this case, either the message "RF OVLD" for overload or "IF OVLD" for exceeded display range (clipping of the trace at the upper diagram border = overrange) is displayed in the status line.

Overloading can be avoided as follows:
  • Reducing the output level of the external generator ("Source Power" in "External Generator > Measurement Configuration")
  • Increasing the reference level ("Reference Level" in the "Amplitude" menu)


Input from Noise Sources

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Input from Noise Sources
Input from Noise Sources

The R&S FSW provides a connector (NOISE SOURCE CONTROL) with a voltage supply for an external noise source. By switching the supply voltage for an external noise source on or off in the firmware, you can activate or deactive the device as required.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of an amplifier.

In this case, you can first connect an external noise source (whose noise power level is known in advance) to the R&S FSW and measure the total noise power. From this value you can determine the noise power of the R&S FSW. Then when you measure the power level of the actual DUT, you can deduct the known noise level from the total power to obtain the power level of the DUT.

The noise source is controlled in the "Output" settings, see "Noise Source"


Receiving and Providing Trigger Signals

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Receiving Data Input and Providing Data Output > Receiving and Providing Trigger Signals
Receiving and Providing Trigger Signals

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the R&S FSW can use a signal from an external reference as a trigger to capture data. Alternatively, the internal trigger signal used by the R&S FSW can be output for use by other connected devices. Using the same trigger on several devices is useful to synchronize the transmitted and received signals within a measurement.

For details on the connectors see the R&S FSW "Getting Started" manual.

External trigger as input

If the trigger signal for the R&S FSW is provided by an external reference, the reference signal source must be connected to the R&S FSW and the trigger source must be defined as "External" on the R&S FSW.

Trigger output

The R&S FSW can provide output to another device either to pass on the internal trigger signal, or to indicate that the R&S FSW itself is ready to trigger.

The trigger signal can be output by the R&S FSW automatically, or manually by the user. If it is provided automatically, a high signal is output when the R&S FSW has triggered due to a sweep start ("Device Triggered"), or when the R&S FSW is ready to receive a trigger signal after a sweep start ("Trigger Armed").

Manual triggering

If the trigger output signal is initiated manually, the length and level (high/low) of the trigger pulse is also user-definable. Note, however, that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is provided.

Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .


Analog Demodulation in MSRA/MSRT Operating Mode

Analog Demodulation (R&S FSW-K7) > Measurement Basics > Analog Demodulation in MSRA/MSRT Operating Mode
Analog Demodulation in MSRA/MSRT Operating Mode

The Analog Demodulation application can also be used to analyze data in MSRA or MSRT operating mode. The main difference between the two modes is that in MSRA mode, an I/Q analyzer performs data acquisition, while in MSRT mode, a realtime measurement is performed to capture data.

In MSRA/MSRT operating mode, only the MSRA/MSRT Master actually captures data; the data acquisition settings for an Analog Demodulation application channel in MSRA/MSRT mode configure the analysis interval, not an actual data capture from the input signal.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for Analog Demodulation.

The currently used analysis interval (in seconds, related to measurement start) is indicated in the window header for each result display.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .


Configuration

Analog Demodulation (R&S FSW-K7) > Configuration
Configuration

Analog demodulation measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate an Analog Demodulation application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Analog Demodulation"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate the Analog Demodulation application, a Analog Demodulation measurement for the input signal is started automatically with the default configuration. It can be configured in the Analog Demodulation "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

The main configuration settings and dialog boxes are also available via the "Analog Demod" menu which is displayed when you press the MEAS CONFIG key.

For a description see
  • "Demodulation Bandwidth"
  • "Measurement Time (AQT)"
  • "Time per Division"
  • "AF Filter"
  • "Scaling"
  • "Basic Demodulation Measurement Parameters (Demod)"
  • "Demodulation Display"

The remote commands required to perform these tasks are described in "Remote Commands for Analog Demodulation Measurements".

Predefined settings

For commonly performed measurements, standard setup files are provided for quick and easy configuration. Simply load an existing standard settings file and, if necessary, adapt the measurement settings to your specific requirements.

For an overview of predefined standards and settings see "Predefined Standards and Settings".

Contents
  • Default Settings for Analog Demodulation
  • Configuration According to Digital Standards
  • Configuration Overview
  • Input and Frontend Settings
  • Trigger Configuration
  • Data Acquisition
  • Demodulation Display
  • Demodulation
  • Output Settings
  • Automatic Settings


Default Settings for Analog Demodulation

Analog Demodulation (R&S FSW-K7) > Configuration > Default Settings for Analog Demodulation
Default Settings for Analog Demodulation

When you activate the Analog Demodulation application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • preamplification
  • signal source and digital I/Q input settings
  • input coupling
  • external mixer

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after the Analog Demodulation application is activated, or after a "Preset Channel":

Default settings for Analog Demodulation channels
Parameter | Value
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Trigger offset | 0
Demodulation BW | 5 MHz
Measurement time | 62.5 μs
Demodulation filter | Flat
AF filters | none
Sample rate | 8 MHz
Sweep points | 1001
Squelch state | off
Squelch level | -20.0 dBm
Usable I/Q Bandwidth | 12.228 MHz
Traces | 1: Clr/Wrte, Auto Peak detector; 2-6: blank
Limit check | off
Evaluations | Window 1: FM Time Domain Window 2: Result Summary


Configuration According to Digital Standards

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards
Configuration According to Digital Standards

Various predefined settings files for common digital standards are provided for use with the Analog Demodulation application. In addition, you can create your own settings files for user-specific measurements.

For details on which settings are defined and an overview of predefined standards see "Predefined Standards and Settings".

Digital standard settings are available via the "Digital Standards" softkey in the MEAS menu or the "Overview".

└ Setup Standard
└ Selecting the Storage Location - Drive/ Path/ Files
└ File Name
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Setup Standard

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard
Setup Standard

Opens a file selection dialog box to select a predefined setup file. The predefined settings are configured in the R&S FSW Analog Demodulation application. This allows for quick and easy configuration for commonly performed measurements.

For an overview of predefined standards and settings see "Predefined Standards and Settings".

└ Selecting the Storage Location - Drive/ Path/ Files
└ File Name
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Selecting the Storage Location - Drive/ Path/ Files

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > Selecting the Storage Location - Drive/ Path/ Files
Selecting the Storage Location - Drive/ Path/ Files

Select the storage location of the settings file on the instrument or an external drive.

The "Drive" indicates the internal (C:) or any connected external drives (e.g. a USB storage device).

The "Path" contains the drive and the complete file path to the currently selected folder.

The "Files" list contains all subfolders and files of the currently selected path.

The default storage location for the settings files is: C:/FSW/user/predefined/AdemodPredefined.

Note: Saving instrument settings in secure user mode. In secure user mode all data is stored to volatile memory, and is only available during the current instrument session. As soon as the power is switched off on the R&S FSW, the data is cleared.
To store settings permanently, select an external storage location, such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode" .


File Name

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > File Name
File Name

Contain the name of the data file without the path or extension.

For details on the file name and location see "Storage Location and File Name" .

Note: Secure user mode. In secure user mode, settings that are to be stored on the instrument are stored to volatile memory. To store data permanently, select an external storage location such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode" .


Load Standard

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > Load Standard
Load Standard

Loads the selected measurement settings file.

For an overview of predefined standards and settings see "Predefined Standards and Settings".

Remote command:

[SENSe:​]ADEMod:​PRESet[:​STANdard]


Save Standard

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > Save Standard
Save Standard

Saves the current measurement settings for a specific standard as a file with the defined name.

For an overview of predefined standards and settings see "Predefined Standards and Settings".

Remote command:

[SENSe:​]ADEMod:​PRESet:​STORe


Delete Standard

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > Delete Standard
Delete Standard

Deletes the selected standard. Standards predefined by Rohde & Schwarz can also be deleted. A confirmation query is displayed to avoid unintentional deletion of the standard.

Note: Restoring predefined standard files. The standards predefined by Rohde & Schwarz available at the time of delivery can be restored using the "Restore Standards" softkey.
(See "Restore Standard Files").


Restore Standard Files

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration According to Digital Standards > Setup Standard > Restore Standard Files
Restore Standard Files

Restores the standards predefined by Rohde & Schwarz available at the time of delivery.

Note that this function will overwrite customized standards that have the same name as predefined standards.

Remote command:

[SENSe:​]ADEMod:​PRESet:​RESTore


Configuration Overview

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

Analog Demodulation in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire Analog Demodulation measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Input/Frontend

    See "Input and Frontend Settings"

  2. Trigger

    See "Trigger Configuration"

  3. Data Acquisition

    See "Data Acquisition"

  4. Demod/Display

    See "Demodulation Display"

  5. Demodulation Settings

    See "Demodulation"

  6. Analysis

    See "Analysis"

  7. (Optionally:) Outputs

    See "Output Settings"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

The main configuration settings and dialog boxes are also available via the "Analog Demod" menu which is displayed when you press the MEAS CONFIG key.

For a description see
  • "Demodulation Bandwidth"
  • "Measurement Time (AQT)"
  • "Time per Division"
  • "AF Filter"
  • "Scaling"
  • "Basic Demodulation Measurement Parameters (Demod)"
  • "Demodulation Display"
└ Preset Channel
└ Setup Standard
└ Specifics for


Preset Channel

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for Analog Demodulation".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Setup Standard

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration Overview > Setup Standard
Setup Standard

Opens a file selection dialog box to select a predefined setup file. See "Setup Standard".


Specifics for

Analog Demodulation (R&S FSW-K7) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Input and Frontend Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings
Input and Frontend Settings

The source and characteristics of the input signal to be demodulated are configured in the "Input and Frontend Settings" dialog box.

Output settings are described in "Output Settings".

►

To display this dialog box, do one of the following:

  • Select the "Input/Frontend" button in the Analog Demodulation "Overview"
  • Select the INPUT/OUTPUT key and then the "Input Source Config" softkey.
  • Select the INPUT/OUTPUT key and then the "Power Sensor Config" softkey.
Contents
  • Input Source Settings
  • Power Sensor
  • Amplitude
  • Frequency


Input Source Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

External mixers are not supported in MSRA/MSRT mode.

Contents
  • Radio Frequency Input
  • External Mixer Settings
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings
  • External Generator Control Settings


Radio Frequency Input

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


External Mixer Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

For more information on using external mixers see "External Mixer (Option -B21)" .

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


Digital I/Q Input Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes".

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes".

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


External Generator Control Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings
External Generator Control Settings

The "External Generator" settings are available in the "Input" dialog box if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Interface Configuration Settings
  • Measurement Settings
  • Source Calibration Functions


Interface Configuration Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings
Interface Configuration Settings

The interface settings for the connection to the external generator are defined in the "Interface Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

For more information on configuring interfaces see "Remote Control Interfaces and Protocols" .

└ Generator Type
└ Interface
└ TTL Handshake
└ GPIB Address / TCP/IP Address
└ Reference
└ Edit Generator Setup File
└ Frequency Min. / Frequency Max.
└ Level Min. / Level Max.


Generator Type

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Generator Type
Generator Type

Selects the generator type and thus defines the generator setup file to use.

For an overview of supported generators see "Overview of Generators Supported by the R&S FSW-B10 Option". For information on generator setup files see "Generator Setup Files".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​TYPE


Interface

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Interface
Interface

Type of interface connection used. The following interfaces are currently supported:

  • GPIB
  • TCP/IP (not by all generators)

For details on which signal generators support which interfaces, see the documentation of the corresponding signal generator.

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​INTerface


TTL Handshake

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > TTL Handshake
TTL Handshake

If available for the specified generator type, this option activates TTL synchronization via handshake for GPIB connections.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

For more information on TTL synchronization see "TTL synchronization".

For an overview of which generators support TTL synchronization see "Overview of Generators Supported by the R&S FSW-B10 Option".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​LINK


GPIB Address / TCP/IP Address

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > GPIB Address / TCP/IP Address
GPIB Address / TCP/IP Address

For LAN connections: TCP/IP address of the signal generator

For GPIB connections: GPIB address of the signal generator.

For details on interfaces see "Remote Control Interfaces and Protocols" .

Remote command:

SYSTem:​COMMunicate:​GPIB:​RDEVice:​GENerator:​ADDRess

SYSTem:​COMMunicate:​TCPip:​RDEVice:​GENerator:​ADDRess


Reference

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Reference
Reference

Selects the internal R&S FSW or an external frequency reference to synchronize the R&S FSW with the generator (default: internal).

Remote command:

SOURce:​EXTernal:​ROSCillator[:​SOURce]


Edit Generator Setup File

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Edit Generator Setup File
Edit Generator Setup File

Displays the setup file for the currently selected "Generator Type" in read-only mode in an editor.

Although the existing setup files are displayed in read-only mode in the editor, they can be saved under a different name (using "File > SaveAs").

Be careful, however, to adhere to the required syntax and commands. Errors will only be detected and displayed when you try to use the new generator (see also "Displayed Information and Errors").

For details see "Generator Setup Files".


Frequency Min. / Frequency Max.

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Frequency Min. / Frequency Max.
Frequency Min. / Frequency Max.

For reference only: Lower and upper frequency limit for the generator.


Level Min. / Level Max.

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Interface Configuration Settings > Level Min. / Level Max.
Level Min. / Level Max.

For reference only: Lower and upper power limit for the generator.


Measurement Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings
Measurement Settings

The measurement settings for external generator control are configured in the "Measurement Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Source State
└ Source Power
└ Source Offset
└ Source Frequency Coupling
└ (Manual) Source Frequency
└ (Automatic) Source Frequency (Numerator/Denominator/Offset)
└ Result Frequency Start
└ Result Frequency Stop


Source State

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source State
Source State

Activates or deactivates control of an external generator.

For more information on external generator control see "Basics on External Generator Control".

Remote command:

SOURce:​EXTernal[:​STATe]


Source Power

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Power
Source Power

The output power of the external generator. The default output power is -20 dBm. The range is specified in the data sheet.

Remote command:

SOURce:​EXTernal:​POWer[:​LEVel]


Source Offset

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Offset
Source Offset

Constant level offset for the external generator. Values from -200 dB to +200 dB in 1 dB steps are allowed. The default setting is 0 dB. Offsets are indicated by the "LVL" label in the channel bar (see also "Displayed Information and Errors").

With this offset, attenuators or amplifiers at the output connector of the external generator can be taken into account for the displayed output power values on screen or during data entry, for example. Positive offsets apply to an amplifier and negative offsets to an attenuator subsequent to the external generator.

Remote command:

SOURce:​POWer[:​LEVel][:​IMMediate]:​OFFSet


Source Frequency Coupling

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Source Frequency Coupling
Source Frequency Coupling

Defines the frequency coupling mode between the R&S FSW and the generator.

For more information on coupling frequencies see "Coupling the Frequencies".

"Auto" | Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"); the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
"Manual" | The generator uses a single fixed frequency, defined by "(Manual) Source Frequency" which is displayed when you select "Manual" coupling.
Remote command:

SOURce:​EXTernal:​FREQuency:​COUPling[:​STATe]


(Manual) Source Frequency

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > (Manual) Source Frequency
(Manual) Source Frequency

Defines the fixed frequency to be used by the generator.

Remote command:

SOURce:​EXTernal:​FREQuency


(Automatic) Source Frequency (Numerator/Denominator/Offset)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > (Automatic) Source Frequency (Numerator/Denominator/Offset)
(Automatic) Source Frequency (Numerator/Denominator/Offset)

With automatic frequency coupling, a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW.

However, the frequency used by the generator may differ from the input from the R&S FSW. The RF frequency may be multiplied by a specified factor, or a frequency offset can be added, or both.

Note: The input for the generator frequency is not validated, i.e. you can enter any values. However, if the allowed frequency ranges of the generator are exceeded, an error message is displayed on the R&S FSW and the values for "Result Frequency Start" and "Result Frequency Stop" are corrected to comply with the range limits.

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets <> 0 Hz are indicated by the "FRQ" label in the channel bar. Negative offsets can be used to define reverse sweeps.

For more information on coupling frequencies and reverse sweeps see "Coupling the Frequencies". For more information on error messages and the channel bar see "Displayed Information and Errors".

Remote command:

SOURce:​EXTernal:​FREQuency[:​FACTor]:​DENominator

SOURce:​EXTernal:​FREQuency[:​FACTor]:​NUMerator

SOURce:​EXTernal:​FREQuency:​OFFSet


Result Frequency Start

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Result Frequency Start
Result Frequency Start

For reference only: The start frequency for the generator, calculated from the configured generator frequency and the start value defined for the R&S FSW.


Result Frequency Stop

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Measurement Settings > Result Frequency Stop
Result Frequency Stop

For reference only: The stop frequency for the generator, calculated from the configured generator frequency and the stop value defined for the R&S FSW.


Source Calibration Functions

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions
Source Calibration Functions

The calibration functions of the external generator are available in the "Source Calibration" subtab of the "External Generator" tab, but only if external generator control is active (see "Source State").

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Calibrate Transmission
└ Calibrate Reflection Short
└ Calibrate Reflection Open
└ Source Calibration Normalize
└ Recall
└ Save As Trd Factor
└ Reference Position
└ Reference Value


Calibrate Transmission

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Transmission
Calibrate Transmission

Starts a transmission type measurement to determine a reference trace. This trace is used to calculate the difference for the normalized values.

This function is only available if external generator control is active (see "Source State").

For details see "Calibration Mechanism".

Remote command:

[SENSe:​]CORRection:​METHod


Calibrate Reflection Short

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Short
Calibrate Reflection Short

Starts a short-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both calibrations (open circuit, short circuit) are carried out, the calibration trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for short-circuit calibration.


Calibrate Reflection Open

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Open
Calibrate Reflection Open

Starts an open-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both reflection-type calibrations (open circuit, short circuit) are carried out, the reference trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for open-circuit calibration.


Source Calibration Normalize

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Source Calibration Normalize
Source Calibration Normalize

Switches the normalization of measurement results on or off. This function is only available if the memory contains a reference trace, that is, after a calibration has been performed.

For details on normalization see "Normalization".

Remote command:

[SENSe:​]CORRection[:​STATe]


Recall

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Recall
Recall

Restores the settings that were used during source calibration. This can be useful if instrument settings were changed after calibration (e.g. center frequency, frequency deviation, reference level, etc).

This function is only available if external generator control is active (see "Source State").

Remote command:

[SENSe:​]CORRection:​RECall


Save As Trd Factor

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Save As Trd Factor
Save As Trd Factor

Uses the normalized measurement data to generate a transducer factor. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under "c:\r_s\instr\trd". The frequency points are allocated in equidistant steps between start and stop frequency. The generated transducer factor can be further adapted using the "Transducer" softkey in the SETUP menu.

For more information on transducers see "Basics on Transducer Factors" .

This function is only available if "Source Calibration Normalize" is switched on.

Note: Note that the normalized measurement data is used, not the reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).

Remote command:

[SENSe:​]CORRection:​TRANsducer:​GENerator


Reference Position

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Reference Position
Reference Position

Defines the position of the "Result Frequency Stop" in percent of the total y-axis range. The top of the diagram is 100%, the bottom is 0%. By default, the 0 dB line is displayed at the top of the diagram (100%).

This setting is only available if normalization is on (see "Source Calibration Normalize").

The reference line defined by the reference value and reference position is similar to the "Reference Level" defined in the "Amplitude" settings. However, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The normalized trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Reference Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Input Source Settings > External Generator Control Settings > Source Calibration Functions > Reference Value
Reference Value

Defines the reference value to be displayed at the specified "Result Frequency Start".

This setting can be used to shift the reference line and thus the normalized trace, similar to the "Shifting the Display (Offset)" defined in the "Amplitude" settings shifts the reference level in the display.

Shifting the normalized trace is useful, for example, to reflect an attenuation or gain caused by the measured DUT. If you then zoom into the diagram around the normalized trace, the measured trace still remains fully visible.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Power Sensor

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Power Sensor
Power Sensor

The R&S FSW can also analyze data from a connected power sensor.

For background information on working with power sensors see "Power Sensors" .


Amplitude

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude
Amplitude

The amplitude is configured in the "Amplitude" tab of the "Input/Frontend" dialog box. Amplitude settings are identical to the base unit.

►

To display this dialog box, do one of the following:

  • Select the "Input/Frontend" button in the Analog Demodulation "Overview" and switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

Contents
  • Amplitude Settings for RF Input
  • Amplitude Settings for Analog Baseband Input


Amplitude Settings for RF Input

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input
Amplitude Settings for RF Input

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

To display the "Amplitude" dialog box, do one of the following:

  • Select "Amplitude" from the "Overview".
  • Select the AMPT key and then the "Amplitude Config" softkey.

The remote commands required to define these settings are described in "Configuring the Vertical Axis (Amplitude, Scaling)".

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Mechanical Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Note that for input from the External Mixer (R&S FSW-B21) the maximum reference level also depends on the conversion loss, see "Reference level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Reference Level > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Setting the Reference Level Automatically (Auto Level)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


Mechanical Attenuation

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Mechanical Attenuation
Mechanical Attenuation

Defines the mechanical attenuation for RF input.

This function is not available for input from the R&S Digital I/Q Interface (option R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Mechanical Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for RF Input > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Amplitude Settings for Analog Baseband Input

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Unit

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for Analog Baseband Input > Reference Level > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Full Scale Level Mode / Value

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Amplitude > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Frequency

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Frequency
Frequency

The center frequency of the input signal is configured in the "Frequency" tab of the "Input/Frontend" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Input/Frontend" button in the Analog Demodulation "Overview" and switch to the "Frequency" tab.
  • Select the FREQ key and then the "Frequency Config" softkey.
└ Center frequency
└ Center Frequency Stepsize


Center frequency

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Frequency > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

Analog Demodulation (R&S FSW-K7) > Configuration > Input and Frontend Settings > Frequency > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size of the center frequency. The step size can be coupled to the demodulation bandwidth, or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"0.1 * Demod BW" | Sets the step size for the center frequency to 10 % of the demodulation bandwidth. This is the default setting.
"0.5 * Demod BW" | Sets the step size for the center frequency to 50 % of the demodulation bandwidth.
"X * Demod BW" | Sets the step size for the center frequency to a manually defined factor of the demodulation bandwidth. The "X-Factor" defines the percentage of the demodulation bandwidth. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency and removes the coupling of the step size to the demodulation bandwidth. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP:​LINK

[SENSe:​]FREQuency:​CENTer:​STEP:​LINK:​FACTor

[SENSe:​]FREQuency:​CENTer:​STEP


Trigger Configuration

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration
Trigger Configuration

Triggering means to capture the interesting part of the signal. Choosing the right trigger type and configuring all trigger settings correctly allows you to detect various incidents in your demodulated signals.

Optionally, the trigger signal used by the R&S FSW can be output to a connected device, and an external trigger signal from a connected device can be used by the R&S FSW.

Trigger settings are identical to the base unit, except for the available trigger sources. Gating is not available for Analog Demodulation measurements.

For background information on trigger settings, trigger output and working with external triggers, see "Trigger and Gate Configuration" .

The trigger settings are configured in the "Trigger" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Trigger" button in the Analog Demodulation "Overview"
  • Select the TRIG key and then the "Trigger Config" softkey.
Contents
  • Trigger Source Settings
  • Trigger Input and Output Settings


Trigger Source Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings
Trigger Source Settings

The trigger source settings are configured in the "Trigger Source" tab of the "Trigger" dialog box.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power/BB Power
└ Digital I/Q
└ FM / AM / PM / RF (Offline)
└ Time
└ RF Power
└ Power Sensor
└ Trigger Level
└ Trigger Offset
└ Hysteresis
└ Drop-Out Time
└ Slope
└ Trigger Holdoff


Trigger Source

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source
Trigger Source

In the Analog Demodulation application, the next measurement can be triggered if the selected input signal exceeds the threshold specified using the "Trigger Level" setting (see "Trigger Level"). Thus, a periodic signal modulated onto the carrier frequency can be displayed. It is recommended that the measurement time covers at least five periods of the audio signal.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power/BB Power
└ Digital I/Q
└ FM / AM / PM / RF (Offline)
└ Time
└ RF Power
└ Power Sensor


Free Run

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


I/Q Power

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

The trigger bandwidth corresponds to the resolution bandwidth setting for data acquisition (see "Data Acquisition").

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


IF Power/BB Power

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > IF Power/BB Power
IF Power/BB Power

Depending on the input source type, this softkey defines triggering of the measurement using:

  • the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)
  • the third intermediate frequency(RF input)
    The R&S FSW is triggered as soon as the trigger threshold is exceeded around the selected frequency (= start frequency in the frequency sweep). The trigger threshold depends on the defined trigger level, as well as on the RF attenuation and preamplification. A reference level offset, if defined, is also considered. The trigger bandwidth at the intermediate frequency depends on the RBW and sweep type. For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector" )

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


FM / AM / PM / RF (Offline)

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > FM / AM / PM / RF (Offline)
FM / AM / PM / RF (Offline)

Triggers when the demodulated input signal exceeds the trigger level.

Remote command:

TRIGger[:​SEQuence]:​SOURce


Time

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > Time
Time

Triggers in a specified repetition interval.

Remote command:

TRIG:SOUR TIME, see TRIGger[:​SEQuence]:​SOURce


RF Power

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

This trigger source is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71). If the trigger source "RF Power" is selected and digital I/Q or analog baseband input is activated, the trigger source is automatically switched to "Free Run".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Power Sensor

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Source > Power Sensor
Power Sensor

Uses an external power sensor as a trigger source. This option is only available if a power sensor is connected and configured.

Note: For R&S power sensors, the "Gate Mode" Lvl is not supported. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed.

Remote command:

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel:​IQPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

For analog baseband (B71) or digital baseband (B17) input only:

TRIGger[:​SEQuence]:​LEVel:​RFPower

TRIGger[:​SEQuence]:​LEVel:​AM:​RELative

TRIGger[:​SEQuence]:​LEVel:​AM[:​ABSolute]

TRIGger[:​SEQuence]:​LEVel:​FM

TRIGger[:​SEQuence]:​LEVel:​PM


Trigger Offset

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)

For the "Time" trigger source, this function is not available.

Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Drop-Out Time

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Slope

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Trigger Holdoff

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Source Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Trigger Input and Output Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings
Trigger Input and Output Settings

The trigger input and output settings are configured in the "Trigger In/Out" tab of the "Trigger" dialog box, or in the "Outputs" configuration dialog box (via the INPUT/OUTPUT key).

└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger 2/3

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector. Note: For offline AF or RF triggers, no output signal is provided.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered"

(Default) Sends a trigger when the R&S FSW triggers.

"Trigger Armed"

Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state.

This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).

For details see "STATus:OPERation Register" and the R&S FSW Getting Started manual.

"User Defined"

Sends a trigger when user selects "Send Trigger" button.

In this case, further parameters are available for the output signal.

Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Analog Demodulation (R&S FSW-K7) > Configuration > Trigger Configuration > Trigger Input and Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Data Acquisition

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition
Data Acquisition

How data is to be acquired and then demodulated is configured in the "Data Acquisition" dialog box.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the Analog Demodulation application in MSRA/MSRT mode define the analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Contents
  • Bandwidth Settings
  • Sweep Settings


Bandwidth Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings
Bandwidth Settings

The bandwidth settings define which parts of the input signal are acquired and then demodulated. They are configured via the BW key or in the "Bandwidth" tab of the "Data Acquisition" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Data Acquisition" button in the Analog Demodulation "Overview"
  • Select the BW key and then the "Bandwidth Config" softkey.
└ Demodulation Bandwidth
└ Demodulation Filter
└ Measurement Time (AQT)
└ Capture Offset
└ Resolution Bandwidth


Demodulation Bandwidth

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings > Demodulation Bandwidth
Demodulation Bandwidth

Defines the demodulation bandwidth of the measurement. The demodulation bandwidth determines the sampling rate with which the input signal is captured and analyzed.

For recommendations on finding the correct demodulation bandwidth see "Demodulation Bandwidth".

For details on the relation between demodulation bandwidth and sampling rate refer to "Sample Rate, Measurement Time and Trigger Offset".

Remote command:

[SENSe:​]BANDwidth|BWIDth:​DEMod


Demodulation Filter

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings > Demodulation Filter
Demodulation Filter

Defines the filter to be used for demodulation.

For details on sample rates, measurement times and trigger offsets for various demodulation bandwidths when using a Gaussian filter, see "Sample Rate, Measurement Time and Trigger Offset".

"Flat" | Default
"Gauss" | Optimizes the settling behaviour of the filter
Remote command:

[SENSe:​]BANDwidth|BWIDth:​DEMod:​TYPE


Measurement Time (AQT)

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings > Measurement Time (AQT)
Measurement Time (AQT)

Defines how long data is acquired for demodulatation. For details on the measurement time see "Sample Rate, Measurement Time and Trigger Offset".

Remote command:

[SENSe:​]ADEMod:​MTIMe


Capture Offset

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

In MSRT mode, the offset may be negative if a pretrigger time is defined.

For details on the MSRA operating mode see "Applications and Operating Modes" .

For details on the MSRT operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet

[SENSe:​]RTMS:​CAPTure:​OFFSet


Resolution Bandwidth

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Bandwidth Settings > Resolution Bandwidth
Resolution Bandwidth

Defines the resolution bandwidth for data acquisition. The available range is specified in the data sheet.

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Sweep Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings
Sweep Settings

The sweep settings define how often data from the input signal is acquired and then demodulated. They are configured via the SWEEP key or in the "Sweep" tab of the "Data Acquisition" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Data Acquisition" button in the Analog Demodulation "Overview" and switch to the "Sweep" tab.
  • Select the SWEEP key and then the "Sweep Config" softkey.
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh
└ Measurement Time (AQT)
└ Sweep Points
└ Sweep/Average Count


Continuous Sweep/RUN CONT

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
If the Sequencer is active in MSRT mode, the "Continuous Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, trace averaging is performed.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
If the Sequencer is active in MSRT mode, the "Single Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, no trace averaging is performed.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA or MSRT applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Measurement Time (AQT)

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Measurement Time (AQT)
Measurement Time (AQT)

Defines how long data is acquired for demodulatation. For details on the measurement time see "Sample Rate, Measurement Time and Trigger Offset".

Remote command:

[SENSe:​]ADEMod:​MTIMe


Sweep Points

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Sweep Points
Sweep Points

Defines the number of measured values to be collected during one sweep.

For details see "How Much Data is Measured: Sweep Points and Sweep Count" .

All values from 101 to 100001 can be set. The default value is 1001 sweep points.

Remote command:

[SENSe:​]SWEep:​POINts


Sweep/Average Count

Analog Demodulation (R&S FSW-K7) > Configuration > Data Acquisition > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Demodulation Display

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation Display
Demodulation Display

The demodulated signal can be displayed using various evaluation methods. All evaluation methods available for the Analog Demodulation application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Demod/Display" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in the main "Analog Demod" menu.

Up to six evaluation methods can be displayed simultaneously in separate windows. The Analog Demodulation evaluation methods are described in "Measurements and Result Displays".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Demodulation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation
Demodulation

Demodulation parameters can be configured in the "Demodulation Settings" dialog box which is displayed when you select the "Demod Settings" button in the "Overview".

Contents
  • Basic Demodulation Measurement Parameters (Demod)
  • Demodulation Spectrum
  • AF Filter
  • Scaling
  • Units


Basic Demodulation Measurement Parameters (Demod)

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod)
Basic Demodulation Measurement Parameters (Demod)

The basic demodulation measurement parameters define how the measurement is performed. They are configured in the "Demod" tab of the "Demodulation Settings" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Demod Settings" button in the Analog Demodulation "Overview" and select the "Demod" tab.
  • Select the MEAS CONFIG key and then the "Demod Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ Squelch State
└ Squelch Level
└ AF Coupling
└ Selected Trace
└ Time Domain Zoom
└ State
└ Start
└ Length
└ Time per Division
└ Zero Phase Reference Position (PM Time Domain only)
└ Phase Wrap On/Off (PM Time Domain only)


Squelch State

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Squelch State
Squelch State

Activates the squelch function, i.e. if the signal falls below a defined threshold, the demodulated data is automatically set to 0. This is useful, for example, to avoid demodulation noise during transmission breaks.

Remote command:

[SENSe:​]ADEMod:​SQUelch[:​STATe]


Squelch Level

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Squelch Level
Squelch Level

Defines the level threshold below which the demodulated data is set to 0 if squelching is enabled. The squelch level is an absolute value.

Remote command:

[SENSe:​]ADEMod:​SQUelch:​LEVel


AF Coupling

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > AF Coupling
AF Coupling

Controls the automatic correction of the frequency offset and phase offset of the input signal:

This function is only available for FM or PM time domain evaluations.

  • FM time evaluation
    If DC is selected, the absolute frequency is displayed, i.e. an input signal with an offset relative to the center frequency is not displayed symmetrically with respect to the zero line.
    If AC is selected, the frequency offset is automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
  • PM time evaluation
    If DC is selected, the phase runs according to the existing frequency offset. In addition, the DC signal contains a phase offset of ± π.
    If AC is selected, the frequency offset and phase offset are automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
Remote command:

[SENSe:​]ADEMod<n>:​AF:​COUPling


Selected Trace

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Selected Trace
Selected Trace

Defines the trace used to determine the results in the Result Summary.


Time Domain Zoom

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Time Domain Zoom
Time Domain Zoom

Using the time domain zoom, the demodulated data for a particular time span is extracted and displayed in more detail. This is useful if the measurement time is very large and thus each sweep point represents a large time span. The time domain zoom function distributes the available sweep points only among the time span defined by the zoom area length. The time span displayed per division of the diagram is decreased. Thus, the display of the extracted time span becomes more precise. Note that the time domain zoom area affects not only the diagram display, but the entire evaluation for the current window.

This function is only available for evaluations in the time domain.

Tip: In addition to the Time Domain Zoom, a graphical zoom is available for all diagram evaluations. However, the graphical zoom is useful only if more measured values than trace points are available. The (time) span represented by each measurement point remains the same. For details see "Zoom Functions".

└ State
└ Start
└ Length
└ Time per Division


State

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Time Domain Zoom > State
State

Activates or deactivates the time domain zoom mode.

"ON"

Activates the time domain zoom.

"OFF"

Deactivates the time domain zoom and restores the original display. If more measured values than measurement points are available, several measured values are combined in one measurement point according to the method of the selected trace detector.

For details on detectors refer to "Mapping Samples to Sweep Points with the Trace Detector" .

Remote command:

[SENSe:​]ADEMod<n>:​ZOOM[:​STATe]


Start

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Time Domain Zoom > Start
Start

Defines the start time for the time domain zoom area. For spectrum evaluations the start time is always 0.

Remote command:

[SENSe:​]ADEMod<n>:​ZOOM:​STARt


Length

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Time Domain Zoom > Length
Length

Defines the length of the time domain zoom area. Enter the length as a time value manually, or use the "Auto" setting to set the length to the current number of sweep points automatically.

Remote command:

[SENSe:​]ADEMod<n>:​ZOOM:​LENGth

[SENSe:​]ADEMod<n>:​ZOOM:​LENGth:​MODE


Time per Division

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Time Domain Zoom > Time per Division
Time per Division

The "Time per Division" softkey in the main Analog Demodulation menu enables the "Time Domain Zoom" function and defines the zoom area length in one step. The width of the zoom display is divided into 10 divisions; thus, by entering the time that is displayed in each division, you indirectly define the zoom area length ("Time per Division" * 10). The starting point of the zoom area is determined automatically. To specify the starting point manually, use the "Start" setting.

For details see "Time Domain Zoom".


Zero Phase Reference Position (PM Time Domain only)

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Zero Phase Reference Position (PM Time Domain only)
Zero Phase Reference Position (PM Time Domain only)

Defines the position at which the phase of the PM-demodulated signal is set to 0 rad. The entry is made with respect to time. In the default setting, the first measured value is set to 0 rad.

This setting is only available for PM time domain displays with DC coupling.

Remote command:

[SENSe:​]ADEMod:​PM:​RPOint[:​X]


Phase Wrap On/Off (PM Time Domain only)

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Basic Demodulation Measurement Parameters (Demod) > Phase Wrap On/Off (PM Time Domain only)
Phase Wrap On/Off (PM Time Domain only)

Activates/deactivates the phase wrap.

On | The phase is displayed in the range ±180° (± Π). For example, if the phase exceeds +180°, 360° is subtracted from the phase value, with the display thus showing >-180°.
Off | The phase is not wrapped.

This setting is only available for PM time domain displays with DC coupling.


Demodulation Spectrum

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum
Demodulation Spectrum

The demodulation spectrum defines which span of the demodulated data is evaluated. It is configured in the "Spectrum" tab of the "Demodulation Settings" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Demod Settings" button in the Analog Demodulation "Overview" and select the "Spectrum" tab.
  • Select the MEAS CONFIG key and then the "Demod Config" softkey. Then select the "Spectrum" tab.

Depending on the evaluation (AF or RF display), the settings vary.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • AF Evaluation
  • RF Evaluation


AF Evaluation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation
AF Evaluation

The demodulation spectrum defines which span of the demodulated data is evaluated.

These settings are only available for AF Spectrum evaluations, not in the time domain.

└ AF Center
└ AF Start
└ AF Stop
└ AF Span
└ AF Full Span


AF Center

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation > AF Center
AF Center

Defines the center frequency of the demodulated data to evaluate.

Remote command:

[SENSe:​]ADEMod:​AF:​CENTer


AF Start

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation > AF Start
AF Start

Defines the start frequency of the demodulated data to evaluate.

Remote command:

[SENSe:​]ADEMod:​AF:​STARt


AF Stop

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation > AF Stop
AF Stop

Defines the stop frequency of the demodulated data to evaluate.

The maximum AF stop frequency corresponds to half the demodulation bandwidth.

Remote command:

[SENSe:​]ADEMod:​AF:​STOP


AF Span

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation > AF Span
AF Span

Defines the span (around the center frequency) of the demodulated data to evaluate. The maximum span is DBW/2.

Remote command:

[SENSe:​]ADEMod:​AF:​SPAN


AF Full Span

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > AF Evaluation > AF Full Span
AF Full Span

Sets the span (around the center frequency) of the demodulated data to the maximum of DBW/2.

Remote command:

[SENSe:​]ADEMod:​AF:​SPAN:​FULL


RF Evaluation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > RF Evaluation
RF Evaluation

The demodulation spectrum defines which span of the demodulated data is evaluated.

These settings are only available for RF evaluation, both in time and frequency domain. Note that for RF data the center frequency and demodulation bandwidth correspond to the settings defined in the "Input" and "Data Acquisition" configuration.

└ Center frequency
└ Span
└ Demodulation Bandwidth
└ RF Full Span


Span

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > RF Evaluation > Span
Span

Defines the frequency span. The center frequency is kept constant. The following range is allowed:

span = 0: 0 Hz

span >0:

spanmin ≤ f span ≤ f max

and fmax=DBW/2

fmax and spanmin are specified in the data sheet.

For more information see "Defining the Scope of the Measurement - Frequency Range" .

Remote command:

[SENSe:​]ADEMod:​SPECtrum:​SPAN[:​MAXimum]

[SENSe:​]ADEMod:​SPEC:​SPAN:​ZOOM


Demodulation Bandwidth

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > RF Evaluation > Demodulation Bandwidth
Demodulation Bandwidth

Defines the demodulation bandwidth of the measurement. The demodulation bandwidth determines the sampling rate with which the input signal is captured and analyzed.

For recommendations on finding the correct demodulation bandwidth see "Demodulation Bandwidth".

For details on the relation between demodulation bandwidth and sampling rate refer to "Sample Rate, Measurement Time and Trigger Offset".

Remote command:

[SENSe:​]BANDwidth|BWIDth:​DEMod


RF Full Span

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Demodulation Spectrum > RF Evaluation > RF Full Span
RF Full Span

Sets the span (around the center frequency) of the RF data to be evaluated to the demodulation bandwidth.

Remote command:

[SENSe:​]ADEMod:​SPECtrum:​SPAN[:​MAXimum]


AF Filter

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter
AF Filter

The AF filter reduces the evaluated bandwidth of the demodulated signal and can define a weighting function. It is configured in the "AF Filter" tab of the "Demodulation Settings" dialog box.

AF filters are only available for AF time domain evaluations.

A maximum of two filters out of high pass, low pass or deemphasis filters can be active at the same time if analog demodulation output is active (see "Analog Demodulation Output Settings").

►

To display this dialog box, do one of the following:

  • Select the "Demod Settings" button in the Analog Demodulation "Overview" and select the "AF Filter" tab.
  • Select the MEAS CONFIG key and then the "AF Filter Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ High Pass
└ Low Pass
└ Weighting
└ Deemphasis
└ Deactivating all AF Filters


High Pass

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter > High Pass
High Pass

Defines a high pass filter with the given limit to separate the DC component. The filters are indicated by the 3 dB cutoff frequency. The 50 Hz and 300 Hz filters are designed as 2nd-order Butterworth filter (12 dB/octave). The 20 Hz filter is designed as 3rd-order Butterworth filter (18 dB/octave).

The high pass filters are active in the following demodulation bandwidth range:

None | No AF Filter used (default)
20 Hz | 100 Hz ≤ demodulation bandwidth ≤ 1.6 MHz
50 Hz: | 200 Hz ≤ demodulation bandwidth ≤ 3 MHz
300 Hz: | 800 Hz ≤ demodulation bandwidth ≤ 8 MHz
Manual: | A high pass filter with the manually defined frequency is used.

Note: If online demodulation output is active, the predefined (fixed) filters are not available. In this case, the frequency for the high pass filter must be defined manually (see also "Analog Demodulation Output Settings").
If a filter was already configured when online demodulation output is activated, it is replaced by a manual filter that provides corresponding results, if possible.

Remote command:

[SENSe:​]FILTer<n>:​HPASs[:​STATe]

[SENSe:​]FILTer<n>:​HPASs:​FREQuency[:​ABSolute]

[SENSe:​]FILTer<n>:​HPASs:​FREQuency:​MANual


Low Pass

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter > Low Pass
Low Pass

Defines a low pass filter type. Relative and absolute low pass filter are available.

  • Absolute low pass filters:
    Absolute filters are indicated by the 3 dB cutoff frequency. The 3 kHz, 15 kHz and 23 kHz filters are designed as 5th-order Butterworth filters (30 dB/octave). The 150 kHz filter is designed as 8th-order Butterworth filter (48 dB/octave).
    The absolute low pass filters are active in the following demodulation bandwidth range:
Filter type | Demodulation bandwidth
3 kHz: | 6.4 kHz ≤ demodulation bandwidth ≤ 3 MHz
15 kHz: | 50 kHz ≤ demodulation bandwidth ≤ 8 MHz
23 kHz | 50 kHz ≤ demodulation bandwidth ≤ 18 MHz
150 kHz: | 400 kHz ≤ demodulation bandwidth ≤ 8 MHz
Manual: | A low pass filter with the manually defined frequency is used.

Note: If online demodulation output is active, the predefined (fixed) filters are not available. In this case, the frequency for the low pass filter must be defined manually (see also "Analog Demodulation Output Settings").
If a filter was already configured when online demodulation output is activated, it is replaced by a manual filter that provides corresponding results, if possible.

  • Relative low pass filters:
    Relative filters (3 dB) can be selected in % of the demodulation bandwidth. The filters are designed as 5th-order Butterworth filter (30 dB/octave) and active for all demodulation bandwidths.
  • "None" deactivates the AF low pass filter (default).
Remote command:

[SENSe:​]FILTer<n>:​LPASs[:​STATe]

[SENSe:​]FILTer<n>:​LPASs:​FREQuency[:​ABSolute]

[SENSe:​]FILTer<n>:​LPASs:​FREQuency:​RELative

[SENSe:​]FILTer<n>:​LPASs:​FREQuency:​MANual


Weighting

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter > Weighting
Weighting

Selects a weighting AF filter. By default, no weighting filter is active.

"A weighted" | Switches on the A weighted filter. The weighting filter is active in the following demodulation bandwidth range: 100 kHz ≤ demodulation bandwidth ≤ 800 kHz
"CCITT" | Switches on a CCITT P.53 weighting filter. The weighting filter is active in the following demodulation bandwidth range: 20 kHz ≤ demodulation bandwidth ≤ 3 MHz
"CCIR weighted" | Switches on the CCIR weighted filter. The weighting filter is active in the following demodulation bandwidth range: 100 kHz ≤ demodulation bandwidth ≤ 3.0 MHz
"CCIR unweighted" | Switches on the CCIR unweighted filter, which is the combination of the 20 Hz highpass and 23 kHz low pass filter. The weighting filter is active in the following demodulation bandwidth range: 50 kHz ≤ demodulation bandwidth ≤ 1.6 MHz
Remote command:

[SENSe:​]FILTer<n>:​CCIT

[SENSe:​]FILTer<n>:​CCIR:​[:​UNWeighted][:​STATe]

[SENSe:​]FILTer<n>:​CCIR:​WEIGhted[:​STATe]

[SENSe:​]FILTer<n>:​AWEighted[:​STATe]


Deemphasis

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter > Deemphasis
Deemphasis

Activates a deemphasis filter with the given time constant.

Sometimes a modulated signal is extorted by a pre-emphasis filter before transmission, for example to eliminate frequencies that are more prone to interferences. In this case, the emphasis function must be reversed after demodulation. This is done by the deemphasis filter.

The deemphasis filter is active in the following demodulation bandwidth range:

25 μs: | 25 kHz ≤ demodulation bandwidth ≤ 40 MHz
50 μs: | 6.4 kHz ≤ demodulation bandwidth ≤ 18 MHz
75 μs: | 6.4 kHz ≤ demodulation bandwidth ≤ 18 MHz
750 μs: | 800 Hz ≤ demodulation bandwidth ≤ 3 MHz

Depending on the deemphasis filter, a minimum demodulation bandwidth is required for an error less than 0.5 dB, up to a maximum AF frequency. The following table shows the dependencies.

Deemphasis [us] | 25 μs | 50 μs | 75 μs | 750 μs
Max. AF frequency | 25 kHz | 12 kHz | 8 kHz | 800 Hz
Required demodulation bandwidth | ≥ 200 kHz | ≥ 100 kHz | ≥ 50 kHz | ≥ 6.4 kHz

For higher AF frequencies the demodulation bandwidth must be increased.

Remote command:

[SENSe:​]FILTer<n>:​DEMPhasis[:​STATe]

[SENSe:​]FILTer<n>:​DEMPhasis:​TCONstant


Deactivating all AF Filters

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > AF Filter > Deactivating all AF Filters
Deactivating all AF Filters

The "All Filter Off" button deactivates all AF filters for the selected evaluation.

Remote command:

[SENSe:​]FILTer<n>:​AOFF


Scaling

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling
Scaling

The scaling parameters define the range of the demodulated data to be displayed. They are configured in the "Scaling" tab of the "Demodulation Settings" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Demod Settings" button in the Analog Demodulation "Overview" and select the "Scaling" tab.
  • Select the MEAS CONFIG key and then the "Scale Config" softkey.

Depending on the evaluation (AF or RF display), the settings vary.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • AF Evaluation
  • RF Evaluation


AF Evaluation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation
AF Evaluation

The scaling parameters define the range of the demodulated data to be displayed. They are configured in the "Scaling" tab of the "Demodulation Settings" dialog box.

These settings are only available for AF evaluations.

└ Dev per Division/ Db per Division
└ Reference Value Position
└ Reference Value
└ AF Coupling
└ Deviation
└ AF Auto Scale


Dev per Division/ Db per Division

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > Dev per Division/ Db per Division
Dev per Division/ Db per Division

Defines the modulation depth or the phase deviation or frequency deviation per division (logarithmic: 0.1 to 20 dB):

AM display: | 0.0001 % to 1000 %
FM display: | 1 Hz/div to 100 MHz/div
PM display: | 0.0001 rad/div to 1000 rad/div

Note: The value defined per division refers to the default display of 10 divisions on the y-axis. If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.


Reference Value Position

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > Reference Value Position
Reference Value Position

Determines the position of the reference value for the modulation depth or the phase deviation or frequency deviation on the y-axis of the diagram.

The position is entered as a percentage of the diagram height with 100 % corresponding to the upper diagram border. The default setting is 50 % (diagram center) for the AF time evaluations and 100 % (upper diagram border) for the AF spectrum evaluations.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Reference Value

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > Reference Value
Reference Value

Determines the modulation depth or the phase deviation or the frequency deviation at the reference line of the y-axis. The reference value can be set specifically for each evaluation.

  • AF time display
    The trace display takes individual frequency/phase offsets into account (in contrast, the "AF Coupling" setting permits automatic correction by the average frequency/phase offset of the signal, and can therefore not be activated simultaneously).
  • AF spectrum display
    In the default setting, the reference value defines the modulation depth or the FM/PM deviation at the upper diagram border.
Possible values:
  • AM: 0 and ± 10000 %
  • FM: 0 and ± 10 MHz
  • PM: 0 and ± 10000 rad

Note: The reference value for the AF range in the window title bar is displayed with respect to the defined reference position. The position may vary for different windows. For time domain and frequency domain windows, for example, a different reference value may be displayed, although the same reference is actually used (but the positions vary).

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


AF Coupling

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > AF Coupling
AF Coupling

Controls the automatic correction of the frequency offset and phase offset of the input signal:

This function is only available for FM or PM time domain evaluations.

  • FM time evaluation
    If DC is selected, the absolute frequency is displayed, i.e. an input signal with an offset relative to the center frequency is not displayed symmetrically with respect to the zero line.
    If AC is selected, the frequency offset is automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
  • PM time evaluation
    If DC is selected, the phase runs according to the existing frequency offset. In addition, the DC signal contains a phase offset of ± π.
    If AC is selected, the frequency offset and phase offset are automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
Remote command:

[SENSe:​]ADEMod<n>:​AF:​COUPling


Deviation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > Deviation
Deviation

Switches between logarithmic and linear display of the modulation depth or the phase deviation or the frequency deviation.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing


AF Auto Scale

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > AF Evaluation > AF Auto Scale
AF Auto Scale

Activates automatic scaling of the y-axis for AF measurements. RF power and RF spectrum measurements are not affected by the auto-scaling.

Remote command:

[SENSe:​]ADJust:​SCALe:​Y:​AUTO[:​CONTinuous]


RF Evaluation

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > RF Evaluation
RF Evaluation

The scaling parameters define the range of the demodulated data to be displayed. They are configured in the "Scaling" tab of the "Demodulation Settings" dialog box.

These settings are only available for RF evaluations and the result summary.

└ Range
└ Ref Level Position
└ Auto Scale Once
└ Scaling


Range

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > RF Evaluation > Range
Range

Defines the displayed y-axis range in dB.

The default value is 100 dB.

For Analog Demodulation measurements, time domain scaling is defined in Hz (default: 500 kHz).

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Ref Level Position

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > RF Evaluation > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

Only available for RF measurements.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Auto Scale Once

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > RF Evaluation > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Scaling

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Scaling > RF Evaluation > Scaling
Scaling

Defines the scaling method for the y-axis.

For more information see "Scaling" .

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB..., and A, V, Watt)
"Linear Unit" | Linear scaling in the unit of the measured signal
"Linear Percent" | Linear scaling in percentages from 0 to 100
"Absolute" | The labeling of the level lines refers to the absolute value of the reference level (not available for "Linear Percent")
"Relative" | The scaling is in dB, relative to the reference level (only available for logarithmic units - dB...). The upper line of the grid (reference level) is always at 0 dB.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Units

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Units
Units

The units define how the demodulated data is displayed. They are configured in the "Units" tab of the "Demodulation Settings" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Demod Settings" button in the Analog Demodulation "Overview" and select the "Units" tab.
  • Select the MEAS CONFIG key and then the "Scale Config" softkey. Then select the "Units" tab.
└ Phase Unit (Rad/Deg)
└ THD Unit (% / DB)


Phase Unit (Rad/Deg)

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Units > Phase Unit (Rad/Deg)
Phase Unit (Rad/Deg)

Sets the phase unit to rad or deg for displaying PM signals.

Remote command:

UNIT:​ANGLe


THD Unit (% / DB)

Analog Demodulation (R&S FSW-K7) > Configuration > Demodulation > Units > THD Unit (% / DB)
THD Unit (% / DB)

Sets the unit to percent or DB for the calculation of the THD (in the Result Summary).

Remote command:

UNIT:​THD


Output Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings
Output Settings
Contents
  • Output Settings
  • Analog Demodulation Output Settings


Output Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Digital I/Q output is not available for Analog Demodulation measurements.

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Analog Demodulation Output Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings
Analog Demodulation Output Settings

The demodulated signal in time domain results can be output to the IF/VIDEO/DEMOD output connector on the rear panel of the R&S FSW.

Output is not possible if the Digital Baseband Interface (R&S FSW-B17) is active.

The following settings and functions are available to configure the output in the Analog Demodulation application. They can be configured via the INPUT/OUTPUT key, in the "Output" dialog box, in the "Analog Demod" tab.

Note that the audio frequency (AF) filter settings used for demodulation also apply to the online output (see"AF Filter"). However, a maximum of two high pass, low pass or deemphasis filters can be active at the same time if analog demodulation output is active.

└ Online Demodulation Output State
└ Output Selection
└ AF Coupling
└ AC Cutoff Frequency
└ Phones Output


Online Demodulation Output State

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings > Online Demodulation Output State
Online Demodulation Output State

Enables or disables online demodulation output. If enabled, the demodulated audio frequencies are output to the IF/VIDEO/DEMOD output connector on the rear panel of the R&S FSW and, optionally, to the PHONES connector on the front panel (see "Phones Output").

Remote command:

OUTPut:​ADEMod[:​ONLine][:​STATe]


Output Selection

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings > Output Selection
Output Selection

Selects the result display whose results are output. Only time domain results can be selected. All currently active time domain result displays are listed.

"Current Focus" dynamically switches to the currently selected window. Thus you can easily change the output signal simply by selecting the windows in the display. If a window is selected that does not contain a time-domain result display, the selection is ignored and the previous setting is maintained.

The result display currently used for output is indicated by a "Demod Out" label in the window title bar.

Remote command:

OUTPut:​ADEMod[:​ONLine]:​SOURce


AF Coupling

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings > AF Coupling
AF Coupling

Controls the automatic correction of the frequency offset and phase offset of the input signal:

This function is only available for FM or PM time domain evaluations.

  • FM time evaluation
    If DC is selected, the absolute frequency is displayed, i.e. an input signal with an offset relative to the center frequency is not displayed symmetrically with respect to the zero line.
    If AC is selected, the frequency offset is automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
  • PM time evaluation
    If DC is selected, the phase runs according to the existing frequency offset. In addition, the DC signal contains a phase offset of ± π.
    If AC is selected, the frequency offset and phase offset are automatically corrected, i.e. the trace is always symmetric with respect to the zero line.
Remote command:

[SENSe:​]ADEMod<n>:​AF:​COUPling


AC Cutoff Frequency

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings > AC Cutoff Frequency
AC Cutoff Frequency

Defines the cutoff frequency for the AC highpass filter (for AC coupling only, see "AF Coupling").

Note that the audio frequency (AF) filter settings used for demodulation also apply to the online output (see"AF Filter").

Remote command:

OUTPut:​ADEMod[:​ONLine]:​AF[:​CFRequency]


Phones Output

Analog Demodulation (R&S FSW-K7) > Configuration > Output Settings > Analog Demodulation Output Settings > Phones Output
Phones Output

In addition to sending the output to the IF/VIDEO/DEMOD connector (on the rear panel of the R&S FSW), it can also be output to headphones connected on the front panel (PHONES connector).

CAUTION! Risk of hearing damage. To protect your hearing, make sure that the volume setting is not too high before putting on the headphones.

Note: If you do not hear output on the connected headphones despite having enabled both general online demodulation output (see"Online Demodulation Output State") and "Phones Output", adjust the volume setting using the rotary knob on the front panel.

Remote command:

OUTPut:​ADEMod[:​ONLine]:​PHONes


Automatic Settings

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, settings related to data acquisition cannot be adjusted for Analog Demodulation applications.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis
└ AF Auto Scale


Adjusting all Determinable Settings Automatically (Auto All)

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Frequency
  • Auto Level
  • "AF Auto Scale"

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)" )

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Remote command:

[SENSe:​]ADJust:​FREQuency


Resetting the Automatic Measurement Time (Meastime Auto)

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


AF Auto Scale

Analog Demodulation (R&S FSW-K7) > Configuration > Automatic Settings > AF Auto Scale
AF Auto Scale

Activates automatic scaling of the y-axis for AF measurements. RF power and RF spectrum measurements are not affected by the auto-scaling.

Remote command:

[SENSe:​]ADJust:​SCALe:​Y:​AUTO[:​CONTinuous]


Analysis

Analog Demodulation (R&S FSW-K7) > Analysis
Analysis

General result analysis settings concerning the trace, markers, lines etc. can be configured via the "Analysis" button in the "Overview". They are identical to the analysis functions in the base unit except for the special marker functions.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Analog Demodulation window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

The remote commands required to perform these tasks are described in "Remote Commands for Analog Demodulation Measurements".

Contents
  • Trace Settings
  • Trace / Data Export Configuration
  • Marker Settings
  • Marker Search Settings and Positioning Functions
  • Marker Function Configuration
  • Marker Peak List Configuration
  • Limit Line Settings and Functions
  • Zoom Functions
  • Analysis in MSRA/MSRT Mode


Trace Settings

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings
Trace Settings

You can configure the settings for up to 6 individual traces.

In the Analog Demodulation application when you configure the traces for a window with a specific evaluation (e.g. AM time domain), the traces in all windows with the same evaluation are configured identically.

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Trace Mode
└ Detector
└ Hold
└ Average Mode
└ Average Count
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

Remote command:

Selected via numeric suffix of:TRACe<1...6> commands


Trace Mode

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector" .

"Auto" | Selects the optimum detector for the selected trace and filter mode. This is the default setting.
"Type" | Defines the selected detector type. Note: If the EMI (R&S FSW-K54) measurement option is installed and the filter type "CISPR" is selected, additional detectors are available, even if EMI measurement is not active.
Remote command:

[SENSe:​][WINDow<n>:​]DETector<trace>[:​FUNCtion]

[SENSe:​][WINDow<n>:​]DETector<t>[:​FUNCtion]:​AUTO


Hold

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Average Mode

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Average Mode
Average Mode

Defines the mode with which the trace is averaged over several sweeps. A different averaging mode can be defined for each trace.

This setting is only applicable if trace mode "Average" is selected.

How many sweeps are averaged is defined by the "Average Count".

For details see "How Trace Data is Averaged - the Averaging Mode" .

"Linear" | The power level values are converted into linear units prior to averaging. After the averaging, the data is converted back into its original unit.
"Logarithmic" | For logarithmic scaling, the values are averaged in dBm. For linear scaling, the behavior is the same as with linear averaging.
"Power" | Activates linear power averaging. The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit. Use this mode to average power values in Volts or Amperes correctly.
Remote command:

[SENSe:​]AVERage<n>:​TYPE


Average Count

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Average Count
Average Count

Determines the number of averaging or maximum search procedures If the trace modes "Average", "Max Hold" or "Min Hold" are set.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

Remote command:

[SENSe:​]AVERage:​COUNt


Predefined Trace Settings - Quick Config

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write
 | Traces 2-6: | Blank
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold
 | Trace 2: | Average
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold
 | Trace 2: | Clear Write
 | Trace 3: | Min Hold
 | Traces 4-6: | Blank


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Analog Demodulation (R&S FSW-K7) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Trace / Data Export Configuration

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration
Trace / Data Export Configuration

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data" .

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

See "Reference: ASCII File Export Format" for details.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Analog Demodulation (R&S FSW-K7) > Analysis > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

For details on the file format see "Reference: ASCII File Export Format" .

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe:​TRACe


Marker Settings

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the Analog Demodulation "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The remote commands required to define these settings are described in "Working with Markers Remotely".

Contents
  • Individual Marker Setup
  • General Marker Settings


Individual Marker Setup

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup
Individual Marker Setup

In the Analog Demodulation application, up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Marker Type
└ Reference Marker
└ Linking to Another Marker
└ Assigning the Marker to a Trace
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?


Selected Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Marker Type

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

If a fixed reference point is configured (see "Defining a Fixed Reference"), the reference point ("FXD") can also be selected instead of another marker.

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Linking to Another Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Linking to Another Marker
Linking to Another Marker

Links the current marker to the marker selected from the list of active markers. If the x-axis value of the inital marker is changed, the linked marker follows on the same x-position. Linking is off by default.

Using this function you can set two markers on different traces to measure the difference (e.g. between a max hold trace and a min hold trace or between a measurement and a reference trace).

Remote command:

CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m>:​LINK


Assigning the Marker to a Trace

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


All Markers Off

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the Analog Demodulation "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Marker Stepsize
└ Defining a Fixed Reference
└ Link Time Marker
└ Link AF Spectrum Marker


Marker Table Display

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Stepsize

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings > Marker Stepsize
Marker Stepsize

Defines the size of the steps that the marker position is moved using the rotary knob.

"Standard" | The marker position is moved from pixel to pixel on the display. This setting is most suitable to move the marker over a larger distance.
"Sweep Points" | The marker position is moved from one sweep point to the next. This setting is required for a very precise positioning if more sweep points are collected than the number of pixels that can be displayed on the screen. It is the default mode.
Remote command:

CALCulate:​MARKer:​X:​SSIZe


Defining a Fixed Reference

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings > Defining a Fixed Reference
Defining a Fixed Reference

Instead of using a reference marker that may vary its position depending on the measurement results, a fixed reference marker can be defined for trace analysis.

When you set the "State" to "On", a vertical and a horizontal red display line are displayed, marked as "FXD". The normal marker 1 is activated and set to the peak value of the trace assigned to marker 1, and a delta marker to the next peak. The fixed reference marker is set to the position of marker 1 at the peak value. The delta marker refers to the fixed reference marker.

If activated, the fixed reference marker ("FXD") can also be selected as a "Reference Marker" instead of another marker.

The "Level" and "Frequency" or "Time" settings define the position and value of the reference marker.

Alternatively, a Peak Search can be performed to set the current maximum value of the trace assigned to marker 1 as the fixed reference marker.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed[:​STATe]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]


Link Time Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings > Link Time Marker
Link Time Marker

Links the markers in all time domain diagrams.

Remote command:

CALCulate:​MARKer<m>:​LINK


Link AF Spectrum Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Settings > General Marker Settings > Link AF Spectrum Marker
Link AF Spectrum Marker

Links the markers in all AF spectrum displays.

Remote command:

CALCulate:​MARKer<m>:​LINK


Marker Search Settings and Positioning Functions

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

The remote commands required to define these settings are described in "Working with Markers Remotely".

Contents
  • Marker Search Settings
  • Positioning Functions


Marker Search Settings

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Markers are commonly used to determine peak values, i.e. maximum or minimum values, in the measured signal. Configuration settings allow you to influence the peak search results.

These settings are are available as softkeys in the Marker To menu, or in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak
└ Peak Excursion


Search Mode for Next Peak

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Peak Excursion

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

Entries from 0 dB to 80 dB are allowed; the resolution is 0.1 dB. The default setting for the peak excursion is 6 dB.

For more information see "Searching for Signal Peaks" .

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Positioning Functions

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key, or in the "Marker" menu.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum


Select Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


Peak Search

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Marker Function Configuration

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration
Marker Function Configuration

Special marker functions can be selected via the "Marker Function" dialog box.

To display this dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab.

Not all marker functions are available for all evaluations. The following table indicates which functions are available for which evaluations.

Evaluation | n dB down | Phase Noise | Reference Fixed
AF time | - | - | X
AF spectrum | X | X | X
RF time | X | - | X
RF spectrum | X | X | X

For details on the special marker functions see "Basics on Markers and Marker Functions" .

The remote commands required to define these settings are described in "Configuring Special Marker Functions".

The Marker Peak List settings are described in "Marker Peak List Configuration".

The Fixed Reference Marker settings are described in "Defining a Fixed Reference".

Contents
  • Phase Noise Measurement Marker
  • n dB Down Marker
  • Deactivating All Marker Functions


Phase Noise Measurement Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Phase Noise Measurement Marker
Phase Noise Measurement Marker

For each of the 16 markers phase noise measurement can be activated. Phase noise measurement markers are configured in the "Phase Noise Config" dialog box, using the "Phase Noise" function.

The individual marker settings correspond to those defined in the "Marker" dialog box. Any settings to the marker state or type changed in the "Marker Function" dialog box are also changed in the "Marker" dialog box and vice versa.

To display the "Phase Noise Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Phase Noise" button. Select the "Phase Noise Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Phase Noise" button. Select the "Phase Noise Config" softkey.
└ Marker X / Delta X
└ Phase Noise Measurement State
└ Defining a Reference Point
└ Switching All Phase Noise Measurements Off


Marker X / Delta X

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Phase Noise Measurement Marker > Marker X / Delta X
Marker X / Delta X

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.


Phase Noise Measurement State

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Phase Noise Measurement Marker > Phase Noise Measurement State
Phase Noise Measurement State

Activates or deactivates phase noise measurement for the reference point in the diagram.

This function is only available for delta markers.

If activated, the delta markers display the phase noise measured at defined offsets from the reference position.

For details see "Measuring Phase Noise" .

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise[:​STATe]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise:​RESult?


Defining a Reference Point

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Phase Noise Measurement Marker > Defining a Reference Point
Defining a Reference Point

Instead of using marker 1 as the reference marker, a fixed reference marker can be defined for phase noise measurement in RF Spectrum analysis.

The "Level" and "Frequency" or "Time" settings define the position and value of the reference point.

Alternatively, a Peak Search can be performed to set the maximum value of the selected trace as the reference point.

If "Automatic Peak Search" is activated, a peak search is started automatically after each sweep and the result is used as the reference point.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise:​AUTO


Switching All Phase Noise Measurements Off

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Phase Noise Measurement Marker > Switching All Phase Noise Measurements Off
Switching All Phase Noise Measurements Off

Deactivates phase noise measurement for all markers.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise[:​STATe]


n dB Down Marker

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > n dB Down Marker
n dB Down Marker

A special marker can be defined to determine a characteristic bandwidth or time span in a measured signal. n dB down markers are configured in the "N dB Down Config" dialog box, using the "n dB down" function.

To display the "N dB Down Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "n dB down" button. Select the "N dB Down Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "n dB down" button. Select the "N dB Down Config" softkey.
└ n dB down Marker State
└ n dB down Delta Value


n dB down Marker State

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > n dB Down Marker > n dB down Marker State
n dB down Marker State

Activates or deactivates the special n dB down marker function.

For details see "Measuring Characteristic Bandwidths (n dB Down Marker)" .

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​STATe

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​RESult?


n dB down Delta Value

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > n dB Down Marker > n dB down Delta Value
n dB down Delta Value

Defines the delta level from the reference marker 1 used to determine the bandwidth or time span.

For details see "Measuring Characteristic Bandwidths (n dB Down Marker)"

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​FREQuency?

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​TIME?


Deactivating All Marker Functions

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Function Configuration > Deactivating All Marker Functions
Deactivating All Marker Functions

All special marker functions can be deactivated in one step.


Marker Peak List Configuration

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration
Marker Peak List Configuration

In the Analog Demodulation application the search limits are not available.

To display the "Marker Peak List" dialog, do one of the following:

  • Press the MKR FUNC key, then select the "Marker Peak List" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Peak List" tab.
└ Peak List State
└ Sort Mode
└ Maximum Number of Peaks
└ Peak Excursion
└ Displaying Marker Numbers
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits
└ Exporting the Peak List
└ Decimal Separator


Peak List State

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Peak List State
Peak List State

Activates/deactivates the marker peak list. If activated, the peak list is displayed and the peaks are indicated in the trace display.

For each listed peak the frequency/time ("X-value") and level ("Y-value") values are given.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​STAT


Sort Mode

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Sort Mode
Sort Mode

Defines whether the peak list is sorted according to the x-values or y-values. In either case the values are sorted in ascending order.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT


Maximum Number of Peaks

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Maximum Number of Peaks
Maximum Number of Peaks

Defines the maximum number of peaks to be determined and displayed.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​LIST:​SIZE


Displaying Marker Numbers

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Displaying Marker Numbers
Displaying Marker Numbers

By default, the marker numbers are indicated in the diagram so you can find the peaks from the list. However, for large numbers of peaks the marker numbers may decrease readability; in this case, deactivate the marker number display.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​ANNotation:​LABel[:​STATe]


Search Limits (Left / Right)

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Search Limits (Left / Right)
Search Limits (Left / Right)

If activated, limit lines are defined and displayed for the search. Only results within the limited search range are considered.

For details on limit lines for searches see "Peak search limits" .

Remote command:

CALCulate<n>:​MARKer<m>:​X:​SLIMits[:​STATe]

CALCulate<n>:​MARKer<m>:​X:​SLIMits:​LEFT

CALCulate<n>:​MARKer<m>:​X:​SLIMits:​RIGHT


Search Threshold

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate<n>:​THReshold


Using Zoom Limits

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate<n>:​MARKer<m>:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate<n>:​MARKer<m>:​X:​SLIMits[:​STATe]

CALCulate<n>:​THReshold:​STATe


Exporting the Peak List

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Exporting the Peak List
Exporting the Peak List

The peak list can be exported to an ASCII file (.DAT) for analysis in an external application.

For details see "How to Export a Peak List" .

Remote command:

MMEMory:​STORe:​PEAK

FORMat:​DEXPort:​DSEParator

└ Decimal Separator


Decimal Separator

Analog Demodulation (R&S FSW-K7) > Analysis > Marker Peak List Configuration > Exporting the Peak List > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Limit Line Settings and Functions

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions
Limit Line Settings and Functions

Up to 8 limit lines can be displayed simultaneously in the R&S FSW. Many more can be stored on the instrument.

Contents
  • Limit Line Management
  • Limit Line Details


Limit Line Management

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management
Limit Line Management

Limit lines are managed in the "Line Config" dialog box which is displayed when you press the LINES key and then "Lines Config" softkey.

For the limit line overview, the R&S FSW searches for all stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder. The overview allows you to determine which limit lines are available and can be used for the current measurement.

For details on settings for individual lines see "Limit Line Details".

For more basic information on limit lines see "Basics on Limit Lines" .

For instructions on configuring and working with limit lines see "Defining Limit Lines" .

└ Name
└ Unit
└ Compatibility
└ Visibility
└ Traces to be Checked
└ Comment
└ Included Lines in Overview (View Filter)
└ Show lines for all modes
└ X-Offset
└ Y-Offset
└ Create New Line
└ Edit Line
└ Copy Line
└ Delete Line
└ Disable All Lines


Name

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Name
Name

The name of the stored limit line.


Unit

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Unit
Unit

The unit in which the y-values of the data points of the limit line are defined.


Compatibility

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Compatibility
Compatibility

Indicates whether the limit line definition is compatible with the current measurement settings.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines" .


Visibility

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Visibility
Visibility

Displays or hides the limit line in the diagram. Up to 8 limit lines can be visible at the same time. Inactive limit lines can also be displayed in the diagram.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​STATe

CALCulate:​LIMit<k>:​UPPer:​STATe

CALCulate:​LIMit:​ACTive


Traces to be Checked

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Traces to be Checked
Traces to be Checked

Defines which traces are automatically checked for conformance with the limit lines. As soon as a trace to be checked is defined, the assigned limit line is active. One limit line can be activated for several traces simultaneously. If any of the "Traces to be Checked" violate any of the active limit lines, a message is indicated in the diagram.

Remote command:

CALCulate:​LIMit<k>:​TRACe<t>:​CHECk


Comment

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Comment
Comment

An optional description of the limit line.


Included Lines in Overview (View Filter)

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter)
Included Lines in Overview (View Filter)

Defines which of the stored lines are included in the overview.

"Show compatible"

Only compatible lines

Whether a line is compatible or not is indicated in the "Compatibility" setting.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines" .

"Show all"

All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder (if not restricted by "Show lines for all modes" setting).

└ Show lines for all modes


Show lines for all modes

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter) > Show lines for all modes
Show lines for all modes

If activated (default), limit lines from all applications are displayed. Otherwise, only lines that were created in the Spectrum application are displayed.

Note that limit lines from some applications may include additional properties that are lost when the limit lines are edited in the Spectrum application. In this case a warning is displayed when you try to store the limit line.


X-Offset

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > X-Offset
X-Offset

Shifts a limit line that has been specified for relative frequencies or times (x-axis) horizontally.

This setting does not have any effect on limit lines that are defined by absolute values for the x-axis.

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​OFFSet


Y-Offset

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Y-Offset
Y-Offset

Shifts a limit line that has relative values for the y-axis (levels or linear units such as volt) vertically.

This setting does not have any effect on limit lines that are defined by absolute values for the y-axis.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​OFFSet

CALCulate:​LIMit<k>:​UPPer:​OFFSet


Create New Line

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Create New Line
Create New Line

Creates a new limit line.

For instructions see "How to configure a new limit line" .


Edit Line

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Edit Line
Edit Line

Edit an existing limit line configuration.

For instructions see "How to edit existing limit lines" .


Copy Line

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Copy Line
Copy Line

Copy the selected limit line configuration to create a new line.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​COPY


Delete Line

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Delete Line
Delete Line

Delete the selected limit line configuration.

For instructions see "How to edit existing limit lines" .

Remote command:

CALCulate:​LIMit<k>:​DELete


Disable All Lines

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Management > Disable All Lines
Disable All Lines

Disable all limit lines in one step.

Remote command:

CALCulate:​LIMit<k>:​STATe


Limit Line Details

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details
Limit Line Details

Limit lines details are configured in the "Edit Line Line" dialog box which is displayed when you select the "New", "Edit" or "Copy To" buttons in the "Line Config" dialog box.

└ Name
└ Comment
└ Threshold
└ Margin
└ X-Axis
└ Y-Axis
└ Data points
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


Name

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Name
Name

Defines the limit line name. All names must be compatible with Windows conventions for file names. The limit line data is stored under this name (with a .LIN extension).

Remote command:

CALCulate:​LIMit<k>:​NAME


Comment

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Comment
Comment

Defines an optional comment for the limit line. The text may contain up to 40 characters.

Remote command:

CALCulate:​LIMit:​COMMent


Threshold

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Threshold
Threshold

Defines an absolute threshold value (only for relative scaling of the y-axis).

For details on thresholds see "Basics on Limit Lines" .

Remote command:

CALCulate:​LIMit<k>:​LOWer:​THReshold

CALCulate:​LIMit<k>:​UPPer:​THReshold


Margin

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Margin
Margin

Defines a margin for the limit line. The default setting is 0 dB (i.e. no margin).

For details on margins see "Basics on Limit Lines" .

Remote command:

CALCulate:​LIMit<k>:​LOWer:​MARGin

CALCulate:​LIMit<k>:​UPPer:​MARGin


X-Axis

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > X-Axis
X-Axis

Describes the horizontal axis on which the data points of the limit line are defined. Includes the following settings:

  • Domain:
    – "Hz": for frequency domain
    – "s": for time domain
  • Scaling mode: absolute or relative (Hz/s/%) values
    For relative values, the frequencies are referred to the currently set center frequency. In the zero span mode, the left boundary of the diagram is used as the reference.
  • Scaling: linear or logarithmic
Remote command:

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing

CALCulate:​LIMit<k>:​LOWer:​MODE

CALCulate:​LIMit<k>:​UPPer:​MODE

CALCulate:​LIMit<k>:​CONTrol:​DOMain


Y-Axis

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Y-Axis
Y-Axis

Describes the vertical axis on which the data points of the limit line are defined. Includes the following settings:

  • Level unit
  • Scaling mode: absolute or relative (dB/%) values
    Relative limit values refer to the reference level.
  • Limit type: upper or lower limit; values must stay above the lower limit and below the upper limit to pass the limit check
Remote command:

CALCulate:​LIMit<k>:​UNIT

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing


Data points

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Data points
Data points

Each limit line is defined by a minimum of 2 and a maximum of 200 data points. Each data point is defined by its position (x-axis) and value (y-value). Data points must be defined in ascending order. The same position can have two different values.

Remote command:

CALCulate:​LIMit<k>:​CONTrol[:​DATA]

CALCulate:​LIMit<k>:​LOWer[:​DATA]

CALCulate:​LIMit<k>:​UPPer[:​DATA]


Insert Value

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Insert Value
Insert Value

Inserts a data point in the limit line above the selected one in the "Edit Limit Line" dialog box.


Delete Value

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Delete Value
Delete Value

Deletes the selected data point in the "Edit Limit Line" dialog box.


Shift x

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift x
Shift x

Shifts the x-value of each data point horizontally by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "X-Offset").

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​SHIFt


Shift y

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Shift y
Shift y

Shifts the y-value of each data point vertically by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "Y-Offset").

Remote command:

CALCulate:​LIMit<k>:​LOWer:​SHIFt

CALCulate:​LIMit<k>:​UPPer:​SHIFt


Save

Analog Demodulation (R&S FSW-K7) > Analysis > Limit Line Settings and Functions > Limit Line Details > Save
Save

Saves the currently edited limit line under the name defined in the "Name" field.


Zoom Functions

Analog Demodulation (R&S FSW-K7) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

Analog Demodulation (R&S FSW-K7) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

Analog Demodulation (R&S FSW-K7) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

Analog Demodulation (R&S FSW-K7) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

Analog Demodulation (R&S FSW-K7) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Analysis in MSRA/MSRT Mode

Analog Demodulation (R&S FSW-K7) > Analysis > Analysis in MSRA/MSRT Mode
Analysis in MSRA/MSRT Mode

The data that was captured by the MSRA/MSRT Master can be analyzed in the Analog Demodulation application.

The analysis settings and functions available in MSRA/MSRT mode are those described for common Signal and Spectrum Analyzer mode.

See "Analysis".

Analysis line settings

In addition, an analysis line can be positioned. The analysis line is a common time marker for all MSRA/MSRT applications.

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRA/MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

Analog Demodulation (R&S FSW-K7) > Analysis > Analysis in MSRA/MSRT Mode > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

Analog Demodulation (R&S FSW-K7) > Analysis > Analysis in MSRA/MSRT Mode > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW

CALCulate:​RTMS:​ALINe:​SHOW


I/Q Data Import and Export

Analog Demodulation (R&S FSW-K7) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

For example, you can capture I/Q data using the I/Q Analyzer application, if available, and then perform a Analog Demodulation measurement on that data later using the R&S FSW Analog Demodulation application.

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


How to Perform Measurements in the Analog Demodulation Application

Analog Demodulation (R&S FSW-K7) > How to Perform Measurements in the Analog Demodulation Application
How to Perform Measurements in the Analog Demodulation Application

The following step-by-step instructions demonstrate how to perform an Analog Demodulation measurement with the R&S FSW-K7 option.

  1. Press the MODE key on the front panel and select the "Analog Demod" application.

  2. Select the "Overview" softkey to display the "Overview" for an Analog Demodulation measurement.

  3. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  4. Select the "Data Acquisition" button and define the bandwidth parameters for the input signal:

    (Note: in MSRA/MSRT mode, define the analysis interval using the same settings.)

    • "Demodulation Bandwidth": the span of the input signal to be demodulated
    • "Measurement Time": how long the input signal is to be measured
    • "Resolution Bandwidth": how precise the signal is to be demodulated
    • "Capture Offset" (multistandard mode only): the offset of the analysis interval from the start of the capture buffer

  5. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an offline demodulation trigger to start capturing data only when a useful signal is transmitted.

  6. Select the "Demod/Display" button and select the demodulation displays that are of interest to you (up to 6).

    Arrange them on the display to suit your preferences.

  7. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  8. Select the "Demodulation Settings" button to define demodulation parameters for each evaluation:

    • Configure the "Squelch" function (on the "Demod" tab) to suppress noise during demodulation.
    • For time domain evaluations, zoom into the areas of interest by defining a zoom area (on the "Demod" tab).
    • For AF evaluations, use special filters to eliminate certain effects of demodulation or to correct pre-emphasized modulated signals (on the "AF Filters" tab).
    • Adapt the diagram scaling to the displayed data (on the "Scaling" tab).

  9. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the demodulation displays.

    • Configure a trace to display the average over a series of sweeps (on the "Trace" tab; if necessary, increase the "Sweep Count" in the "Data Acquisition" settings).
    • Configure markers and delta markers to determine deviations and offsets within the demodulated signal (on the "Marker" tab).
    • Use special marker functions to calculate phase noise or an n dB down bandwidth (on the "Marker Config" tab).
    • Configure a limit check to detect excessive deviations (on the "Lines" tab).

  10. Start a new sweep with the defined settings.

    In multistandard mode you may want to stop the continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.

  11. Optionally, export the trace data of the demodulated signal to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".


Measurement Example: Demodulating an FM Signal

Analog Demodulation (R&S FSW-K7) > Measurement Example: Demodulating an FM Signal
Measurement Example: Demodulating an FM Signal

A practical example for a basic Analog Demodulation measurement is provided here. It demonstrates how operating and measurement errors can be avoided using correct configuration settings.

The measurement is performed using the following devices:

  • An R&S FSW with application firmware R&S FSW-K7: Analog Demodulation
  • A vector signal generator, e.g. R&S SMU
Test setup
Signal generator settings (e.g. R&S SMU):
Frequency: | 500 MHz
Level: | -10 dBm
Modulation: | FM
Modulation frequency: | 10 kHz
Frequency deviation: | 50 kHz
Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 500 MHz.

  3. Set the reference level to 0 dBm.

  4. Select the MODE key and then the "Analog Demod" button.

    By default, the FM Time Domain result display and a Result Summary are shown.

    Default Analog Demodulation measurement result display

  5. Set the measurement time (AQT) to 1 ms in order to measure 10 periods of the signal.

  6. Adjust the y-axis scaling to the measured frequency deviation automatically by selecting the "Scale Config" softkey and, in the "Scaling" tab, setting "AF Auto Scale" to "ON".

    Auto-scaled measurement of 10 signal periods (continuous)

  7. Display the RF spectrum of the measured signal to determine the required demodulation bandwidth. Select the "Display Config" softkey and add an "RF Spectrum" window to the display.

    RF spectrum of FM signal with default demodulation bandwidth = 5 MHz

  8. As you can see in figure "RF spectrum of FM signal with default demodulation bandwidth = 5 MHz", the default demodulation bandwidth of 5 MHz is much too large - the actual signal takes up only a small part of the displayed range. That means that any noise or additional signals apart from the FM signal of interest may be included in the measured results. Select the "Demod BW" softkey and reduce the value to 200 kHz.

    RF spectrum with demodulation bandwidth = 200 kHz

    The span is automatically reduced to 200 kHz as well, as only the demodulated range can be displayed.

  9. Now the RF spectrum shows that part of the FM signal is cut off. The missing signal parts are not included in the calculated results. Increase the demodulation bandwidth to 400 kHz to include the entire signal, but no interfering frequencies.

    The span is not automatically increased for the wider DBW since it may be useful to display only a small range from the demodulated bandwidth. However, this means the RF spectrum will still not show the entire signal.

  10. Increase the span manually to show the entire demodulated bandwidth:

    1. Select the RF Spectrum window.

    2. Press the SPAN key.

    3. Select the "Full Span" softkey.

    RF spectrum with demodulation bandwidth = 400 kHz

  11. Once the correct DBW has been determined, you can replace the RF spectrum by the FM spectrum result display to analyze the spectrum of the FM signal. Select the "Display Config" softkey and move an "FM Spectrum" window over the "RF Spectrum" window in the display.

    FM spectrum and Result Summary including SINAD and THD values

    From the FM spectrum, the SINAD and THD are also calculated and displayed in the Result Summary.

  12. Since the "AF Auto Scale" function is enabled, the "FM Spectrum" diagram is scaled according to the current measurement automatically. Each diagram is scaled individually, so that the reference values at the top of the two diagrams can differ (100 kHz in the "FM Time Domain" versus 50 kHz in the "FM Spectrum". However, you can adjust the values manually.

    1. Select the "FM Spectrum" window to set the focus in it.

    2. Press the AMPT key and select the "Scale Config" softkey.

    3. Disable the "AF Auto Scale" function.

    4. Define the new reference value (at 100% = top of the diagram) as 100 kHz.

    Note that while the reference values at the top of both y-axes are now identical, the reference values indicated in the window title bars are not. This is due to the fact that, by default, in AF time domain displays the reference value is defined at the reference position 50 % (=center of diagram), while in AF frequency domains it is defined at the position 100 % (= top of diagram).


Optimizing and Troubleshooting the Measurement

Analog Demodulation (R&S FSW-K7) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, consider the following notes and tips to optimize the measurement.

Determining the demodulation bandwidth

A frequent cause for measurement errors and false results is an incorrectly defined demodulation bandwidth (DBW).

If the DBW is too large, the actual signal takes up only a small part of the demodulated range. That means that any noise or additional signal parts may be included in the measured results, which are then false.

On the other hand, if the DBW is too small, part of the signal is cut off and thus not included in the calculation of the results.

An easy way to determine the required DBW is to display the RF spectrum of the input signal. If the entire signal is displayed there and takes up most of the diagram width, the DBW should be appropriate.

This procedure is demonstrated in the measurement example described in "Measurement Example: Demodulating an FM Signal".

For further recommendations on finding the correct demodulation bandwidth see "Demodulation Bandwidth".

Adjusting the displayed span

Be aware that the span of the RF Spectrum display is not automatically increased for a wider DBW, since it may be useful to display only a small range from the demodulated bandwidth. However, this means the RF spectrum may not show the entire demodulated bandwidth. In this case you must increase the span manually to show the entire signal.

Determining the SINAD and THD

The signal-to-noise-and-distortion ratio (SINAD) and the total harmonic distortion (THD) of the demodulated signal are a good indicator of the signal quality sent by the DUT. Both values are calculated inside the AF spectrum span and thus only if an AF spectrum window is displayed. If either value deviates strongly from the expected result, make sure the demodulation bandwidth is defined correctly (see "Determining the demodulation bandwidth").


Remote Commands for Analog Demodulation Measurements

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements
Remote Commands for Analog Demodulation Measurements

The commands required to perform measurements in the Analog Demodulation application in a remote environment are described here.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

A programming example at the end of the remote commands description demonstrates the most important commands in a typical application scenario, see "Programming Example".

Status registers

The R&S FSW-K7 option uses the status registers of the base unit (except for the STATus:QUEStionable:ACPLimit register).

(See "Status Reporting System" .)

General R&S FSW Remote Commands
The application-independent remote commands for general tasks on the R&S FSW are also available for Analog Demodulation measurements and are described in the base unit section. In particular, this comprises the following functionality:
  • "Managing Settings and Results"
  • "Configuring the "
  • "Using the Status Register"
Channel-specific commands

Apart from a few general commands on the R&S FSW, most commands refer to the currently active channel. Thus, always remember to activate an Analog Demodulation channel before starting a remote program for an Analog Demodulation measurement.

Contents
  • Introduction
  • Common Suffixes
  • Activating Analog Demodulation Measurements
  • Configuring the Measurement
  • Capturing Data and Performing Sweeps
  • Configuring the Result Display
  • Retrieving Results
  • Analyzing Results
  • Importing and Exporting I/Q Data and Results
  • Commands for Compatibility
  • Programming Example


Introduction

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Common Suffixes
Common Suffixes

In the Analog Demodulation application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<k> | 1..8 | Limit line
<m> | 1..16 | Marker
<n> | 1..6 | Window or Evaluation
<t> | 1..6 | Trace


Activating Analog Demodulation Measurements

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements
Activating Analog Demodulation Measurements

Analog demodulation measurements require a special application on the R&S FSW. The measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA/MSRT Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

Selects the channel type for the current channel.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
ADEMod

Analog Demodulation application, R&S FSW–K7


SYSTem:PRESet:CHANnel[:EXECute]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Activating Analog Demodulation Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Configuring the Measurement

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement
Configuring the Measurement

The following remote commands are required to configure an Analog Demodulation measurement.

Useful commands described elsewhere:
  • "Configuring the Trace Display and Retrieving Trace Data"
Specific commands:
Contents
  • Managing Standard Settings
  • Configuring the Input
  • Configuring the Output
  • Frequency Settings
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Configuring Data Acquisition
  • Triggering
  • Configuring Demodulation
  • Adjusting Settings Automatically
  • Configuring Standard Traces


Managing Standard Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Managing Standard Settings
Managing Standard Settings

You can configure the Analog Demodulation application using predefined standard settings. This allows for quick and easy configuration for commonly performed measurements.

For details see "Configuration According to Digital Standards".

For an overview of predefined standards and settings see "Predefined Standards and Settings".

List of Commands
[SENSe:]ADEMod:PRESet[:STANdard]
[SENSe:]ADEMod:PRESet:RESTore
[SENSe:]ADEMod:PRESet:STORe


[SENSe:]ADEMod:PRESet[:STANdard]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Managing Standard Settings > [SENSe:]ADEMod:PRESet[:STANdard]
[SENSe:]ADEMod:PRESet[:STANdard] <Standard>

This command loads a measurement configuration.

Standard definitions are stored in an xml file. The default directory for Analog Demodulation standards is C:\r_s\instr\user\predefined\AdemodPredefined.

Parameters:
<Standard> | String containing the file name. If you have stored the file in a subdirectory of the directory mentioned above, you have to include the relative path to the file.
Return values:
<Standard> | The query returns the name of the currently loaded standard.
Manual operation: | See "Load Standard"


[SENSe:]ADEMod:PRESet:RESTore

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Managing Standard Settings > [SENSe:]ADEMod:PRESet:RESTore
[SENSe:]ADEMod:PRESet:RESTore

This command restores the default configurations of predefined Analog Demodulation standards.

Note that the command will overwrite customized standards that have the same name as predefined standards.

Usage: | Event
Manual operation: | See "Restore Standard Files"


[SENSe:]ADEMod:PRESet:STORe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Managing Standard Settings > [SENSe:]ADEMod:PRESet:STORe
[SENSe:]ADEMod:PRESet:STORe <Standard>

This command saves the current Analog Demodualtion measurement configuration.

Standard definitions are stored in an xml file. The default directory for Analog Demodualtion standards is C:\r_s\instr\user\predefined\AdemodPredefined.

Parameters:
<Standard> | String containing the file name. You can save the file in a subdirectory of the directory mentioned above. In that case, you have to include the relative path to the file.
Manual operation: | See "Save Standard"


Configuring the Input

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input
Configuring the Input
Contents
  • RF Input
  • Using External Mixers
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Configuring Digital I/Q Input and Output
  • Setting up Probes
  • Working with Power Sensors
  • External Generator Control


RF Input

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"
See "Unit"


INPut:SELect

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Using External Mixers

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers" .

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Configuring Digital I/Q Input and Output

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO


INPut:DIQ:CDEVice

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


Setting up Probes

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Working with Power Sensors

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors
Working with Power Sensors

The following commands describe how to work with power sensors.

Contents
  • Configuring Power Sensors
  • Configuring Power Sensor Measurements
  • Triggering with Power Sensors


Configuring Power Sensors

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensors
Configuring Power Sensors
List of Commands
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine


SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe] <State>

This command turns automatic assignment of a power sensor to the power sensor index on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: SYST:COMM:RDEV:PMET:CONF:AUTO OFF


SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

This command queries the number of power sensors currently connected to the R&S FSW.

Parameters:
<NumberSensors> | Number of connected power sensors.
Example: | SYST:COMM:RDEV:PMET:COUN?
Usage: | Query only


SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine <Placeholder>, <Type>, <Interface>, <SerialNo>

This command assigns the power sensor with the specified serial number to the selected power sensor index (configuration).

The query returns the power sensor type and serial number of the sensor assigned to the specified index.

Suffix: |
<p> | 1...4 Power sensor index
Setting parameters:
<Placeholder> | Currently not evaluated
<SerialNo> | Serial number of a connected power sensor
Query parameters:
<Type> | The power sensor type, e.g. "NRP-Z81".
<Interface> | Currently not evaluated
Return values:
<Placeholder> | Currently not used
<Type> | Detected power sensor type, e.g. "NRP-Z81".
<Interface> | Interface the power sensor is connected to; always "USB"
<SerialNo> | Serial number of the power sensor assigned to the specified index
Example: | SYST:COMM:RDEV:PMET2:DEF '','NRP-Z81','','123456' Assigns the power sensor with the serial number '123456' to the configuration "Power Sensor 2". SYST:COMM:RDEV:PMET2:DEF? Queries the sensor assigned to "Power Sensor 2". Result: '','NRP-Z81','USB','123456' The NRP-Z81 power sensor with the serial number '123456' is assigned to the "Power Sensor 2".


Configuring Power Sensor Measurements

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements
Configuring Power Sensor Measurements
List of Commands
CALibration:PMETer<p>:ZERO:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative:STATe
FETCh:PMETer<p>?
READ:PMETer<p>?
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio


CALibration:PMETer<p>:ZERO:AUTO ONCE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > CALibration:PMETer<p>:ZERO:AUTO ONCE
CALibration:PMETer<p>:ZERO:AUTO ONCE

This commands starts to zero the power sensor.

Note that you have to disconnect the signals from the power sensor input before you start to zero the power sensor. Otherwise, results are invalid.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CAL:PMET2:ZERO:AUTO ONCE;*WAI Starts zeroing the power sensor 2 and delays the execution of further commands until zeroing is concluded.
Usage: | Event


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude] <RefValue>

This command defines the reference value for relative measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<RefValue>
Range: | -200 dBm to 200 dBm
*RST: | 0
Example: CALC:PMET2:REL -30

Sets the reference value for relative measurements to -30 dBm for power sensor 2.


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

This command sets the current measurement result as the reference level for relative measurements.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CALC:PMET2:REL:AUTO ONCE Takes the current measurement value as reference value for relative measurements for power sensor 2.
Usage: | Event


CALCulate<n>:PMETer<p>:RELative:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative:STATe <State>

This command turns relative power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:PMET2:REL:STAT ON

Activates the relative display of the measured value for power sensor 2.


FETCh:PMETer<p>?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > FETCh:PMETer<p>?
FETCh:PMETer<p>?

This command queries the results of power sensor measurements.

Suffix: |
<p> | 1...4 Power sensor index
Return values:
<Level> | Power level that has been measured by a power sensor. The unit is either dBm (absolute measurements) or dB (relative measurements).
Usage: | Query only


READ:PMETer<p>?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > READ:PMETer<p>?
READ:PMETer<p>?

This command initiates a power sensor measurement and queries the results.

Suffix: |
<p> | 1...4 Power sensor index
Usage: | Query only


[SENSe:]PMETer<p>:DCYCle[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle[:STATe] <State>

This command turns the duty cycle correction on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:DCYC:STAT ON


[SENSe:]PMETer<p>:DCYCle:VALue

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle:VALue <Percentage>

This command defines the duty cycle for the correction of pulse signals.

The power sensor uses the duty cycle in combination with the mean power to calculate the power of the pulse.

Suffix:
<p>
1...4

Power sensor

Parameters:
<Percentage>
Range: | 0.001 to 99.999
*RST: | 99.999
Default unit: | %
Example: PMET2:DCYC:STAT ON

Activates the duty cycle correction.

PMET2:DCYC:VAL 0.5

Sets the correction value to 0.5%.


[SENSe:]PMETer<p>:FREQuency

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency <Frequency>

This command defines the frequency of the power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Frequency>

The available value range is specified in the data sheet of the power sensor in use.

*RST: 50 MHz
Example: PMET2:FREQ 1GHZ

Sets the frequency of the power sensor to 1 GHz.


[SENSe:]PMETer<p>:FREQuency:LINK

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:FREQuency:LINK <Coupling>

This command selects the frequency coupling for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Coupling>
CENTer

Couples the frequency to the center frequency of the analyzer

MARKer1

Couples the frequency to the position of marker 1

OFF

Switches the frequency coupling off

*RST: CENTer
Example: PMET2:FREQ:LINK CENT

Couples the frequency to the center frequency of the analyzer


[SENSe:]PMETer<p>:MTIMe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe <Duration>

This command selects the duration of power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Duration>
SHORt | NORMal | LONG
*RST: NORMal
Example: PMET2:MTIM SHOR

Sets a short measurement duration for measurements of stationary high power signals for the selected power sensor.


[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt <NumberReadings>

This command sets the number of power readings included in the averaging process of power sensor measurements.

Extended averaging yields more stable results for power sensor measurements, especially for measurements on signals with a low power, because it minimizes the effects of noise.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<NumberReadings>

An average count of 0 or 1 performs one power reading.

Range: | 0 to 256
Increment: | binary steps (1, 2, 4, 8, ...)
Example: PMET2:MTIM:AVER ON

Activates manual averaging.

PMET2:MTIM:AVER:COUN 8

Sets the number of readings to 8.


[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe] <State>

This command turns averaging for power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:MTIM:AVER ON

Activates manual averaging.


[SENSe:]PMETer<p>:ROFFset[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe] <State>

This command includes or excludes the reference level offset of the analyzer for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | 1

Includes the reference level offset in the results.

OFF | 0

Ignores the reference level offset.

*RST: 1
Example:

PMET2:ROFF OFF

Takes no offset into account for the measured power.


[SENSe:]PMETer<p>[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>[:STATe] <State>

This command turns a power sensor on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1 ON

Switches the power sensor measurements on.


[SENSe:]PMETer<p>:UPDate[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe] <State>

This command turns continuous update of power sensor measurements on and off.

If on, the results are update even if a single sweep is complete.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1:UPD ON

The data from power sensor 1 is updated continuously.


UNIT<n>:PMETer<p>:POWer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer <Unit>

This command selects the unit for absolute power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DBM | WATT | W
*RST: DBM
Example: UNIT:PMET:POW DBM


UNIT<n>:PMETer<p>:POWer:RATio

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer:RATio
UNIT<n>:PMETer<p>:POWer:RATio <Unit>

This command selects the unit for relative power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DB | PCT
*RST: DB
Example: UNIT:PMET:POW:RAT DB


Triggering with Power Sensors

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors
Triggering with Power Sensors
List of Commands
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]


[SENSe:]PMETer<p>:TRIGger:DTIMe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:DTIMe <Time>

This command defines the time period that the input signal has to stay below the IF power trigger level before the measurement starts.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Time>
Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 100 µs
Example: PMET2:TRIG:DTIMe 0.001


[SENSe:]PMETer<p>:TRIGger:HOLDoff

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HOLDoff <Holdoff>

This command defines the trigger holdoff for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Holdoff>

Time period that has to pass between the trigger event and the start of the measurement, in case another trigger event occurs.

Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 0 s
Example: PMET2:TRIG:HOLD 0.1

Sets the holdoff time of the trigger to 100 ms


[SENSe:]PMETer<p>:TRIGger:HYSTeresis

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis for external power triggers.

The hysteresis in dB is the value the input signal must stay below the IF power trigger level in order to allow a trigger to start the measurement.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
Increment: | 1 dB
*RST: | 0 dB
Example: PMET2:TRIG:HYST 10

Sets the hysteresis of the trigger to 10 dB.


[SENSe:]PMETer<p>:TRIGger:LEVel

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:LEVel <Level>

This command defines the trigger level for external power triggers.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Level>
-20 to +20 dBm
Range: | -20 dBm to 20 dBm
*RST: | -10 dBm
Example: PMET2:TRIG:LEV -10 dBm

Sets the level of the trigger


[SENSe:]PMETer<p>:TRIGger:SLOPe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger:SLOPe <Edge>

This command selects the trigger condition for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Edge>
POSitive

The measurement starts in case the trigger signal shows a positive edge.

NEGative

The measurement starts in case the trigger signal shows a negative edge.

*RST: POSitive
Example: PMET2:TRIG:SLOP NEG


[SENSe:]PMETer<p>:TRIGger[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:TRIGger[:STATe] <State>

This command turns the external power trigger on and off.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:TRIG ON

Switches the external power trigger on


External Generator Control

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control
External Generator Control

External generator control commands are available if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Measurement Configuration
  • Interface Configuration
  • Source Calibration
  • Programming Example for External Generator Control


Measurement Configuration

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration
Measurement Configuration

The following commands are required to activate external generator control and to configure a calibration measurement with an external tracking generator.

List of Commands
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet


SOURce:EXTernal:FREQuency

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency <Frequency>

This command defines a fixed source frequency for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Frequency>

Source frequency of the external generator.

*RST: 1100050000
Example:

SOUR:EXT:FREQ 10MHz

Manual operation: See "(Manual) Source Frequency"


SOURce:EXTernal:FREQuency:COUPling[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:COUPling[:STATe] <State>

This command couples the frequency of the external generator output to the R&S FSW.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)

OFF | 0

The generator uses a single fixed frequency, defined by SOURce:​EXTernal:​FREQuency.

*RST: 1
Example: SOUR:EXT:FREQ:COUP ON
Example:

See "Programming Example for External Generator Control"

Manual operation: See "Source Frequency Coupling"


SOURce:EXTernal:FREQuency[:FACTor]:DENominator

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:DENominator <Value>

This command defines the denominator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency[:FACTor]:NUMerator

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator <Value>

This command defines the numerator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency:OFFSet <Offset>

This command defines the frequency offset of the generator with reference to the analyzer frequency.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the offset such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Offset>
<numeric value>, specified in Hz, kHz, MHz or GHz, rounded to the nearest Hz
*RST: 0 Hz
Example: SOUR:EXT:FREQ:OFFS 10HZ

Sets an offset of the generator output frequency compared to the analyzer frequency of 10 Hz.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:POWer[:LEVel]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:POWer[:LEVel] <Level>

This command sets the output power of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<Level>
<numeric value>
*RST: -20 dBm
Example: SOUR:EXT:POW -30dBm

Sets the generator level to -30 dBm

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source Power"


SOURce:EXTernal[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:EXTernal[:STATe]
SOURce:EXTernal[:STATe] <State>

This command activates or deactivates the connected external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source State"


SOURce:POWer[:LEVel][:IMMediate]:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Measurement Configuration > SOURce:POWer[:LEVel][:IMMediate]:OFFSet
SOURce:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

This command defines a level offset for the external generator level. Thus, for example, attenuators or amplifiers at the output of the external generator can be taken into account for the setting.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Offset>
Range: | -200 dB to +200 dB
*RST: | 0dB
Example: SOUR:POW:OFFS -10dB

Sets the level offset of the external generator to – 20 dBm.

Usage: SCPI confirmed
Manual operation: See "Source Offset"


Interface Configuration

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration
Interface Configuration

The following commands are required to configure the interface for the connection to the external generator.

List of Commands
SOURce:EXTernal:ROSCillator[:SOURce]
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess


SOURce:EXTernal:ROSCillator[:SOURce]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal:ROSCillator[:SOURce] <Source>

This command controls selection of the reference oscillator for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

If the external reference oscillator is selected, the reference signal must be connected to the rear panel of the instrument.

Parameters:
<Source>
INTernal

the internal reference is used

EXTernal

the external reference is used; if none is available, an error flag is displayed in the status bar

*RST: INT
Example: SOUR:EXT:ROSC EXT

Switches to external reference oscillator

Manual operation: See "Reference"


SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess <Number>

Changes the IEC/IEEE-bus address of the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Number>
Range: | 0 to 30
*RST: | 28
Example: SYST:COMM:GPIB:RDEV:GEN:ADDR 15
Example:

See "Programming Example for External Generator Control".

Manual operation: See "GPIB Address / TCP/IP Address"


SYSTem:COMMunicate:RDEVice:GENerator:INTerface

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:INTerface <Type>

Defines the interface used for the connection to the external generator.

Parameters:
<Type>
GPIB | TCPip
*RST: GPIB
Example: SYST:COMM:RDEV:GEN:INT TCP
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Interface"


SYSTem:COMMunicate:RDEVice:GENerator:LINK

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:LINK <Type>

This command selects the link type of the external generator if the GPIB interface is used.

The difference between the two GPIB operating modes is the execution speed. While, during GPIB operation, each frequency to be set is transmitted to the generator separately, a whole frequency list can be programmed in one go if the TTL interface is also used. Frequency switching can then be performed per TTL handshake which results in considerable speed advantages.

Parameters:
<Type>
GPIB | TTL
GPIB

GPIB connection without TTL synchronization (for all generators of other manufacturers and some Rohde & Schwarz devices)

TTL

GPIB connection with TTL synchronization (if available; for most Rohde&Schwarz devices)

*RST: GPIB
Example: SYST:COMM:RDEV:GEN:LINK TTL

Selects GPIB + TTL interface for generator operation.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "TTL Handshake"


SYSTem:COMMunicate:RDEVice:GENerator:TYPE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:GENerator:TYPE <Type>

This command selects the type of external generator.

For a list of the available generator types see "Overview of Generators Supported by the R&S FSW-B10 Option".

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Name>
<Generator name as string value>
*RST: SMU02
Example: SYST:COMM:RDEV:GEN2:TYPE 'SME02'

Selects SME02 as generator 2

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Generator Type"


SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Interface Configuration > SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess <Address>

Configures the TCP/IP address for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Address>
TCP/IP address between 0.0.0.0 and 0.255.255.255
*RST: 0.0.0.0
Example: SYST:COMM:TCP:RDEV:GEN:ADDR 130.094.122.195
Manual operation: See "GPIB Address / TCP/IP Address"


Source Calibration

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration
Source Calibration

The following commands are required to activate the calibration functions of the external tracking generator. However, they are only available if external generator control is active (see SOURce:​EXTernal[:​STATe]).

Remote commands exclusive to source calibration:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection[:STATe]
[SENSe:]CORRection:TRANsducer:GENerator


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Reference Value"


[SENSe:]CORRection:COLLect[:ACQuire]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > [SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:COLLect[:ACQuire] <MeasType>

This command initiates a reference measurement (calibration). The reference measurement is the basis for the measurement normalization. The result depends on whether a reflection measurement or transmission measurement is performed (see [SENSe:​]CORRection:​METHod).

To obtain a correct reference measurement, a complete sweep with synchronization to the end of the sweep must have been carried out. This is only possible in the single sweep mode.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<MeasType> | THRough "TRANsmission" mode: calibration with direct connection between external generator and device input "REFLection" mode: calibration with short circuit at the input OPEN only allowed in "REFLection" mode: calibration with open input
Example: | INIT:CONT OFF Selects single sweep operation CORR:METH TRAN Selects a transmission measurement. CORR:COLL THR;*WAI Starts the measurement of reference data using direct connection between generator and device input and waits for the sweep end.
Example: | See "Programming Example for External Generator Control".
Usage: | Setting only SCPI confirmed
Manual operation: | See "Calibrate Reflection Short" See "Calibrate Reflection Open"


[SENSe:]CORRection:METHod

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > [SENSe:]CORRection:METHod
[SENSe:]CORRection:METHod

This command selects the type of measurement to be performed with the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:

REFLection

Selects reflection measurements.

TRANsmission

Selects transmission measurements.

*RST: TRANsmission
Example: CORR:METH TRAN

Sets the type of measurement to "transmission".

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Calibrate Transmission"
See "Calibrate Reflection Short"
See "Calibrate Reflection Open"


[SENSe:]CORRection:RECall

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > [SENSe:]CORRection:RECall
[SENSe:]CORRection:RECall

This command restores the measurement configuration used for calibration.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Example: | CORR:REC
Usage: | Event
Manual operation: | See "Recall"


[SENSe:]CORRection[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > [SENSe:]CORRection[:STATe]
[SENSe:]CORRection[:STATe] <State>

This command turns correction of measurement results (normalization) on and off.

The command is available after you have created a reference trace for the selected measurement type with [SENSe:​]CORRection:​COLLect[:​ACQuire].

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CORR ON

Activates normalization.

Example:

See "Programming Example for External Generator Control".

Usage: SCPI confirmed
Manual operation: See "Source Calibration Normalize"


[SENSe:]CORRection:TRANsducer:GENerator

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Source Calibration > [SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection:TRANsducer:GENerator <Name>

This command uses the normalized measurement data to generate a transducer factor with up to 1001 points. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between start and stop frequency.

The generated transducer factor can be further adapted using the commands described in "Working with Transducers" ).

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active and normalization is switched on.

Parameters:
<Name> | '<name>
Example: | CORR:TRAN:GEN 'SMU01' Creates the transducer file C:\r_s\instr\trd\SMU01.trd.
Usage: | SCPI confirmed
Manual operation: | See "Save As Trd Factor"


Programming Example for External Generator Control

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Input > External Generator Control > Programming Example for External Generator Control
Programming Example for External Generator Control

The following example demonstrates how to work with an external generator in a remote environment.

It assumes a signal generator of the type SMU04 is connected to the R&S FSW, including TTL synchronization, as described in "External Generator Connections".

//--------------Preparing the instrument -----------

//Reset the instrument
*RST

//Set the frequency span.
SENS:FREQ:STAR 10HZ
SENS:FREQ:STOP 1MHZ

//--------------Configuring the interface -----------

//Set the generator type to SMU04 with a frequency range of 100 kHz to 4GHz
SYST:COMM:RDEV:GEN:TYPE 'SMU04'

//Set the interface used to the GPIB address 28
SYST:COMM:RDEV:GEN:INT GPIB
SYST:COMM:GPIB:RDEV:GEN:ADDR 28

//Activate the use of TTL synchronization to optimize measurement speed
SYST:COMM:RDEV:GEN:LINK TTL

//Activate the use of the external reference frequency at 10 MHz on the generator
SOUR:EXT:ROSC EXT

//--------------Configuring the calibration measurement -----------

//Activate external generator control.
SOUR:EXT:STAT ON
//Set the generator output level to -10 dBm.
SOUR:EXT:POW -10DBM
//Set the frequency coupling to automatic
SOUR:EXT:FREQ:COUP:STAT ON

//--------------Configuring the generator frequency range -----------

//Define a series of frequencies (one for each sweep point) based on the current
//frequency at the RF input of the analyzer; the generator frequency is half the
//frequency of the analyzer, with an offset of 100 kHz;
// analyzer start:            10 Hz
// analyzer stop:             1 MHz
// analyzer span:             999.99 KHz
// generator frequency start: 100.005 KHz
// generator frequency stop:  600 KHz
// generator span:            499.995 KHz

SOUR:EXT:FREQ:FACT:NUM 1
SOUR:EXT:FREQ:FACT:DEN 2
SOUR:EXT:FREQ:OFFS 100KHZ

//--------------Performing the calibration measurement -----------

//Perform a transmission measurement with direct connection between the generator
//and the analyzer and wait till the end
SENS:CORR:METH TRAN
SENS:CORR:COLL:ACQ THR; *WAI

//--------------Retrieving the calibration trace results -----------

//Retrieve the measured frequencies (10 Hz - 600 kHz)
TRAC:DATA:X? TRACE1

//Retrieve the measured power levels; = 0 between 10 Hz and 100 kHz (below
//generator minimum frequency); nominal -5dBm as of 100 kHz;
TRAC:DATA? TRACE1

//--------------Normalizing the calibration trace results -----------

//Retrieve the normalized power levels (= power offsets from calibration results)
//Should be 0 for all sweep points directly after calibration
SENS:CORR:STAT ON
TRAC:DATA? TRACE1

//--------------Changing the display of the calibration results -----------
//Shift the reference line so the -5 dB level is displayed in the center
DISP:TRAC:Y:SCAL:RVAL -5DB
DISP:TRAC:Y:SCAL:RPOS 50PCT


Configuring the Output

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output
Configuring the Output

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:ADEMod[:ONLine][:STATe]
OUTPut:ADEMod[:ONLine]:SOURce
OUTPut:ADEMod[:ONLine]:AF[:CFRequency]
OUTPut:ADEMod[:ONLine]:PHONes


DIAGnostic:SERVice:NSOurce

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:ADEMod[:ONLine][:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output > OUTPut:ADEMod[:ONLine][:STATe]
OUTPut:ADEMod[:ONLine][:STATe] <State>

This command enables or disables online demodulation output to the IF/VIDEO/DEMOD output connector on the rear panel of the R&S FSW.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:ADEM ON
Manual operation: See "Online Demodulation Output State"


OUTPut:ADEMod[:ONLine]:SOURce

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output > OUTPut:ADEMod[:ONLine]:SOURce
OUTPut:ADEMod[:ONLine]:SOURce <WindowName>

This command selects the result display whose results are output. Only active time domain results can be selected.

Parameters:
<WindowName>
<string>

String containing the name of the window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

FOCus

Dynamically switches to the currently selected window. If a window is selected that does not contain a time-domain result display, the selection is ignored and the previous setting is maintained.

Example: OUTP:ADEM:ONL:SOUR 'AnalogDemod'

OR:

DISP:WIND1:SEL
OUTP:ADEM:SOUR FOC
Manual operation: See "Output Selection"


OUTPut:ADEMod[:ONLine]:AF[:CFRequency]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output > OUTPut:ADEMod[:ONLine]:AF[:CFRequency]
OUTPut:ADEMod[:ONLine]:AF[:CFRequency] <Frequency>

This command defines the cutoff frequency for the AC highpass filter (for AC coupling only, see [SENSe:​]ADEMod<n>:​AF:​COUPling).

Parameters:
<Frequency>
numeric value
Range: | 10 Hz to DemodBW/10 (= 300 kHz for active demodulation output)
*RST: | 100 Hz
Example: OUTP:ADEM:ONL:AF:CFR 100Hz
Manual operation: See "AC Cutoff Frequency"


OUTPut:ADEMod[:ONLine]:PHONes

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Output > OUTPut:ADEMod[:ONLine]:PHONes
OUTPut:ADEMod[:ONLine]:PHONes <State>

In addition to sending the output to the IF/VIDEO/DEMOD output connector (on the rear panel of the R&S FSW), it can also be output to headphones connected on the front panel (PHONES connector).

CAUTION: To protect your hearing, make sure that the volume setting is not too high before putting on the headphones.

If you do not hear output on the connected headphones despite having enabled both general online demod output OUTPut:​ADEMod[:​ONLine][:​STATe] and this command, adjust the volume setting using the rotary knob on the front panel.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:ADEM:PHON ON
Manual operation: See "Phones Output"


Frequency Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Frequency Settings
Frequency Settings
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor


[SENSe:]FREQuency:CENTer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Frequency Settings > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Frequency Settings > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:LINK

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Frequency Settings > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

(for RF spectrum result display)

RBW

Couples the step size to the resolution bandwidth. Available for measurements in the time domain.

(for all result displays except RF spectrum)

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN
Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Frequency Settings > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>

This command defines a step size factor if the center frequency step size is coupled to the span or the resolution bandwidth.

Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT
Manual operation: See "Center Frequency Stepsize"


Configuring the Vertical Axis (Amplitude, Scaling)

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Configuring the Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis


Amplitude Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings
Useful commands for amplitude configuration described elsewhere:
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude configuration:
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:UNIT:POWer
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet


CALCulate<n>:MARKer<m>:FUNCtion:REFerence

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:REFerence

This command matches the reference level to the power level of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:REF Sets the reference level to the level of marker 2.
Usage: | Event


CALCulate<n>:UNIT:POWer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Unit"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


Configuring the Attenuation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the preamplification is defined by INPut:​GAIN[:​VALue].

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis
Scaling the Y-Axis
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Parameters:
<Range>

If the y-axis shows the power, the unit is dB with a range from 10 dB to 200 dB.

If the y-axis shows the frequency, the unit is Hz with a variable range.

*RST: 100 dB (frequency domain), 500 kHz (time domain)
Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Range"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL
Manual operation: See "Scaling"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

For measurements with the external generator (R&S FSW-B10) the command defines the position of the reference value.

Parameters:
<Position>
*RST: 100 PCT = AF spectrum display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Position"
See "Reference Value Position"
See "Ref Level Position"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

For AF spectrum displays, only the parameters "LINear" and "LOGarithmic" are permitted.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Deviation"
See "Scaling"


Configuring Data Acquisition

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition
Configuring Data Acquisition

The following remote commands are required to configure which data is to be acquired and then demodulated in a remote environment.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition commands for the Analog Demodulation application in MSRA/MSRT mode define the analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

List of Commands
[SENSe:]ADEMod:MTIMe
[SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:SET
[SENSe:]ADEMod:SPECtrum:BANDwidth|BWIDth[:RESolution]
[SENSe:]ADEMod:SRATe?
[SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:POINts


[SENSe:]ADEMod:MTIMe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]ADEMod:MTIMe
[SENSe:]ADEMod:MTIMe <Time>

This command defines the measurement time for analog demodulation.

Parameters:
<Time>
*RST: 62.5us
Example:

ADEM:MTIM 62.5us

Sets the measurement time to 62.5 μs.

Example:

See "Programming Example".

Manual operation: See "Measurement Time (AQT)"


[SENSe:]ADEMod:RLENgth?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:RLENgth?

This command returns the record length set up for the current analog demodulation measurement.

Example: | ADEM:RLEN? Returns the current record length.
Usage: | Query only


[SENSe:]ADEMod:SET

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]ADEMod:SET
[SENSe:]ADEMod:SET <SampleRate> | <RecordLength> | <TriggerSource> | <TriggerSlope> | <OffsetSamples> | <NoOfMeas>

This command configures the analog demodulator of the instrument.

Parameters:
<SampleRate>
numeric value

The frequency at which measurement values are taken from the A/D-converter and stored in I/Q memory.

Allowed range: refer to "Sample Rate, Measurement Time and Trigger Offset".

*RST: 8 MHz
<RecordLength>

Number of samples to be stored in I/Q memory.

Range: | 1 to 400001 with AF filter or AF trigger active, 1 to 480001 with both AF filter and AF trigger deactive
*RST: | 501)
<TriggerSource>

Selection of the trigger source to use for the demodulator. For details on trigger sources see "Trigger Source".

IMMediate | EXTernal | EXT2 | EXT3 | IFPower | RFPower| AF | AM | AMRelative | FM | PM

Note: After selecting IF Power, the trigger threshold can be set with the TRIGger[:​SEQuence]:​LEVel:​IFPower command.

*RST: IMMediate
<TriggerSlope>
POSitive | NEGative

Used slope of the trigger signal.

The value indicated here will be ignored for <trigger source> = IMMediate.

*RST: POSitive
<OffsetSamples>

Number of samples to be used as an offset to the trigger signal.

For details refer to "Sample Rate, Measurement Time and Trigger Offset".

The value indicated here is ignored for <trigger source> = "IMMediate".

*RST: 0
<NoOfMeas>

Number of repetitions of the measurement to be executed. The value indicated here is especially necessary for the average/maxhold/minhold function.

Range: | 0 to 32767
*RST: | 0
Example: ADEM:SET 8MHz,32000,EXT,POS,-500,30

Performs a measurement at:

sample rate = 8 MHz

record length = 32000

trigger source = EXTernal

trigger slope = POSitive

offset samples = -500 (500 samples before trigger occurred)

# of meas = 30

Example:

See "Programming Example".


[SENSe:]ADEMod:SPECtrum:BANDwidth|BWIDth[:RESolution]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]ADEMod:SPECtrum:BANDwidth|BWIDth[:RESolution]
[SENSe:]ADEMod:SPECtrum:BANDwidth|BWIDth[:RESolution] <Bandwidth>

Defines the resolution bandwidth for data acquisition.

From the specified RBW and the demodulation span set by [SENSe:​]ADEMod:​SPECtrum:​SPAN[:​MAXimum] or [SENSe:​]BANDwidth|BWIDth:​DEMod, the required measurement time is calculated. If the available measurement time is not sufficient for the given bandwidth, the measurement time is set to its maximum and the resolution bandwidth is increased to the resulting bandwidth.

This command is identical to [SENSe:​]BANDwidth|BWIDth[:​RESolution].

Parameters:
<Bandwidth>
refer to data sheet
*RST: 61.2 kHz
Example:

ADEM:SPEC:BAND 61.2kHz

Sets the resolution bandwidth to 61.2 kHz.


[SENSe:]ADEMod:SRATe?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]ADEMod:SRATe?
[SENSe:]ADEMod:SRATe?

This command returns the sample rate set up for the current analog demodulation measurement.

Example: | ADEM:SRAT? Returns the current sample rate.
Usage: | Query only


[SENSe:]BANDwidth|BWIDth:DEMod

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod <Bandwidth>

This command sets the bandwidth for analog demodulation. Depending on the selected demodulation bandwidth, the instrument selects the required sampling rate.

For details on the correlation between demodulation bandwidth and sampling rate refer to "Sample Rate, Measurement Time and Trigger Offset".

This command is identical to SENS:ADEM:BAND:DEM.

Parameters:
<Bandwidth>
*RST: 5 MHz
Example:

BAND:DEM 1MHz

Sets demodulation bandwidth to 1 MHz

Example:

See "Programming Example".

Manual operation: See "Demodulation Bandwidth"


[SENSe:]BANDwidth|BWIDth:DEMod:TYPE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE <FilterType>

This command defines the type of demodulation filter to be used.

This command is identical to SENS:ADEM:BAND:DEM:TYPE:

Parameters:
<FilterType>
FLAT

Standard flat demodulation filter

GAUSs

Gaussian filter for optimized settling behaviour

*RST: FLAT
Manual operation: See "Demodulation Filter"


[SENSe:]BANDwidth|BWIDth[:RESolution]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution] <Bandwidth>

This command defines the resolution bandwidth and decouples the resolution bandwidth from the span.

For statistics measurements, this command defines the demodulation bandwidth.

For measurements on I/Q data in the frequency domain, the maximum RBW is 1 MHz.

Parameters:
<Bandwidth>
refer to data sheet
*RST: RBW: AUTO is set to ON; DBW: 3MHz
Example: BAND 1 MHz

Sets the resolution bandwidth to 1 MHz

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Resolution Bandwidth"


[SENSe:]SWEep:COUNt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

When you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:POINts

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Data Acquisition > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

This command defines the number of measurement points analyzed during a sweep.

Parameters:
<SweepPoints>
Range: | 101 to 100001
*RST: | 1001
Example: SWE:POIN 251
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep Points"


Triggering

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering
Triggering

The following remote commands are required to configure a triggered measurement in a remote environment. More details are described for manual operation in "Trigger Configuration".

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:AM:RELative
TRIGger[:SEQuence]:LEVel:AM[:ABSolute]
TRIGger[:SEQuence]:LEVel:FM
TRIGger[:SEQuence]:LEVel:PM
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For compatibility reasons, this command is also available for the "baseband power" trigger source when using the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IQPower

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:RFPower

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:AM:RELative

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:AM:RELative
TRIGger[:SEQuence]:LEVel:AM:RELative <Level>

The command sets the level when AM-modulated signals are used as trigger source.

For triggering to be successful, the measurement time must cover at least 5 periods of the audio signal.

Parameters:
<Level>
Range: | -100 to +100
*RST: | 0 %
Default unit: | %
Example:

TRIG:LEV:AM:REL -20 %

Sets the AM trigger threshold to -20 %

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:AM[:ABSolute]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:AM[:ABSolute]
TRIGger[:SEQuence]:LEVel:AM[:ABSolute] <Level>

The command sets the level when RF power signals are used as trigger source.

For triggering to be successful, the measurement time must cover at least 5 periods of the audio signal.

Parameters:
<Level>
Range: | -100 to +30
*RST: | -20 dBm
Default unit: | dBm
Example:

TRIG:LEV:AM -30 dBm

Sets the RF power signal trigger threshold to -30 dBm

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:FM

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:FM
TRIGger[:SEQuence]:LEVel:FM <Level>

The command sets the level when FM-modulated signals are used as trigger source.

For triggering to be successful, the measurement time must cover at least 5 periods of the audio signal.

Parameters:
<Level>
Range: | -10 to +10
*RST: | 0 Hz
Default unit: | MHz
Example:

TRIG:LEV:FM 10 kHz

Sets the FM trigger threshold to 10 kHz

Example:

See "Programming Example".

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:PM

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:PM
TRIGger[:SEQuence]:LEVel:PM <Level>

The command sets the level when PM-modulated signals are used as trigger source.

For triggering to be successful, the measurement time must cover at least 5 periods of the audio signal.

Parameters:
<Level>
Range: | -1000 to +1000
*RST: | 0 RAD
Default unit: | RAD | DEG
Example:

TRIG:LEV:PM 1.2 RAD

Sets the PM trigger threshold to 1.2 rad

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:SLOPe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For all trigger sources except time you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

For triggering with AF, AM, AMRelative, FM, and PM trigger sources to be successful, the measurement time must cover at least 5 periods of the audio signal. For details on trigger sources see "Trigger Source".

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

TIME

Time interval

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

PSEN

External power sensor

AF

AF power signal

FM

FM power signal

AM

corresponds to the RF power signal

AMRelative

corresponds to the AM signal

PM

PM power signal

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example".

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "I/Q Power"
See "IF Power/BB Power"
See "Digital I/Q"
See "FM / AM / PM / RF (Offline)"
See "Time"
See "RF Power"
See "Power Sensor"


TRIGger[:SEQuence]:TIME:RINTerval

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Note: For offline AF or RF triggers, no output signal is provided.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Triggering > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Configuring Demodulation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation
Configuring Demodulation

The following remote commands are required to configure the demodulation parameters in a remote environment. The tasks for manual operation are described in "Demodulation".

Contents
  • Basic Demodulation Settings
  • Time Domain Zoom Settings
  • Configuring the Demodulation Spectrum
  • (Post-processing) AF Filters
  • Defining the Scaling and Units
  • Scaling for AF Evaluation
  • Scaling for RF Evaluation
  • Units


Basic Demodulation Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Basic Demodulation Settings
Basic Demodulation Settings

The basic demodulation measurement parameters define how the measurement is performed.

Useful commands described elsewhere:
  • "Time Domain Zoom Settings"
Basic demodulation commands:
List of Commands
[SENSe:]ADEMod<n>:AF:COUPling
[SENSe:]ADEMod:PM:RPOint[:X]
[SENSe:]ADEMod:SQUelch[:STATe]
[SENSe:]ADEMod:SQUelch:LEVel


[SENSe:]ADEMod<n>:AF:COUPling

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Basic Demodulation Settings > [SENSe:]ADEMod<n>:AF:COUPling
[SENSe:]ADEMod<n>:AF:COUPling <Coupling>

This command selects the coupling of the AF path of the analyzer in the specified window.

Parameters:
<Coupling>
AC | DC
*RST: AC (PM); DC (FM)
Example:

ADEM:AF:COUP DC

Switches on DC coupling.

Manual operation: See "AF Coupling"


[SENSe:]ADEMod:PM:RPOint[:X]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Basic Demodulation Settings > [SENSe:]ADEMod:PM:RPOint[:X]
[SENSe:]ADEMod:PM:RPOint[:X] <Time>

This command determines the position where the phase of the PM-demodulated signal is set to 0 rad. The maximum possible value depends on the measurement time selected in the instrument; this value is output in response to the query ADEM:PM:RPO:X? MAX.

Parameters:
<Time>
0 s to measurement time
*RST: 0 s
Example:

ADEM:PM:RPO 500us

Sets the position where the phase to 0 rad setting to 500 μs.

Usage: SCPI confirmed
Manual operation: See "Zero Phase Reference Position (PM Time Domain only)"


[SENSe:]ADEMod:SQUelch[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Basic Demodulation Settings > [SENSe:]ADEMod:SQUelch[:STATe]
[SENSe:]ADEMod:SQUelch[:STATe] <State>

This command activates the squelch function, i.e. if the signal falls below a defined threshold (see [SENSe:​]ADEMod:​SQUelch:​LEVel), the demodulated data is automatically set to 0.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DEM:SQU ON

Signals below the level threshold are squelched.

Manual operation: See "Squelch State"


[SENSe:]ADEMod:SQUelch:LEVel

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Basic Demodulation Settings > [SENSe:]ADEMod:SQUelch:LEVel
[SENSe:]ADEMod:SQUelch:LEVel <Threshold>

This command defines the level threshold below which the demodulated data is set to 0 if squelching is enabled (see [SENSe:​]ADEMod:​SQUelch[:​STATe]).

Parameters:
<Threshold>
numeric value

The absolute threshold level

Range: | -150 dBm to 30 dBm
*RST: | -40 dBm
Example: DEM:SQU:LEV -80

If the signal drops below -80 dBm, the demodulated data is set to 0.

Manual operation: See "Squelch Level"


Time Domain Zoom Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Time Domain Zoom Settings
Time Domain Zoom Settings

Using the time domain zoom, the demodulated data for a particular time span is extracted and displayed in more detail.

List of Commands
[SENSe:]ADEMod<n>:ZOOM:LENGth
[SENSe:]ADEMod<n>:ZOOM:LENGth:MODE
[SENSe:]ADEMod<n>:ZOOM:STARt
[SENSe:]ADEMod<n>:ZOOM[:STATe]


[SENSe:]ADEMod<n>:ZOOM:LENGth

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Time Domain Zoom Settings > [SENSe:]ADEMod<n>:ZOOM:LENGth
[SENSe:]ADEMod<n>:ZOOM:LENGth <Length>

The command allows you to define the length of the time domain zoom area for the analog-demodulated measurement data in the specified window manually. If the length is defined manually using this command, the zoom mode is also set to manual.

Parameters:
<Length>
*RST: sweep time

Length of the zoom area in seconds.

Example:

ADEM:ZOOM:LENG 2s

Zoom mode is set to manual and the zoom length to 2 seconds.

Manual operation: See "Length"


[SENSe:]ADEMod<n>:ZOOM:LENGth:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Time Domain Zoom Settings > [SENSe:]ADEMod<n>:ZOOM:LENGth:MODE
[SENSe:]ADEMod<n>:ZOOM:LENGth:MODE <Mode>

The command defines whether the length of the zoom area for the analog-demodulated measurement data is defined automatically or manually in the specified window.

Parameters:
<Mode>
AUTO | MAN
AUTO

(Default:) The number of sweep points is used as the zoom length.

MAN

The zoom length is defined manually using [SENSe:​]ADEMod<n>:​ZOOM:​LENGth.

*RST: AUTO
Example:

ADEM:ZOOM:LENG:MODE MAN

Zoom function uses the length defined manually.

Manual operation: See "Length"


[SENSe:]ADEMod<n>:ZOOM:STARt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Time Domain Zoom Settings > [SENSe:]ADEMod<n>:ZOOM:STARt
[SENSe:]ADEMod<n>:ZOOM:STARt <Time>

The command selects the start time for the zoomed display of analog-demodulated measurements in the specified window. The maximum possible value depends on the measurement time, which is set and can be queried with the [SENSe:​]ADEMod:​MTIMe command.

If the zoom function is enabled, the defined number of sweep points are displayed from the start time specified with this command.

Parameters:
<Time>
Range: | 0 s to (measurement time – zoom length)
*RST: | 0 s
Example:

ADEM:ZOOM:STAT ON

Switches on the zoom function

ADEM:ZOOM:STAR 500us

Sets the starting point of the display to 500 μs.

Manual operation: See "Start"


[SENSe:]ADEMod<n>:ZOOM[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Time Domain Zoom Settings > [SENSe:]ADEMod<n>:ZOOM[:STATe]
[SENSe:]ADEMod<n>:ZOOM[:STATe] <State>

The command enables or disables the time domain zoom function for the analog-demodulated measurement data in the specified window.

If the zoom function is enabled, the defined number of sweep points are displayed from the start time specified with [SENSe:​]ADEMod<n>:​ZOOM:​STARt.

If the zoom function is disabled, data reduction is used to adapt the measruement points to the number of points available on the display.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

ADEM:ZOOM ON

Switches on the zoom function

Manual operation: See "State"


Configuring the Demodulation Spectrum

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum
Configuring the Demodulation Spectrum

The demodulation spectrum defines which span of the demodulated data is evaluated.

Contents
  • AF evaluation
  • RF evaluation


AF evaluation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation
AF evaluation

These settings are only available for AF Spectrum evaluations, not in the time domain.

List of Commands
[SENSe:]ADEMod:AF:CENTer
[SENSe:]ADEMod:AF:SPAN
[SENSe:]ADEMod:AF:SPAN:FULL
[SENSe:]ADEMod:AF:STARt
[SENSe:]ADEMod:AF:STOP


[SENSe:]ADEMod:AF:CENTer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation > [SENSe:]ADEMod:AF:CENTer
[SENSe:]ADEMod:AF:CENTer <Frequency>

This command sets the center frequency for AF spectrum result display.

Parameters:
<Frequency>
*RST: 1.25 MHz
Manual operation: See "AF Center"


[SENSe:]ADEMod:AF:SPAN

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation > [SENSe:]ADEMod:AF:SPAN
[SENSe:]ADEMod:AF:SPAN <Span>

This command sets the span (around the center frequency) for AF spectrum result display.

The span is limited to DBW/2 (see [SENSe:​]BANDwidth|BWIDth:​DEMod).

Parameters:
<Span>
*RST: 9 MHz
Example:

ADEM:AF:SPAN 200 kHz

Sets the AF span to 200 kHz

Manual operation: See "AF Span"


[SENSe:]ADEMod:AF:SPAN:FULL

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation > [SENSe:]ADEMod:AF:SPAN:FULL
[SENSe:]ADEMod:AF:SPAN:FULL

This command sets the maximum span for AF spectrum result display.

The maximum span corresponds to DBW/2 (see [SENSe:​]BANDwidth|BWIDth:​DEMod).

Example: | ADEM:BAND 5 MHz Sets the demodulation bandwidth to 5 MHz ADEM:AF:SPAN:FULL Sets the AF span to 2.5 MHz
Manual operation: | See "AF Full Span"


[SENSe:]ADEMod:AF:STARt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation > [SENSe:]ADEMod:AF:STARt
[SENSe:]ADEMod:AF:STARt <Frequency>

This command sets the start frequency for AF spectrum result display.

Parameters:
<Frequency>
*RST: 0 MHz
Example:

ADEM:AF:STAR 0 kHz

Sets the AF start frequency to 0 kHz

ADEM:AF:STOP 500 kHz

Sets the AF stop frequency to 500 kHz

Manual operation: See "AF Start"


[SENSe:]ADEMod:AF:STOP

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > AF evaluation > [SENSe:]ADEMod:AF:STOP
[SENSe:]ADEMod:AF:STOP <Frequency>

This command sets the stop frequency for AF spectrum result display.

Parameters:
<Frequency>
*RST: 9 MHz
Example:

ADEM:AF:STAR 0 kHz

Sets the AF start frequency to 0 kHz

ADEM:AF:STOP 500 kHz

Sets the AF stop frequency to 500 kHz

Manual operation: See "AF Stop"


RF evaluation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > RF evaluation
RF evaluation

These settings are only available for RF evaluation, both in time and frequency domain.

Useful commands described elsewhere
  • [SENSe:​]FREQuency:​CENTer
  • [SENSe:​]BANDwidth|BWIDth:​DEMod
Specific commands:
List of Commands
[SENSe:]ADEMod:SPEC:SPAN:ZOOM
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]


[SENSe:]ADEMod:SPEC:SPAN:ZOOM

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > RF evaluation > [SENSe:]ADEMod:SPEC:SPAN:ZOOM
[SENSe:]ADEMod:SPEC:SPAN:ZOOM <Span>

This command sets the span (around the center frequency) for RF spectrum result display.

The span is limited to the demodulation bandwidth (see [SENSe:​]BANDwidth|BWIDth:​DEMod).

Parameters:
<Span>
*RST: 5 MHz
Example:

ADEM:SPEC:SPAN:ZOOM 200 kHz

Sets the rF span to 200 kHz

Manual operation: See "Span"


[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Configuring the Demodulation Spectrum > RF evaluation > [SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum] <FreqRange>

Sets the DBW to the specified value and the span (around the center frequency) of the RF data to be evaluated to its new maximum (the demodulation bandwidth).

Parameters:
<FreqRange>
*RST: | 5 MHz
Default unit: | Hz
Manual operation: See "Span"
See "RF Full Span"


(Post-processing) AF Filters

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters
(Post-processing) AF Filters

The AF filter reduces the evaluated bandwidth of the demodulated signal and can define a weighting function. AF filters are only available for AM or FM time domain evaluations.

List of Commands
[SENSe:]FILTer<n>:AWEighted[:STATe]
[SENSe:]FILTer<n>:AOFF
[SENSe:]FILTer<n>:CCIR:WEIGhted[:STATe]
[SENSe:]FILTer<n>:CCIR:[:UNWeighted][:STATe]
[SENSe:]FILTer<n>:CCIT
[SENSe:]FILTer<n>:DEMPhasis:TCONstant
[SENSe:]FILTer<n>:DEMPhasis[:STATe]
[SENSe:]FILTer<n>:HPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:HPASs:FREQuency:MANual
[SENSe:]FILTer<n>:HPASs[:STATe]
[SENSe:]FILTer<n>:LPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:LPASs:FREQuency:MANual
[SENSe:]FILTer<n>:LPASs:FREQuency:RELative
[SENSe:]FILTer<n>:LPASs[:STATe]


[SENSe:]FILTer<n>:AWEighted[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:AWEighted[:STATe]
[SENSe:]FILTer<n>:AWEighted[:STATe] <State>

This command activates/deactivates the "A" weighting filter for the specified evaluation.

For details on weighting filters see "Weighting".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:AWE ON

Activates the A weighting filter.

Manual operation: See "Weighting"


[SENSe:]FILTer<n>:AOFF

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:AOFF
[SENSe:]FILTer<n>:AOFF

This command switches all AF filters for the selected evaluation off.

Usage: | Setting only
Manual operation: | See "Deactivating all AF Filters"


[SENSe:]FILTer<n>:CCIR:WEIGhted[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:CCIR:WEIGhted[:STATe]
[SENSe:]FILTer<n>:CCIR:WEIGhted[:STATe] <State>

This command activates/deactivates the weighted CCIR filter for the specified evaluation.

For details on weighting filters see "Weighting".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:CCIR:WEIG ON

Activates the weighted CCIR filter.

Manual operation: See "Weighting"


[SENSe:]FILTer<n>:CCIR:[:UNWeighted][:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:CCIR:[:UNWeighted][:STATe]
[SENSe:]FILTer<n>:CCIR:[:UNWeighted][:STATe] <State>

This command activates/deactivates the unweighted CCIR filter in the specified window.

For details on weighting filters see "Weighting".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:CCIR:UNW ON

Activates the unweighted CCIR filter.

Manual operation: See "Weighting"


[SENSe:]FILTer<n>:CCIT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:CCIT
[SENSe:]FILTer<n>:CCIT <State>

This command activates/deactivates the CCITT (CCITT P.53) weighting filter for the specified evaluation.

For details on weighting filters see "Weighting".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:CCIT ON

Activates the CCITT weighting filter.

Manual operation: See "Weighting"


[SENSe:]FILTer<n>:DEMPhasis:TCONstant

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:DEMPhasis:TCONstant
[SENSe:]FILTer<n>:DEMPhasis:TCONstant

This command selects the deemphasis for the specified evaluation.

For details on deemphasis refer to "Deemphasis".

Parameters:

25 us | 50 us | 75 us | 750 us
*RST: 50 us
Example:

FILT:DEMP:TCON 750us

Selects the deemphasis for the demodulation bandwidth range from 800 Hz to 4 MHz with a time constant of 750 μs.

Manual operation: See "Deemphasis"


[SENSe:]FILTer<n>:DEMPhasis[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:DEMPhasis[:STATe]
[SENSe:]FILTer<n>:DEMPhasis[:STATe] <State>

This command activates/deactivates the selected deemphasis for the specified evaluation.

For details about deemphasis refer to "Deemphasis".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:DEMP ON

Activates the selected deemphasis.

Manual operation: See "Deemphasis"


[SENSe:]FILTer<n>:HPASs:FREQuency[:ABSolute]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:HPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:HPASs:FREQuency[:ABSolute] <FilterType>

This command selects the high pass filter type for the specified evaluation.

For details on the high pass filters refer to "High Pass".

Parameters:
<FilterType>
20 Hz | 50 Hz | 300 Hz
*RST: | 300Hz
Default unit: | Hz
Example:

FILT:HPAS:FREQ 300Hz

Selects the high pass filter for the demodulation bandwidth range from 800 Hz to 8 MHz.

Manual operation: See "High Pass"


[SENSe:]FILTer<n>:HPASs:FREQuency:MANual

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:HPASs:FREQuency:MANual
[SENSe:]FILTer<n>:HPASs:FREQuency:MANual <Frequency>

This command selects the cutoff frequency of the high pass filter for the specified evaluation.

For details on the high pass filters refer to "High Pass".

Parameters:
<Frequency>
numeric value
Range: | 0 to 3 MHz
*RST: | 15kHz
Example:

FILT:HPAS:FREQ:MAN 3MHz

The AF results are restricted to frequencies lower than 3 MHz.

Manual operation: See "High Pass"


[SENSe:]FILTer<n>:HPASs[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:HPASs[:STATe]
[SENSe:]FILTer<n>:HPASs[:STATe] <State>

This command activates/deactivates the selected high pass filter for the specified evaluation.

For details on the high pass filter refer to "High Pass".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:HPAS ON

Activates the selected high pass filter.

Manual operation: See "High Pass"


[SENSe:]FILTer<n>:LPASs:FREQuency[:ABSolute]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:LPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:LPASs:FREQuency[:ABSolute] <FilterType>

This command selects the absolute low pass filter type for the specified evaluation

For details on the low pass filter refer to "Low Pass".

Parameters:
<FilterType>
3kHz | 15kHz | 150kHz
*RST: 15kHz
Example:

FILT:LPAS:FREQ 150kHz

Selects the low pass filter for the demodulation bandwidth range from 400 kHz to 16 MHz.

Manual operation: See "Low Pass"


[SENSe:]FILTer<n>:LPASs:FREQuency:MANual

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:LPASs:FREQuency:MANual
[SENSe:]FILTer<n>:LPASs:FREQuency:MANual <Frequency>

This command selects the cutoff frequency of the low pass filter for the specified evaluation.

For details on the low pass filter refer to "Low Pass".

Parameters:
<Frequency>
numeric value
Range: | 0 to 3 MHz
*RST: | 15kHz
Example:

FILT:LPAS:FREQ:MAN 150kHz

The AF results are restricted to frequencies lower than 150 kHz.

Manual operation: See "Low Pass"


[SENSe:]FILTer<n>:LPASs:FREQuency:RELative

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:LPASs:FREQuency:RELative
[SENSe:]FILTer<n>:LPASs:FREQuency:RELative <FilterType>

This command selects the relative low pass filter type for the specified evaluation

For details on the low pass filter refer to "Low Pass".

Parameters:
<FilterType>
5PCT | 10PCT | 25PCT
*RST: 25PCT
Example:

FILT:LPAS:FREQ:REL 25PCT

Selects the low pass filter as 25 % of the demodulation bandwidth.

Manual operation: See "Low Pass"


[SENSe:]FILTer<n>:LPASs[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > (Post-processing) AF Filters > [SENSe:]FILTer<n>:LPASs[:STATe]
[SENSe:]FILTer<n>:LPASs[:STATe] <State>

This command activates/deactivates the selected low pass filter for the specified evaluation.

For details on the low pass filter refer to "Low Pass".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

FILT:LPAS ON

Activates the selected low pass filter.

Manual operation: See "Low Pass"


Defining the Scaling and Units

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Defining the Scaling and Units
Defining the Scaling and Units

The scaling parameters define the range of the demodulated data to be displayed.


Scaling for AF Evaluation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Scaling for AF Evaluation
Scaling for AF Evaluation

These settings are only available for AF evaluations.

Useful commands described elsewhere:
  • [SENSe:​]ADJust:​SCALe:​Y:​AUTO[:​CONTinuous]
  • [SENSe:​]ADEMod<n>:​AF:​COUPling
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
Specific commands:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Scaling for AF Evaluation > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

This command defines the reference value assigned to the reference position in the specified window. Separate reference values are maintained for the various displays.

Parameters:
<Value>
*RST: AM time domain: 0 PCT; FM time domain: 0 Hz; PM time domain: 0 rad; AM spectrum: 100 PCT; FM spectrum: 250 kHz; PM spectrum: 10 rad;
Example:

DISP:TRAC:Y:RVAL 0

Sets the value assigned to the reference position to 0 Hz

Manual operation: See "Reference Value"


Scaling for RF Evaluation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Scaling for RF Evaluation
Scaling for RF Evaluation

These commands are required for RF evaluations and the result summary.

  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Units

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Units
Units

The units define how the demodulated data is displayed.

List of Commands
UNIT:ANGLe
UNIT:THD


UNIT:ANGLe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Units > UNIT:ANGLe
UNIT:ANGLe <Unit>

This command selects the unit for angles (for PM display).

This command is identical to CALC:UNIT:ANGL

Parameters:
<Unit>
DEG | RAD
*RST: RAD
Example:

UNIT:ANGL DEG

Manual operation: See "Phase Unit (Rad/Deg)"


UNIT:THD

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Demodulation > Units > UNIT:THD
UNIT:THD <Mode>

Selects the unit for THD measurements.

This command is identical to CALC:UNIT:THD

Parameters:
<Mode>
DB | PCT
*RST: DB
Example:

UNIT:THD PCT

Manual operation: See "THD Unit (% / DB)"


Adjusting Settings Automatically

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically
Adjusting Settings Automatically

The following remote commands are required to adjust settings automatically in a remote environment. The tasks for manual operation are described in " Automatic Settings".

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, settings related to data acquisition cannot be adjusted for Analog Demodulation applications.

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]ADJust:SCALe:Y:AUTO[:CONTinuous]


[SENSe:]ADJust:ALL

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Center frequency
  • Reference level
  • Scaling
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:FREQuency

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


[SENSe:]ADJust:SCALe:Y:AUTO[:CONTinuous]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Adjusting Settings Automatically > [SENSe:]ADJust:SCALe:Y:AUTO[:CONTinuous]
[SENSe:]ADJust:SCALe:Y:AUTO[:CONTinuous] <State>

Activates automatic scaling of the y-axis in all diagrams according to the current measurement results. Currently auto-scaling is only available for AF measurements. RF power and RF spectrum measurements are not affected by the auto-scaling.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SENS:ADJ:SCAL:Y:AUTO ON
Example:

See "Programming Example".

Manual operation: See "AF Auto Scale"


Configuring Standard Traces

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces
Configuring Standard Traces
Useful commands for trace configuration described elsewhere
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
Remote commands exclusive to trace configuration
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:SELect
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain][:TYPE]
[SENSe:]ADEMod:AM:RELative[:TDOMain][:TYPE]
[SENSe:]ADEMod:AM:RELative:AFSPectrum[:TYPE]
[SENSe:]ADEMod:FM[:TDOMain][:TYPE]
[SENSe:]ADEMod:FM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:PM[:TDOMain][:TYPE]
[SENSe:]ADEMod:PM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:SPECtrum[:TYPE]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>:TYPE
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

In the Analog Demodulation application when you configure the traces for a window with a specific evaluation (e.g. AM time domain), the traces in all windows with the same evaluation are configured identically.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>:SELect

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:SELect
DISPlay[:WINDow<n>]:TRACe<t>:SELect

This command selects the trace specified by the index <t> in the window specified by the index <n>. Only traces that are active in the specified result display can be selected. The selected trace is used to determine the "Result Summary" for the corresponding result display (see "Result Summary").

The query returns the number of the currently selected trace in the window specified by the index <n> (trace index is ignored). Traces can only be queried for graphical result displays (not Result Summary, Marker Table or Peak Marker List).

Return values:
<TraceNo> | Number of the currently selected trace.
Example: | DISP:TRAC3:SEL
Usage: | SCPI confirmed


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 for TRACe1, 0 for TRACe 2 to 6
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]ADEMod:AM[:ABSolute][:TDOMain][:TYPE]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:]ADEMod:AM[:ABSolute][:TDOMain][:TYPE]
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain][:TYPE]
[SENSe:]ADEMod:AM:RELative[:TDOMain][:TYPE]
[SENSe:]ADEMod:AM:RELative:AFSPectrum[:TYPE]
[SENSe:]ADEMod:FM[:TDOMain][:TYPE]
[SENSe:]ADEMod:FM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:PM[:TDOMain][:TYPE]
[SENSe:]ADEMod:PM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:SPECtrum[:TYPE] <TraceMode1>, <TraceMode2>, <TraceMode3>, <TraceMode4>, <TraceMode5>, <TraceMode6>

This command selects the trace modes of the evaluated signal to be measured simultaneously. For each of the six available traces a mode can be defined.

For details on trace modes see "Trace Mode".

The trace modes are configured identically for all windows with a specific evaluation. The following table indicates which command syntax refers to which evaluation method.

Command syntax | Evaluation method
AM[:ABSolute][:TDOMain] | RF time domain
AM:RELative[:TDOMain] | AM time domain
AM:RELative:AFSPectrum | AM spectrum
FM[:TDOMain] | FM time domain
FM:AFSPectrum | FM spectrum
PM[:TDOMain] | PM time domain
PM:AFSPectrum | PM spectrum
SPECtrum | RF spectrum

Note: The trace modes for each trace and each window can also be configured individually using the DISP:TRAC:MODE command, see DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE.

Parameters:
<TraceMode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

OFF

Hides the selected trace.

*RST: WRITe,OFF,OFF,OFF,OFF,OFF
Example: ADEM:AM AVER,MAXH,MINH,OFF,OFF,OFF

Determines average, max hold and min hold values simultaneously for the traces 1-3 of the RF time domain evaluation.

ADEM:AM WRIT,OFF,OFF,OFF,OFF,OFF

Determines only the current measurement values for trace 1.

ADEM:AM OFF,OFF,OFF,OFF,OFF,OFF

Switches AM demodulation off.

Example:

See "Programming Example".


[SENSe:]AVERage:COUNt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<AverageCount>

If you set a average count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"
See "Average Count"


[SENSe:]AVERage<n>[:STATe<t>]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>

This command turns averaging for a particular trace in a particular window on and off.

Parameters:
<State>
ON | OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


[SENSe:]AVERage<n>:TYPE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>:TYPE <Mode>

This command selects the trace averaging mode.

Parameters:
<Mode>
VIDeo

The logarithmic power values are averaged.

LINear

The power values are averaged before they are converted to logarithmic values.

POWer

The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit.

*RST: VIDeo
Example: AVER:TYPE LIN

Switches to linear average calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Average Mode"


[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector" .

Parameters:
<Detector>
APEak

Autopeak

NEGative

Negative peak

POSitive

Positive peak

QPEak

Quasipeak (CISPR filter only)

SAMPle

First value detected per trace point

RMS

RMS value

AVERage

Average

CAVerage

CISPR Average (CISPR filter only)

CRMS

CISPR RMS (CISPR filter only)

*RST: APEak (I/Q Analyzer: RMS)

For more information see "Mapping Samples to Sweep Points with the Trace Detector" .

Example: DET POS

Sets the detector to "positive peak".

Example:

See "Programming Example: EMI Measurement" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Detector"


[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Measurement > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO <State>

This command couples and decouples the detector to the trace mode.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DET:AUTO OFF

The selection of the detector is not coupled to the trace mode.

Manual operation: See "Detector"


Capturing Data and Performing Sweeps

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps
Capturing Data and Performing Sweeps
MSRA/MSRT operating mode

Note that in MSRA/MSRT operating mode, capturing data is only possible for the MSRA/MSRT Master channel. In Analog Demodulation application channels, the sweep configuration commands define the analysis interval. Be sure to select the correct measurement channel before using these commands.

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
SYSTem:SEQuencer


ABORt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:REFResh

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

The application channel must be selected before this command can be executed (see INSTrument[:​SELect]).

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


INITiate:SEQuencer:ABORt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SEQuencer:REFResh[:ALL]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


SYSTem:SEQuencer

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Capturing Data and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Configuring the Result Display

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display
Configuring the Result Display

The following remote commands are required to configure the screen display in a remote environment.

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example: LAY:ADD? '1',BEL,'XTIM:AM:RELative[:TDOMain]'

Adds an AM Time Domain display below window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example".

Usage: Query only
Manual operation: See "AM Time Domain"
See "FM Time Domain"
See "PM Time Domain"
See "AM Spectrum"
See "FM Spectrum"
See "PM Spectrum"
See "RF Time Domain"
See "RF Spectrum"
See "Result Summary"
See "Marker Table"
See "Marker Peak List"
<WindowType> parameter values for AnalogDemod application
Parameter value | Window type
MTABle | Marker table
PEAKlist | Marker peak list
RSUMmary | Result summary
'XTIM:AM' | RF Time Domain (= RF power)
'XTIM:AM:RELative' | AM Time Domain
'XTIM:AM:RELative:AFSPectrum' | AM Spectrum
'XTIM:FM' | FM Time Domain
'XTIM:FM:AFSPectrum' | FM Spectrum
'XTIM:PM' | PM Time Domain
'XTIM:PM:AFSPectrum' | PM Spectrum
'XTIM:SPECtrum' | RF Spectrum


LAYout:CATalog[:WINDow]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Retrieving Results

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results
Retrieving Results

The following remote commands are required to retrieve the results from an Analog Demodulation measurement in a remote environment.

In the Analog Demodulation application when you configure the traces for a window with a specific evaluation (e.g. AM time domain), the traces in all windows with the same evaluation are configured identically.

Useful commands described elsewhere:
  • "Storing Measurement Results"
Specific commands:
Contents
  • Retrieving Trace Results
  • Retrieving Result Summary Values


Retrieving Trace Results

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following remote commands are required to retrieve the trace results in a remote environment.

List of Commands
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain]:RESult?
[SENSe:]ADEMod:AM:RELative[:TDOMain]:RESult?
[SENSe:]ADEMod:AM:RELative:AFSPectrum:RESult?
[SENSe:]ADEMod:FM[:TDOMain]:RESult?
[SENSe:]ADEMod:FM:AFSPectrum:RESult?
[SENSe:]ADEMod:PM[:TDOMain]:RESult?
[SENSe:]ADEMod:PM:AFSPectrum:RESult?
[SENSe:]ADEMod:SPECtrum:RESult?
FORMat[:DATA]
TRACe<n>[:DATA]


[SENSe:]ADEMod:AM[:ABSolute][:TDOMain]:RESult?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Trace Results > [SENSe:]ADEMod:AM[:ABSolute][:TDOMain]:RESult?
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain]:RESult? <TraceMode>
[SENSe:]ADEMod:AM:RELative[:TDOMain]:RESult? <TraceMode>
[SENSe:]ADEMod:AM:RELative:AFSPectrum:RESult? <TraceMode>
[SENSe:]ADEMod:FM[:TDOMain]:RESult? <TraceMode>
[SENSe:]ADEMod:FM:AFSPectrum:RESult? <TraceMode>
[SENSe:]ADEMod:PM[:TDOMain]:RESult? <TraceMode>
[SENSe:]ADEMod:PM:AFSPectrum:RESult? <TraceMode>
[SENSe:]ADEMod:SPECtrum:RESult? <TraceMode>

This command reads the result data of the evaluated signal in the specified trace mode. The data format of the output data block is defined by the FORMat command (see FORMat[:​DATA]).

The trace results are configured for a specific evaluation. The following table indicates which command syntax refers to which evaluation method, as well as the output unit of the results.

Command syntax | Evaluation method | Output unit
AM[:ABSolute][:TDOMain] | RF time domain | dBm
AM:RELative[:TDOMain] | AM time domain | %
AM:RELative:AFSPectrum | AM spectrum | %
FM[:TDOMain] | FM time domain | kHz
FM:AFSPectrum | FM spectrum | kHz
PM[:TDOMain] | PM time domain | rad or °
PM:AFSPectrum | PM spectrum | rad or °
SPECtrum | RF spectrum | dBm (logarithmic display) or V (linear display).
Query parameters:
<TraceMode> | WRITe | AVERage | MAXHold | MINHold | VIEW The specified trace mode must be one of those configured by SENS:ADEM:<Evaluation>:TYPE, see [SENSe:​]ADEMod:​SPECtrum[:​TYPE]. Otherwise a query error is generated.
Example: | ADEM:AM AVER,MAXH,MINH Sets up RF time domain results to be measured INIT; *WAI Starts measurement and waits for sync FORM ASC Selects output format ADEM:AM:RES? AVER Reads RF time domain average results ADEM:AM:RES? MAXH Reads RF time domain max hold results ADEM:AM:RES? MINH Reads RF time domain min hold results
Usage: | Query only


FORMat[:DATA]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]
TRACe<n>[:DATA]

This command queries current trace data and measurement results.

The data format depends on FORMat[:​DATA].

Query parameters:
<ResultType>

Selects the type of result to be returned.

TRACE1 | ... | TRACE6

Returns the trace data for the corresponding trace.

Return values:
<TraceData>

The trace data consists of a list of power levels that have been measured. The number of power levels in the list depends on the currently selected number of sweep points. The unit depends on the measurement and on the unit you have currently set.

If you are measuring with the auto peak detector, the command returns positive peak values only.

Example: TRAC? TRACE3

Queries the data of trace 3.

Example:

See "Programming Example: Performing a Basic Frequency Sweep"

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Example: SEM Measurement" .

Example:

See "Programming Example".

Usage: SCPI confirmed


Retrieving Result Summary Values

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values
Retrieving Result Summary Values

The result summary contains measurement values that are calculated from the trace data.

For details see "Result Summary".

List of Commands
CALCulate<n>:MARKer:FUNCtion:ADEMod:AFRequency[:RESult]?
CALCulate:MARKer:FUNCtion:ADEMod:AM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:FM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:PM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:CARRier[:RESult]?
CALCulate:MARKer:FUNCtion:ADEMod:FERRor[:RESult<t>]?
CALCulate<n>:MARKer:FUNCtion:ADEMod:SINad:RESult<t>?
CALCulate<n>:MARKer:FUNCtion:ADEMod:THD:RESult<t>?
[SENSe:]ADEMod:FM:OFFSet?
[SENSe:]ADEMod:PM:RPOint[:X]


CALCulate<n>:MARKer:FUNCtion:ADEMod:AFRequency[:RESult]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate<n>:MARKer:FUNCtion:ADEMod:AFRequency[:RESult]?
CALCulate<n>:MARKer:FUNCtion:ADEMod:AFRequency[:RESult]?

This command queries the modulation (audio) frequency for the demodulation method in the selected window.

Parameters:
<ModFreq> | Modulation frequency in Hz.
Usage: | Query only


CALCulate:MARKer:FUNCtion:ADEMod:AM[:RESult<t>]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate:MARKer:FUNCtion:ADEMod:AM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:AM[:RESult<t>]? <MeasType>
CALCulate:MARKer:FUNCtion:ADEMod:FM[:RESult<t>]? <MeasType>
CALCulate:MARKer:FUNCtion:ADEMod:PM[:RESult<t>]? <MeasType>

This command queries the current value of the demodulated signal for the specified trace (as displayed in the Result Summary in manual operation).

Note that all windows with the same evaluation method have the same traces, thus the window is irrelevant.

Query parameters:
<MeasType> | PPEak | MPEak | MIDDle | RMS PPEak Postive peak (+PK) MPEak | NPEak Negative peak (-PK) MIDDle Average of positive and negative peaks ±PK/2 RMS Root mean square value
Example: | CALC:FEED 'XTIM:PM:TDOM' Switches on the PM time domain result display. DISP:TRAC ON Switches on the trace. CALC:MARK:FUNC:ADEM:PM? PPE Queries the peak value of the demodulated PM trace.
Usage: | Query only
Manual operation: | See "Result Summary"


CALCulate:MARKer:FUNCtion:ADEMod:CARRier[:RESult]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate:MARKer:FUNCtion:ADEMod:CARRier[:RESult]?
CALCulate:MARKer:FUNCtion:ADEMod:CARRier[:RESult]?

This command queries the carrier power, which is determined from the Clr/Write data.

Return values:
<CPower> | Power of the carrier without modulation in dBm.
Example: | See "Programming Example".
Usage: | Query only


CALCulate:MARKer:FUNCtion:ADEMod:FERRor[:RESult<t>]?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate:MARKer:FUNCtion:ADEMod:FERRor[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:FERRor[:RESult<t>]?

This command queries the carrier offset (= frequency error) for FM and PM demodulation. The carrier offset is determined from the current measurement data (CLR/WRITE). The modulation is removed using low pass filtering.

The offset thus determined differs from that calculated in the [SENSe:​]ADEMod:​FM:​OFFSet? command which uses averaging to determine the frequency deviation.

Return values:
<CarrOffset> | The deviation of the calculated carrier frequency to the ideal carrier frequency in Hz.
Example: | See "Programming Example".
Usage: | Query only


CALCulate<n>:MARKer:FUNCtion:ADEMod:SINad:RESult<t>?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate<n>:MARKer:FUNCtion:ADEMod:SINad:RESult<t>?
CALCulate<n>:MARKer:FUNCtion:ADEMod:SINad:RESult<t>?

This command queries the result of the signal-to-noise-and-distortion (SINAD) measurement in the specified window for the specified trace.

Note that this value is only calculated if an AF Spectrum window is displayed.

Parameters:
<SINAD> | The signal-to-noise-and-distortion ratio in dB.
Example: | See "Programming Example".
Usage: | Query only


CALCulate<n>:MARKer:FUNCtion:ADEMod:THD:RESult<t>?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > CALCulate<n>:MARKer:FUNCtion:ADEMod:THD:RESult<t>?
CALCulate<n>:MARKer:FUNCtion:ADEMod:THD:RESult<t>?

This command queries the result of the total harmonic distortion (THD) measurement in the specified window.

Note that this value is only calculated if an AF Spectrum window is displayed.

Parameters:
<THD> | Total harmonic distortion of the demodulated signal in dB.
Example: | See "Programming Example".
Usage: | Query only


[SENSe:]ADEMod:FM:OFFSet?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > [SENSe:]ADEMod:FM:OFFSet?
[SENSe:]ADEMod:FM:OFFSet? <ResultType>

This command calculates the FM carrier offset from the currently available measurement data set.

If averaging has been activated before acquiring the data set (using [SENSe:​]ADEMod:​FM[:​TDOMain][:​TYPE], the averaged FM offset over several measurements can also be obtained by setting <ResultType> = AVERage.

The offset thus determined differs from the one calculated by the CALCulate:​MARKer:​FUNCtion:​ADEMod:​FERRor[:​RESult<t>]? command since, for determination of the frequency deviation, the modulation is removed by means of low pass filtering, producing results that are different from those obtained by averaging.

Query parameters:
<ResultType>
IMMediate | AVERage
IMMediate

The current measurement results are used to calculate the FM offset

AVERage

The measurement results that were averaged over the given number of measurements are used to calculate the FM offset

If no average measurement was active during the last measurement sequence only the [SENSe:]ADEMod:FM:OFFSet? IMMediate command will return a correct result (data to calculate the offset are taken from the last measured data set).

[SENSe:]ADEMod:FM:OFFSet? AVERage will cause a query error in this case.

Example:

ADEM:SET 8MHz,32000,EXT,POS,-500,30

Sets up demodulator parameters to execute 30 measurements

ADEM:FM AVER,OFF,OFF

Selects FM results to perform averaging

INIT; WAI

Starts measurement and waits for sync

ADEM:FM:OFFS? IMM

Reads FM offset of last measurement of the sequence of 30

ADEM:FM:OFFS? AVER

Reads FM offset averaged over 30 measurements

Example:

See "Programming Example".

Usage: Query only


[SENSe:]ADEMod:PM:RPOint[:X]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Retrieving Results > Retrieving Result Summary Values > [SENSe:]ADEMod:PM:RPOint[:X]
[SENSe:]ADEMod:PM:RPOint[:X] <Time>

This command determines the position where the phase of the PM-demodulated signal is set to 0 rad. The maximum possible value depends on the measurement time selected in the instrument; this value is output in response to the query ADEM:PM:RPO:X? MAX.

Parameters:
<Time>
0 s to measurement time
*RST: 0 s
Example:

ADEM:PM:RPO 500us

Sets the position where the phase to 0 rad setting to 500 μs.


Analyzing Results

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results
Analyzing Results

The following remote commands are required to configure general result analysis settings concerning the trace, markers, lines etc. in a remote environment. They are identical to the analysis functions in the base unit except for some special marker functions and spectrograms, which are not available in the Analog Demodulation application.

See
  • "Configuring Display and Limit Lines"
  • "Zooming into the Display"

More details are described for manual operation in "Analysis".

Contents
  • Working with Markers Remotely
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Configuring an Analysis Interval and Line (MSRT mode only)


Working with Markers Remotely

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely
Working with Markers Remotely

In the Analog Demodulation application, up to 16 markers or delta markers can be activated for each window simultaneously.

More details are described for manual operation in "Marker Function Configuration".

Contents
  • Setting Up Individual Markers
  • General Marker Settings
  • Marker Search Settings
  • Positioning the Marker
  • Configuring Special Marker Functions


Setting Up Individual Markers

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2> <State>

This command links normal marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:LINK:TO:MARK2 ON

Links marker 4 to marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:MARKer<m>[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 6 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is either Hz (frequency domain) or s (time domain) or dB (statistics).

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


CALCulate<n>:MARKer<m>:Y?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

If the analog demodulator (option Analog Demodulation, R&S FSW–K7) is activated, the query result is output in the following units in the specified window:

Result display | Output unit
AM | %
FM | Hz
PM | rad/deg (defined with UNIT:​ANGLe)
RF | dB (Range Log or Range Linear %) % (Range Linear dB)
Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker:AOFF

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON
Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2> <State>

This command links delta marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, delta marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT4:LINK:TO:MARK2 ON

Links the delta marker 4 to the marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker:MODE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker:MODE <Mode>

This command defines whether the position of a delta marker is provided as an absolute value or relative to a reference marker. Note that when the position of a delta marker is queried, the result is always an absolute value (see CALCulate<n>:​DELTamarker<m>:​X)!

Parameters:
<Mode>
ABSolute

Delta marker position in absolute terms.

RELative

Delta marker position in relation to a reference marker.

*RST: RELative
Example: CALC:DELT:MODE ABS

Absolute delta marker position.


CALCulate<n>:DELTamarker<m>:MREF

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The position is relative to the reference marker.

To select an absolute position you have to change the delta marker mode with CALCulate<n>:​DELTamarker:​MODE.

A query returns the absolute position of the delta marker.

Range: The value range and unit depend on the measurement and scale of the x-axis.
Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


CALCulate<n>:DELTamarker<m>:X:RELative?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:Y?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Analog demodulation measurements
Parameter, measuring function or result display | Output unit
AM result display (R&S FSW–K7) | % (lin) dB (log)
FM result display (R&S FSW–K7) | Hz (lin) dB (log)
PM result display (R&S FSW–K7) | rad | deg (lin) dB (log)
RF result display (R&S FSW–K7) | dB (Range Log or Range Linear %) % (Range Linear %)
Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


General Marker Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

See also "Fixed Reference Marker Settings"

List of Commands
CALCulate:MARKer:X:SSIZe
CALCulate:MARKer<m>:LINK
DISPlay:MTABle


CALCulate:MARKer:X:SSIZe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings > CALCulate:MARKer:X:SSIZe
CALCulate:MARKer:X:SSIZe <StepSize>

This command selects the marker step size mode.

The step size defines the distance the marker moves when you move it with the rotary knob. It therefore takes effect in manual operation only.

Parameters:
<StepSize>
STANdard

the marker moves from one pixel to the next

POINts

the marker moves from one sweep point to the next

*RST: POINts
Example: CALC:MARK:X:SSIZ STAN

Sets the marker step size to one pixel.

Manual operation: See "Marker Stepsize"


CALCulate:MARKer<m>:LINK

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings > CALCulate:MARKer<m>:LINK
CALCulate:MARKer<m>:LINK <DisplayType>

Links the specified marker in all displays of the specified type.

Parameters:
<DisplayType>
TIME | SPECtrum | BOTH | NONE
TIME

Links the markers in all time domain diagrams

SPECtrum

Links the markers in all AF Spectrum displays

BOTH

Links the markers both in the time domain diagrams and in the AF Spectrum displays

NONE

Markers are not linked.

*RST: NONE
Manual operation: See "Link Time Marker"
See "Link AF Spectrum Marker"


DISPlay:MTABle

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Marker Search Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Marker Search Settings
Marker Search Settings

The following commands define criteria for searches.

List of Commands
CALCulate<n>:MARKer:PEXCursion


CALCulate<n>:MARKer:PEXCursion

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Marker Search Settings > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Application/Result display | Unit
Spectrum | dB
ADEMOD, RF | dB
ADEMOD, AM | PCT
ADEMOD, FM | kHz
ADEMOD, PM | RAD
Parameters:
<Excursion>

The excursion is the distance to a trace maximum that must be attained before a new maximum is recognized, or the distance to a trace minimum that must be attained before a new minimum is recognized

*RST: 5 PCT in AM displays, 50 kHz in FM displays, (0.5 RAD in PM displays)
Example: CALC:MARK:PEXC 10dB

Defines peak excursion as 10 dB.

Manual operation: See "Peak Excursion"


Positioning the Marker

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker
Positioning the Marker

The following remote commands are required to position the marker on a trace.

Contents
  • Positioning Markers
  • Positioning Delta Markers


Positioning Markers

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers
Positioning Markers

The following commands position markers on the trace.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Positioning Delta Markers

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Configuring Special Marker Functions

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions
Configuring Special Marker Functions

The following commands are required to configure the special marker functions that are available in the Analog Demodulation application

.

Contents
  • Fixed Reference Marker Settings
  • Marker Peak Lists
  • n dB Down Marker
  • Phase Noise Measurement Marker


Fixed Reference Marker Settings

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings
Fixed Reference Marker Settings

The following commands configure a fixed reference marker.

List of Commands
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]

This command moves the fixed reference marker to the peak power.

Example: | CALC:DELT:FUNC:FIX:RPO:MAX Sets the reference point level for delta markers to the peak of the selected trace.
Usage: | Event
Manual operation: | See "Defining a Fixed Reference" See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X <RefPoint>

This command defines the horizontal position of the fixed delta marker reference point. The coordinates of the reference may be anywhere in the diagram.

Parameters:
<RefPoint>

Numeric value that defines the horizontal position of the reference.

For frequency domain measurements, it is a frequency in Hz.

For time domain measurements, it is a point in time in s.

*RST: Fixed Reference: OFF
Example: CALC:DELT:FUNC:FIX:RPO:X 128 MHz

Sets the frequency reference to 128 MHz.

Manual operation: See "Defining a Fixed Reference"
See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y <RefPointLevel>

This command defines the vertical position of the fixed delta marker reference point. The coordinates of the reference may be anywhere in the diagram.

Parameters:
<RefPoint>

Numeric value that defines the vertical position of the reference.

The unit and value range is variable.

*RST: Fixed Reference: OFF
Example: CALC:DELT:FUNC:FIX:RPO:Y -10dBm

Sets the reference point level for delta markers to -10 dBm.

Manual operation: See "Defining a Fixed Reference"
See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet <Offset>

This command defines a level offset for the fixed delta marker reference point.

Parameters:
<Offset>
Numeric value
*RST: | 0
Default unit: | dB


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe] <State>

This command activates or deactivates a marker that defines a fixed reference point for relative marker analysis.

If necessary, the command activates a marker and positions it on the peak power.

Subsequently, you can change the coordinates of the fixed reference independent of the marker. The fixed reference is independent of the trace and is applied to all active delta markers.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:FIX ON

Switches on the measurement with fixed reference value for all delta markers.

CALC:DELT:FUNC:FIX:RPO:X 128 MHZ

Sets the frequency reference to 128 MHz.

CALC:DELT:FUNC:FIX:RPO:Y 30 DBM

Sets the reference level to +30 dBm.

Manual operation: See "Defining a Fixed Reference"


Marker Peak Lists

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists
Marker Peak Lists
Useful commands for peak lists described elsewhere
  • CALCulate<n>:​MARKer:​PEXCursion
  • MMEMory:​STORe:​PEAK
  • "Marker Search Settings"
Remote commands exclusive to peak lists
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe] <State>

This command turns labels for peaks found during a peak search on and off.

The labels correspond to the marker number in the marker peak list.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:FUNC:FPE:ANN:LAB:STAT OFF

Removes the peak labels from the diagram

Manual operation: See "Displaying Marker Numbers"


CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

This command queries the number of peaks that have been found during a peak search.

The actual number of peaks that have been found may differ from the number of peaks you have set to be found because of the peak excursion.

Return values:
<NumberOfPeaks> |
Example: | CALC:MARK:FUNC:FPE:COUN? Queries the number of peaks.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate] <Peaks>

This command initiates a peak search.

Parameters:
<Peaks>

This parameter defines the number of peaks to find during the search.

Note that the actual number of peaks found during the search also depends on the peak excursion you have set with CALCulate<n>:​MARKer:​PEXCursion.

Range: 1 to 200
Example: CALC:MARK:PEXC 5

Defines a peak excursion of 5 dB, i.e. peaks must be at least 5 dB apart to be detected as a peak.

CALC:MARK:FUNC:FPE 10

Initiates a search for 10 peaks on the current trace.


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE <MaxNoPeaks>

This command defines the maximum number of peaks that the R&S FSW looks for during a peak search.

Parameters:
<MaxNoPeaks>

Maximum number of peaks to be determined.

Range: | 1 to 200
*RST: | 50
Example: CALC:MARK:FUNC:FPE:LIST:SIZE 10

The marker peak list will contain a maximum of 10 peaks.

Manual operation: See "Maximum Number of Peaks"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT <SortMode>

This command selects the order in which the results of a peak search are returned.

Parameters:
<SortMode>
X

Sorts the peaks according to increasing position on the x-axis.

Y

Sorts the peaks according to decreasing position on the y-axis.

*RST: X
Example: CALC:MARK:FUNC:FPE:SORT Y

Sets the sort mode to decreasing y values

Manual operation: See "Sort Mode"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT <State>

This command turns a peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:FPE:STAT ON

Activates marker peak search

Manual operation: See "Peak List State"


CALCulate:MARKer:FUNCtion:FPEeaks:X?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:X?

This command queries the position of the peaks on the x-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the x-axis. The unit depends on the measurement.
Usage: | Query only


CALCulate:MARKer:FUNCtion:FPEeaks:Y?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?

This command queries the position of the peaks on the y-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the y-axis. The unit depends on the measurement.
Usage: | Query only


n dB Down Marker

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker
n dB Down Marker

The following commands control the n dB down markers.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown <Distance>

This command defines the distance of the n dB down markers to the reference marker.

Parameters:
<Distance>

Distance of the temporary markers to the reference marker in dB.

For a positive offset, the markers T1 and T2 are placed below the active reference point.

For a negative offset (for example for notch filter measurements), the markers T1 and T2 are placed above the active reference point.

*RST: 6dB
Example: CALC:MARK:FUNC:NDBD 3dB

Sets the distance to the reference marker to 3 dB.


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?

This command queries the position of the n dB down markers on the x-axis when measuring in the frequency domain.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Frequency> | <frequency 1> absolute frequency of the n dB marker to the left of the reference marker in Hz <frequency 2> absolute frequency of the n dB marker to the right of the reference marker in Hz.
Example: | INIT:CONT OFF Switches to single sweep mode. CALC:MARK:FUNC:NDBD ON Switches on the n dB down function. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK:FUNC:NDBD:FREQ? This command would return, for example, 100000000, 200000000, meaning that the first marker position is at 100 MHz, the second marker position is at 200 MHz
Usage: | Query only
Manual operation: | See "n dB down Delta Value"


CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?

This command queries the Q factor of n dB down measurements.

Return values:
<QFactor> |
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?

This command queries the distance of the n dB down markers from each other.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Distance>

The result depends on the span.

In case of frequency domain measurements, the command returns the bandwidth between the two n dB down markers in Hz.

In case of time domain measurements, the command returns the pulse width between the two n dB down markers in seconds.

Example: INIT:CONT OFF

Switches to single sweep mode.

CALC:MARK:FUNC:NDBD ON

Switches on the n dB down function.

INIT;*WAI

Starts a sweep and waits for the end.

CALC:MARK:FUNC:NDBD:RES?

Outputs the measured value.

Usage: Query only
Manual operation: See "n dB down Marker State"


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe <State>

This command turns the n dB Down marker function on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:NDBD:STAT ON

Turns the n dB Down marker on.

Manual operation: See "n dB down Marker State"


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?

This command queries the position of the n dB down markers on the x-axis when measuring in the time domain.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<TimeX1> | absolute position in time of the n dB marker to the left of the reference marker in seconds
<TimeX2> | absolute position in time of the n dB marker to the right of the reference marker in seconds
Example: | INIT:CONT OFF Switches to single sweep mode CALC:MARK:FUNC:NDBD ON Switches on the n dB down function. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK:FUNC:NDBD:TIME? Outputs the time values of the temporary markers.
Usage: | Query only
Manual operation: | See "n dB down Delta Value"


Phase Noise Measurement Marker

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Phase Noise Measurement Marker
Phase Noise Measurement Marker

The following commands control the phase noise measurement marker function.

Useful commands for phase noise markers described elsewhere
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y
Remote commands exclusive to phase noise markers
List of Commands
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO <State>

This command turns an automatic peak search for the fixed reference marker at the end of a sweep on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:PNO:AUTO ON

Activates an automatic peak search for the reference marker in a phase-noise measurement.

Manual operation: See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?

This command queries the result of a phase noise measurement.

If necessary, the command activates the measurement first.

Return values:
<PhaseNoise> |
Example: | CALC:DELT2:FUNC:PNO:RES? Outputs the result of phase-noise measurement of the deltamarker 2.
Usage: | Query only
Manual operation: | See "Phase Noise Measurement State"


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Working with Markers Remotely > Configuring Special Marker Functions > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe] <State>

This command turns the phase noise measurement at the delta marker position on and off.

The reference marker for phase noise measurements is either a normal marker or a fixed reference. If necessary, the command turns on the reference marker.

The correction values for the bandwidth and the log amplifier are taken into account in the measurement.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:PNO ON

Switches on the phase-noise measurement with all delta markers.

CALC:DELT:FUNC:FIX:RPO:X 128 MHZ

Sets the frequency reference to 128 MHz.

CALC:DELT:FUNC:FIX:RPO:Y 30 DBM

Sets the reference level to +30 dBm

Manual operation: See "Phase Noise Measurement State"
See "Switching All Phase Noise Measurements Off"


Configuring an Analysis Interval and Line (MSRA mode only)

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the Analog Demodulation application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Configuring Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the Analog Demodulation measurement.

Useful commands related to MSRA mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]MSRA:CAPTure:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Configuring an Analysis Interval and Line (MSRT mode only)

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRT mode only)
Configuring an Analysis Interval and Line (MSRT mode only)

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

For the Analog Demodulation application, the commands to define tha analysis interval are the same as those used to define the actual data acquisition (see "Configuring Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the Analog Demodulation measurement.

Useful commands related to MSRT mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]RTMS:CAPTure:OFFSet

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Analyzing Results > Configuring an Analysis Interval and Line (MSRT mode only) > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Importing and Exporting I/Q Data and Results

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Importing and Exporting I/Q Data and Results
Importing and Exporting I/Q Data and Results

The I/Q data to be evaluated in the Analog Demodulation application can not only be measured by the Analog Demodulation application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the Analog Demodulation application can be exported for further analysis in external applications.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

List of Commands
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe


MMEMory:LOAD:IQ:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Importing and Exporting I/Q Data and Results > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe 1,<FileName>

This command restores I/Q data from a file.

Parameters:
<FileName> | String containing the path and name of the source file.
Example: | Loads IQ data from the specified file.
Usage: | Setting only


MMEMory:STORe:IQ:COMMent

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:COMMent <Comment>

This command adds a comment to a file that contains I/Q data.

Parameters:
<Comment> | String containing the comment.
Example: | MMEM:STOR:IQ:COMM 'Device test 1b' Creates a description for the export file. MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores I/Q data and the comment to the specified file.


MMEMory:STORe:IQ:STATe

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.


Commands for Compatibility

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote control programs use the specified alternative commands.

List of Commands
CALCulate<n>:FEED


CALCulate<n>:FEED

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <Evaluation>

This command selects the evaluation method of the measured data that is to be displayed in the specified window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<Evaluation> | Type of evaluation you want to display. See the table below for available parameter values.
Example: | INST:SEL ADEM Activates analog demodulator. CALC:FEED 'XTIM:FM' Selects the display of the FM signal.
<Evaluation> parameter values for the AnalogDemod application
Parameter | Evaluation
'XTIM:AM:RELative' | AM Time Domain
'XTIM:AM:RELative:AFSPectrum' | AM Spectrum
'XTIM:FM' | FM Time Domain
'XTIM:FM:AFSPectrum' | FM Spectrum
'XTIM:PM' | PM Time Domain
'XTIM:PM:AFSPectrum' | PM Spectrum
'XTIM:SPECtrum' | RF Spectrum
'XTIM:AM' 'XTIM:RFPower' | RF Time Domain (= RF power)
'XTIM:AMSummary' 'XTIM:AMSummary:RELative' 'XTIM:FMSummary' 'XTIM:FMSummary:RELative' 'XTIM:PMSummary' 'XTIM:PMSummary:RELative' 'XTIM:SUMMary' | Result summary


Programming Example

Analog Demodulation (R&S FSW-K7) > Remote Commands for Analog Demodulation Measurements > Programming Example
Programming Example

In this example we will configure and perform an analog demodulation measurement to demonstrate the remote control commands.

Signal generator settings (e.g. R&S SMU):
Frequency: | 500 MHz
Level: | -10 dBm
Modulation: | FM
Modulation frequency: | 10 kHz
Frequency deviation: | 50 kHz
//-----------Preparing the measurement ------------

*RST
//Reset the instrument
FREQ:CENT 500 MHz
//Set the center frequency to 500 MHz
DISP:TRAC:Y:SCAL:RLEV 0
//Set the reference level to 0 dBm

//---------- Activating an Analog Demod measurement channel -----------

INST:CRE:NEW ADEM,'FMDemodulation'
//Activate an Analog Demodulation measurement channel named "FMDemodulation"

//--------- Configuring data acquisition ------------------

ADEM:MTIM 1ms
//Set the measurement time to 1 ms (=10 periods)
SENS:ADJ:SCAL:Y:AUTO ON
//Optimize the scaling of the y-axis for the current measurement (continuously)
BAND:DEM 400 kHz
//Set the demodulation bandwidth to 400 kHz
TRIG:SOUR FM
//Use (offline) FM trigger
TRIG:LEV:FM 500MHz
//Trigger when signal reaches 500 MHz

//----------- Configuring the result display --------------------

LAY:ADD:WIND? '1',BEL,'XTIM:FM:AFSP'
//Add an FM Spectrum result display below FM Time Domain
ADEM:FM:AFSP WRIT,AVER,OFF,OFF,OFF,OFF
//Defines two traces in the FM Spectrum: 1: Clear/write, 2: average
ADEM:SET 8MHz,32000,FM,POS,-500,30
//Set analog demodulator to execute 30 sweeps with 32000 samples each
//at a sample rate of 8 MHz; use FM trigger, trigger on positive slope
//with a pretrigger offset of 500 samples

//--------------Performing the Measurement-----

INIT:CONT OFF
//Stop continuous sweep
INIT;*WAI
//Start a new measurement with 30 sweeps and wait for the end

//---------------Retrieving Results-------------

CALC:MARK:FUNC:ADEM:CARR?
//Queries the carrier power
//Result: -10.37 [dBm]
CALC2:MARK:FUNC:ADEM:SIN:RES?
//Queries the signal-to-noise-and-distortion ratio from the FM Spectrum
//Result: 65.026 [dB]
CALC2:MARK:FUNC:ADEM:THD:RES?
//Queries the total harmonic distortion of the demodulated signal
//from the FM Spectrum
//Result: -66.413 [dB]
CALC:MARK:FUNC:ADEM:FERR?
//Queries the FM carrier offset (=frequency error) for the most recent
//measurement (trace 1)
//Result: 649.07 [Hz]
ADEM:FM:OFFS? AVER
//Queries FM carrier offset averaged over 30 measurements
//Result: 600 [Hz]
TRAC:DATA? TRACE1
//Retrieve the trace data of the most recent measurement (trace 1)
//Result: -1.201362252,-1.173495054,-1.187217355,-1.186594367,-1.171583891,
//-1.188250422,-1.204138160,-1.181404829,-1.186317205,-1.197872400, [...]
TRAC:DATA? TRACE2
//Retrieve the averaged trace data for all 30 measurements (trace 2)
//Result: -1.201362252,-1.173495054,-1.187217355,-1.186594367,-1.171583891,
//-1.188250422,-1.204138160,-1.181404829,-1.186317205,-1.197872400, [...]


Reference

Analog Demodulation (R&S FSW-K7) > Reference
Reference
Contents
  • Predefined Standards and Settings


Predefined Standards and Settings

Analog Demodulation (R&S FSW-K7) > Reference > Predefined Standards and Settings
Predefined Standards and Settings

You can configure the Analog Demodulation application using predefined standard settings. This allows for quick and easy configuration for commonly performed measurements.

For details see "Configuration According to Digital Standards".

Provided standard files

The instrument comes prepared with the following standard settings:

  • AM Broadcast
  • FM Narrowband
  • FM Broadcast
  • Frequency Settling
  • None (default settings)

The default storage location for the settings files is: C:/FSW/user/predefined/AdemodPredefined.

Predefined settings

The following parameters can be stored in a standard settings file. Any parameters that are not included in the xml file are set to their default values when the standard is loaded.

Measurement settings:
  • DBW
  • AQT
  • Demod Filter
  • Sweep Points
  • Squelch (State, Level)
  • Units (Phase, THD)
  • RF Span
Window display settings:
  • Position
  • State
  • Window number
  • Window type (all evaluation methods supported by the Analog Demodulation application; see "Measurements and Result Displays")
  • Scaling (Ref Position, Dev per Division)
  • Time Domain Zoom (State, Start, Length)
AF specific settings:
  • AF Center
  • AF Span
  • AF Filters (Lowpass, Highpass, Deemphasis, Weighting)
  • Scaling for Spectrum (Ref Value, Deviation)
  • Scaling for Time Domain (Ref Value, AF Coupling (FM/PM only))
List of predefined standards and settings
Setting | AM Broadcast | FM Narrowband | FM Broadcast | Frequency Settling *) | None (Default)
Demod. bandwidth | 100 kHz | 100 kHz | 400 kHz | 5 MHz | 5 MHz
Aquisition time | 100 ms | 100 ms | 100 ms | 10 ms | 62.5 μs
Input coupling | AC | AC | AC |  | AC
Squelch level |  |  |  | -30 dBm | -20 dBm
Windows | RF Spectrum AM Time Domain AM Spectrum Result Summary | RF Spectrum FM Time Domain FM Spectrum Result Summary | RF Spectrum FM Time Domain FM Spectrum Result Summary | FM Time Domain RF Time Domain | FM Time Domain Result Summary
AF filter - Highpass | 20 kHz | 50 Hz |  |  | -
AF filter - Lowpass | 15 kHz | 3 kHz | 150 kHz |  | -
RF Spectrum
Span | 50 kHz | 25 kHz | 400 kHz |  |
AM/FM Time Domain
Time domain zoom | 10 ms | 10 ms | 10 ms |  | -
Dev per division |  | 1 kHz | 20 kHz | 100 kHz | 50 kHz
AM/FM Spectrum
Start freq. | 0 Hz | 0 Hz | 0 Hz |  |
Stop freq. | 15 kHz | 5 kHz | 63.33 kHz |  |
Ref. value |  | 5 kHz | 75 kHz |  |
*) The Frequency Settling scenario requires a manually defined trigger


List of Remote Commands (AnalogDemod)

Analog Demodulation (R&S FSW-K7) > List of Remote Commands (AnalogDemod)
List of Remote Commands (AnalogDemod)
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:]ADEMod:AF:CENTer
[SENSe:]ADEMod:AF:SPAN
[SENSe:]ADEMod:AF:SPAN:FULL
[SENSe:]ADEMod:AF:STARt
[SENSe:]ADEMod:AF:STOP
[SENSe:]ADEMod:AM:RELative:AFSPectrum:RESult?
[SENSe:]ADEMod:AM:RELative:AFSPectrum[:TYPE]
[SENSe:]ADEMod:AM:RELative[:TDOMain]:RESult?
[SENSe:]ADEMod:AM:RELative[:TDOMain][:TYPE]
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain]:RESult?
[SENSe:]ADEMod:AM[:ABSolute][:TDOMain][:TYPE]
[SENSe:]ADEMod:FM:AFSPectrum:RESult?
[SENSe:]ADEMod:FM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:FM:OFFSet?
[SENSe:]ADEMod:FM[:TDOMain]:RESult?
[SENSe:]ADEMod:FM[:TDOMain][:TYPE]
[SENSe:]ADEMod:MTIMe
[SENSe:]ADEMod:PM:AFSPectrum:RESult?
[SENSe:]ADEMod:PM:AFSPectrum[:TYPE]
[SENSe:]ADEMod:PM:RPOint[:X]
[SENSe:]ADEMod:PM:RPOint[:X]
[SENSe:]ADEMod:PM[:TDOMain]:RESult?
[SENSe:]ADEMod:PM[:TDOMain][:TYPE]
[SENSe:]ADEMod:PRESet:RESTore
[SENSe:]ADEMod:PRESet:STORe
[SENSe:]ADEMod:PRESet[:STANdard]
[SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:SET
[SENSe:]ADEMod:SPEC:SPAN:ZOOM
[SENSe:]ADEMod:SPECtrum:BANDwidth|BWIDth[:RESolution]
[SENSe:]ADEMod:SPECtrum:RESult?
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]
[SENSe:]ADEMod:SPECtrum[:TYPE]
[SENSe:]ADEMod:SQUelch:LEVel
[SENSe:]ADEMod:SQUelch[:STATe]
[SENSe:]ADEMod:SRATe?
[SENSe:]ADEMod<n>:AF:COUPling
[SENSe:]ADEMod<n>:ZOOM:LENGth
[SENSe:]ADEMod<n>:ZOOM:LENGth:MODE
[SENSe:]ADEMod<n>:ZOOM:STARt
[SENSe:]ADEMod<n>:ZOOM[:STATe]
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]ADJust:SCALe:Y:AUTO[:CONTinuous]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]BANDwidth|BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection[:STATe]
[SENSe:]FILTer<n>:AOFF
[SENSe:]FILTer<n>:AWEighted[:STATe]
[SENSe:]FILTer<n>:CCIR:[:UNWeighted][:STATe]
[SENSe:]FILTer<n>:CCIR:WEIGhted[:STATe]
[SENSe:]FILTer<n>:CCIT
[SENSe:]FILTer<n>:DEMPhasis:TCONstant
[SENSe:]FILTer<n>:DEMPhasis[:STATe]
[SENSe:]FILTer<n>:HPASs:FREQuency:MANual
[SENSe:]FILTer<n>:HPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:HPASs[:STATe]
[SENSe:]FILTer<n>:LPASs:FREQuency:MANual
[SENSe:]FILTer<n>:LPASs:FREQuency:RELative
[SENSe:]FILTer<n>:LPASs:FREQuency[:ABSolute]
[SENSe:]FILTer<n>:LPASs[:STATe]
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:POINts
ABORt
CALCulate:MARKer:FUNCtion:ADEMod:AM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:CARRier[:RESult]?
CALCulate:MARKer:FUNCtion:ADEMod:FERRor[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:FM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:ADEMod:PM[:RESult<t>]?
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate:MARKer:X:SSIZe
CALCulate:MARKer<m>:LINK
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:FEED
CALCulate<n>:MARKer:FUNCtion:ADEMod:AFRequency[:RESult]?
CALCulate<n>:MARKer:FUNCtion:ADEMod:SINad:RESult<t>?
CALCulate<n>:MARKer:FUNCtion:ADEMod:THD:RESult<t>?
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:UNIT:POWer
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CALibration:PMETer<p>:ZERO:AUTO ONCE
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:SELect
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
FETCh:PMETer<p>?
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe
OUTPut:ADEMod[:ONLine]:AF[:CFRequency]
OUTPut:ADEMod[:ONLine]:PHONes
OUTPut:ADEMod[:ONLine]:SOURce
OUTPut:ADEMod[:ONLine][:STATe]
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
READ:PMETer<p>?
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe<n>[:DATA]
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:AM:RELative
TRIGger[:SEQuence]:LEVel:AM[:ABSolute]
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:FM
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:PM
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval
UNIT:ANGLe
UNIT:THD
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio


Legal Notice

R&S®FSW-K7
Analog Demodulation Measurement Option

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.